РУКОВОДСТВО АДМИНИСТРАТОРА (сетевой вариант)

© Информационно-аналитический центр "ЛИГА",

ООО "ЛИГА ЗАКОН", 2014
04112, г. Киев, ул. Т. Шамрыло, 23
тел. (044) 538-01-03
e-mail: sales@ligazakon.ua
http://www.ligazakon.ua

РУКОВОДСТВО АДМИНИСТРАТОРА

сетевой вариант

Системы информационно-правового обеспечения

ЛІГА:ЗАКОН

ИНСТАЛЛЯЦИЯ И ЗАПУСК СИСТЕМЫ

АДМИНИСТРИРОВАНИЕ СИСТЕМЫ

СПОСОБЫ ПОЛУЧЕНИЯ ОБНОВЛЕНИЙ ЭЛЕКТРОННЫМИ СРЕДСТВАМИ

ОБНОВЛЕНИЕ СИСТЕМЫ С ПОМОЩЬЮ DVD-ДИСКА

УДАЛЕННЫЙ ДОСТУП

ДОПОЛНИТЕЛЬНЫЕ ЗАДАЧИ


1. ИНСТАЛЛЯЦИЯ И ЗАПУСК СИСТЕМЫ

1.1. Концепция работы сетевого варианта системы ЛЗ

Сетевой вариант системы ЛЗ обеспечивает функционирование системы в многопользовательском режиме в локальной сети. При этом на одном из компьютеров Вашей локальной сети (желательно самом мощном) устанавливается Сервер системы, а на рабочих местах пользователей устанавливаются программные оболочки Клиентов системы. Кроме того, в локальной сети должна быть установлена программная оболочка Администратора системы ЛЗ, обеспечивающая обслуживание базы данных. Исходя из этого, процесс установки системы разделяется на инсталляцию Сервера и программных оболочек Клиентов и Администратора системы.

Система ЛЗ построена по технологии КЛИЕНТ-СЕРВЕР. Эта технология предполагает, что программы-клиенты посылают запросы программе-серверу, которая обрабатывает их и возвращает программам-клиентам результаты выполнения запросов. Таким образом, существенно снижается загрузка локальной сети и требования к компьютерам, на которых функционируют программы-клиенты. Однако компьютеру, на котором устанавливается программа-сервер, предъявляются повышенные требования по производительности, так как он должен обеспечивать одновременное исполнение запросов многих клиентов (см. п. 2.1 этого Раздела).

Сервер системы ЛЗ (далее - Сервер) работает по протоколам TCP/IP и IPX/SPX в редакции Microsoft. Вы можете настроить Сервер для работы по какому-либо одному выбранному протоколу или для работы по двум протоколам одновременно. Второй вариант необходимо использовать в том случае, когда рабочие станции локальной сети работают по разным протоколам. Перед установкой системы убедитесь, что указанные протоколы установлены и правильно функционируют в Вашей локальной сети (см. п. 2.2 этого Раздела).

Клиент системы ЛЗ (далее - Клиент), со своей стороны, устанавливается на прослушивание того протокола, по которому он работает с Сервером. Клиент посылает запрос к Серверу, затем закрывает соединение и ждет ответа со стороны Сервера. Такая схема позволяет минимизировать количество одновременно открытых сетевых соединений к Серверу.

Автоматическая настройка сетевых параметров в системе ЛЗ может осуществляться двумя способами:

Первый (и самый надежный) способ — использование INF-файла, который генерируется при каждом изменении сетевых настроек Сервера. В INF-файле содержатся параметры протоколов, по которым в данный момент работает Сервер. Клиент запрашивает эти параметры и согласует их с сетевыми настройками того компьютера, на котором он запускается.

Если у Клиента настроены оба сетевых протокола и Сервер работает по двум протоколам одновременно, то приоритет отдается протоколу TCP/IP.

Второй способ состоит в использовании т. н. MailSlot (почтовый слот Windows), по которому Windows находит компьютеры в Сетевом Окружении (Network Neighborhood). MailSlot-запросы независимы от типа установленного протокола (TCP/IP или IPX/SPX). Однако, этот способ может не работать в сложных многосегментных сетях.

1.2. Требования к техническим средствам и операционной среде

1.2.1. Обязательные общие требования

Для бесперебойной работы системы необходимо обеспечить отсутствие программных "вирусов" на компьютере пользователя, а также правильную настройку антивирусных программ (антивирусные программы могут конфликтовать с другими программами, в том числе и с системой ЛЗ). Тексты в базе данных хранятся и передаются в заархивированном виде, поэтому необходимо настроить резидентные антивирусные программы таким образом, чтобы они “не видели” файлов системы. Во время работы с протоколом Microsoft TCP/IP не гарантируется стабильная работа системы ЛЗ при использовании DHCP с динамическим адресом на компьютере, где установлен Сервер системы ЛЗ.

Для эффективной работы с системой и выполнения экспорта документов в собственные базы данных обязательно наличие текстовых редакторов Microsoft Office. Рекомендуется использование Microsoft Word версии 2003 и выше. Если Вы используете Microsoft Word версии 97, необходимо дополнительно установить встроенные конверторы, позволяющие сохранять файлы в формате HTML.

Сетевой вариант системы ЛЗ работает в сетевых окружениях с использованием сетевых протоколов TCP/IP или IPX/SPX в редакции Microsoft, скорость передачи данных в локальной сети должна быть не ниже 10 Мб/сек.

Не поддерживается работа с операционными системами, которые не указаны в технических требованиях, а так же не гарантируется стабильная работа системы на виртуальном программном обеспечении.

Возможна установка и работа системы ЛЗ на МАС OS с использованием программы виртуализации Parallels Desktop 9 (проверялась виртуализация на версии OS X 10.8).

Рекомендации: При входе в виртуальную ОС после режима «Приостановки» или спящего режима для МАС OS, необходимо чтобы наш ключ защиты находился в порту USB (если установлен сервер или же перед завершением работы не закрывали систему ЛЗ).

Электронный ключ защиты от несанкционированного доступа должен физически находиться на том компьютере, где установлена система ЛЗ. Возможно использование концентраторов Digi (тестировались модели AnywhereUSB/14 with Multi-Host Connections, AnywhereUSB/2).

Для успешной установки и работы системы ЛЗ, необходимо поставить перед инсталляцией в региональных настройках операционной системы "язык для программ, не поддерживающих Юникод" русский или украинский.

Не гарантируется стабильная работа системы ЛЗ, если на компьютере на один и тот же порт подключены электронный ключ защиты системы и "облегченный" принтер (не имеющий своей памяти, процессора - например, Canon LBP 800, OkiPage 4W).

На компьютерах клиентов с ограниченными правами и с неустановленным пакетом обновления Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package MFC Security Update (KB2538243) необходимо его установить перед инсталляцией Клиента системы ЛІГА:ЗАКОН. Этот пакет обновления присутствует на инсталляционном диске в папке Install\dotNet\Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package MFC Security Update\vcredist_x86.exe.

Для успешной работы системы ЛЗ необходимо, чтобы на компьютере был установлен FrameWork 3.5.

Для корректной работы удаленного клиента системы ЛЗ необходимо разрешить процессу liga.exe подключение к соответствующему удаленному (находящемуся в сети Internet) серверу ЛЗ по протоколу TCP, порт 30583.

Для работы Системы VERDICTUM необходим доступ в Интернет по протоколу https (порт 443) на: cacp.ligazakon.net, update.cacp.ligazakon.net, help.cacp.ligazakon.net.

Примечание

Для корректного отображения в системе ЛЗ кириллических шрифтов необходимо иметь English International версию операционных систем Microsoft Windows с проинсталлированными кириллическими системными шрифтами, или русскую, или украинскую версию этих операционных систем.

Требования к свободному месту на жестком диске для

инсталляции системы ЛЗ:

· ЛЗ БУХГАЛТЕР

До инсталляции на диске должно быть 6 ГБ несжатого свободного места.

Для нормальной работы системы ЛЗ на диске постоянно должно быть не менее 1,5 ГБ свободного места.

На время выполнения задачи «Оптимизация базы» дополнительно 2,5 ГБ.

На время выполнения задачи «Восстановление полнотекстового индекса» дополнительно 4,5 ГБ.

Для резервной копии дополнительно 5,5 ГБ. Резервную копию рекомендуется сохранять на внешний носитель (флешку).

· ЛЗ ПРЕДПРИЯТИЕ
· ЛЗ ЮРИСТ

До инсталляции на диске должно быть 15,5 ГБ несжатого свободного места.

Для нормальной работы системы ЛЗ на диске постоянно должно быть не менее 2 ГБ свободного места.

На время выполнения задачи «Оптимизация базы» дополнительно 6,5 ГБ.

На время выполнения задачи «Восстановление полнотекстового индекса» дополнительно 7,5 ГБ.

Для резервной копии дополнительно 15 ГБ. Резервную копию рекомендуется сохранять на внешний носитель (флешку).

Если система инсталлируется на тот же раздел, где расположен файл подкачки операционной системы, то в расчетах свободного места необходимо учитывать его максимальный размер. Как правило, он в полтора раза больше объема оперативной памяти, установленной в компьютере.

Объем свободного места на жестком диске постоянно уменьшается в связи с ростом баз данных после приема новых поступлений, которые ежедневно готовятся в компании "ЛИГА:ЗАКОН" (например, 1,6 млн документов будут занимать 25 Гб, 2,5 млн - 37 Гб). Мы рекомендуем Вам учитывать этот факт при выборе диска как для инсталляции системы, так и в период ее эксплуатации.

Примечание

Посмотреть, сжат диск или нет, можно в проводнике Windows, щелкнув правой кнопкой мыши на иконке диска, и выбрав пункт меню “Свойства“(“Properties”). Если на закладке “Общие“(“General”) имеется строка “Сжимать диск для экономии места“(“Compress drive to save disk space”) и возле нее стоит отметка, то диск сжат. Отсутствие метки или самой строки означает, что диск не сжат.

Конфигурация компьютера, на который

устанавливается СЕРВЕР системы ЛЗ

Операционная система

· Windows ХР SP3,
· Windows 2003 Server SP2,
· Windows Vista SP2,
· Windows 7 SP1,
· Windows 8,
· Windows Server 2008 SP2

Файловая система - NTFS

Тип процессора

· при сетевом варианте до 9 подключений:
Core™2 Duo 1.80 GHz (рекомендуется Intel Core™2 Duo или двухядерный Intel® Xeon® 3 GHz, Intel Core™ i3-530)
· для варианта 10-50 рабочих мест:
Core™2 Duo или двухядерный Intel® Xeon® 3 GHz, Intel Core™ i3-530 (рекомендуется Intel Core™2 Quad или 4-ядерный Intel® Xeon® 3 GHz, Intel Core™ i5-750)

Оперативная память

· при сетевом варианте до 9 подключений:
XP, 2003 – 1 ГБ (рекомендуется 1,2 ГБ)
Vista, 2008, 7, 8 – 1,2 ГБ (рекомендуется 1,5 ГБ)
· для варианта 10-50 рабочих мест:
XP, 2003 – 1,5 ГБ (рекомендуется 2 ГБ)
Vista, 2008, 7, 8 – 2 ГБ (рекомендуется 3 ГБ)

Жесткий диск - SATA (рекомендуется SAS, Ultra-320 SCSI, SSD).

При сетевом варианте более 50 рабочих мест - необходима консультация специалиста компании "ЛИГА:ЗАКОН".

При работе СЕРВЕР резервирует до 1 МБ оперативной памяти на каждого Клиента.

Сервер должен иметь постоянный IP-адрес.

Конфигурация компьютера, на который

устанавливается КЛИЕНТ или АДМИНИСТРАТОР системы ЛЗ

Операционная система

· Windows ХР SP3,
· Windows Vista SP2,
· Windows 7 SP1,
· Windows 8

Тип процессора

· Intel Pentium III 1 ГГц и выше

Оперативная память

· Windows XP - 512 МБ и выше,
· Windows Vista, Windows 7, 8 - 1 ГБ и выше

Оперативная память для Системы VERDICTUM

· XP - 1 ГБ (рекомендуется 1,5 ГБ),
· Vista, 7, 8 - 1,5 ГБ (рекомендуется 2 ГБ).

Разрешение экрана - 1280*800 и выше

Поддерживается работа Клиента, Сервера и Администратора системы ЛЗ в 64-х разрядных версиях перечисленных выше ОС в режиме совместимости. При этом процессор должен поддерживать установку 64-разрядной ОС, объем оперативной памяти должен быть примерно вдвое, а производительность процессора - примерно в полтора раза выше, чем указано выше для 32-разрядной версии соответствующей ОС.

1.2.2. Требования к сетевым протоколам

Сетевой вариант системы ЛЗ работает в различных сетевых средах и использует только транспортные протоколы TCP/IP и IPX/SPX в редакции Microsoft. При использовании других протоколов сетевая версия системы ЛЗ работать не будет. Должен использоваться WinSock 2.0 производства Microsoft.

Внимание!

1. Если в Вашей локальной сети используется сервер DHCP (Dynamic Host Configure Protocol) для динамического назначения IP-адресов, то для устойчивой работы системы ЛЗ необходимо назначить фиксированный IP-адрес компьютеру, на котором будет установлен Cервер системы.

2. Программа-сервер системы и файлы данных должны быть установлены на одном логическом диске компьютера.

1.2.3. Проверка наличия протоколов TCP/IP и IPX/SPX

· Для Windows XP/2003 (TCP/IP)

Пуск -> Панель управления -> Сетевые подключения -> Подключение по локальной сети.

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Компоненты, используемые этим подключением" должна стоять галочка возле пункта "Протокол интернета (TCP/IP)".

· Для Windows XP /2003 (IPX/SPX)

Пуск -> Панель управления -> Сетевые подключения -> Подключение по локальной сети.

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Компоненты, используемые этим подключением" должен присутствовать пункт "NWLink IPX/SPX-совместимый транспортный протокол" и должна стоять галочка возле этого пункта.

· Для Windows Vista (TCP/IP)

Пуск -> Панель управления -> Центр управления сетями и общим доступом.

На левой панели выбрать раздел "Управление сетевыми подключениями".

Дважды щелкнуть по ярлыку "Подключение по локальной сети".

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Отмеченные компоненты используются этим подключением" должна стоять галочка возле пункта "Протокол интернета версии 4 (TCP/IPv4)".

· Для Windows Vista (IPX/SPX)

Не поддерживается данной операционной системой.

· Для Windows 7 (TCP/IP)

Пуск -> Панель управления -> Центр управления сетями и общим доступом.

На левой панели выбрать раздел "Изменения параметров адаптера".

Дважды щелкнуть по ярлыку "Подключение по локальной сети".

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Отмеченные компоненты используются этим подключением" должна стоять галочка возле пункта "Протокол интернета версии 4 (TCP/IPv4)".

· Для Windows 7 (IPX/SPX)

Не поддерживается данной операционной системой.

· Для Windows Server 2008 (R2) (TCP/IP)

Пуск -> Панель управления -> Центр управления сетями и общим доступом.

На левой панели выбрать раздел "Изменения параметров адаптера".

Дважды щелкнуть по ярлыку "Подключение по локальной сети".

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Отмеченные компоненты используются этим подключением" должна стоять галочка возле пункта "Протокол интернета версии 4 (TCP/IPv4)".

· Для Windows Server 2008 (R2) (IPX/SPX)

Не поддерживается данной операционной системой

1.2.4. Установка протоколов TCP/IP и IPX/SPX

· Для Windows XP/2003 (TCP/IP)

Пуск -> Панель управления -> Сетевые подключения -> Подключение по локальной сети.

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Компоненты, используемые этим подключением" поставьте галочку возле пункта "Протокол интернета (TCP/IP)".

Далее следуйте инструкциям Windows.

· Для Windows XP /2003 (IPX/SPX)

Пуск -> Панель управления -> Сетевые подключения -> Подключение по локальной сети.

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Компоненты, используемые этим подключением" нажать кнопку "Установить" -> Протокол -> NWLink IPX/SPX-совместимый транспортный протокол.

Далее следуйте инструкциям Windows.

· Для Windows Vista (TCP/IP)

Пуск -> Панель управления -> Центр управления сетями и общим доступом.

На левой панели выбрать раздел "Управление сетевыми подключениями".

Дважды щелкнуть по ярлыку "Подключение по локальной сети".

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Отмеченные компоненты используются этим подключением" поставьте галочку возле пункта "Протокол интернета версии 4 (TCP/IPv4)".

Далее следуйте инструкциям Windows.

· Для Windows Vista (IPX/SPX)

Не поддерживается данной операционной системой.

· Для Windows 7 (TCP/IP)

Пуск -> Панель управления -> Центр управления сетями и общим доступом.

На левой панели выбрать раздел "Изменения параметров адаптера".

Дважды щелкнуть по ярлыку "Подключение по локальной сети".

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Отмеченные компоненты используются этим подключением" поставьте галочку возле пункта "Протокол интернета версии 4 (TCP/IPv4)".

Далее следуйте инструкциям Windows.

· Для Windows 7 (IPX/SPX)

Не поддерживается данной операционной системой.

· Для Windows Server 2008 (R2) (TCP/IP)

Пуск -> Панель управления -> Центр управления сетями и общим доступом.

На левой панели выбрать раздел "Изменения параметров адаптера".

Дважды щелкнуть по ярлыку "Подключение по локальной сети".

На закладке "Общие" нажать кнопку "Свойства".

В разделе "Отмеченные компоненты используются этим подключением" поставьте галочку возле пункта "Протокол интернета версии 4 (TCP/IPv4)".

Далее следуйте инструкциям Windows.

· Для Windows Server 2008 (R2) (IPX/SPX)

Не поддерживается данной операционной системой

Внимание!

Параметры протокола TCP/IP (IP-адрес, маску подсети, основной шлюз, адрес DNS-сервера и т. д.) необходимо узнать у системного дминистратора Вашей локальной сети.

Примечание

Технические требования к системам ЛЗ могут изменяться. Актуальные технические требования и другая необходимая информация доступна на http://support.ligazakon.ua.

1.3. Инсталляция системы

Сетевой вариант системы ЛЗ предназначен для одновременной работы нескольких пользователей с одной базой данных системы ЛЗ. Информация о варианте установки содержится в ключевом файле ХXXXX.USR (где XXXХX - регистрационный номер лицензионного пакета системы), который находится на инсталляционном диске в каталоге KeyFiles.

При установке системы инсталляционная программа спросит Вас о местоположении этого файла, после чего процесс инсталляции продолжится в соответствии с приобретенным Вами вариантом системы.

В системе реализованы два типа установки: стандартная и пользовательская. В начале установки программа определяет, есть ли все необходимые условия для стандартной установки, и в этом случае предлагает пользователю выбрать тип установки. Если необходимых условий для стандартной установки недостаточно, то программа проводит пользовательскую (полную) установку, все этапы которой подробно описаны ниже. Выбор стандартной установки дает возможность значительно сократить процесс подготовки к установке.

Внимание!

1. Перед началом инсталляции системы желательно завершить все другие приложения, работающие на Вашем компьютере, для снижения нагрузки на Ваш компьютер и во избежание потери несохраненных данных.
2. Электронный ключ защиты, который имеется в комплекте поставки системы, для инсталляции системы не требуется. Однако не забудьте подключить его к соответствующему порту Вашего компьютера перед первым запуском системы ЛЗ.

Для проведения инсталляции системы ЛЗ используется специальная программа Autorun.exe, которая позволит Вам последовательно пройти все шаги, необходимые для определения основных параметров системы.

Программу Autorun.exe можно запускать не только с фирменных DVD-дисков, но и с винчестера, и даже с сетевого ресурса, предварительно скопировав туда содержимое инсталляционного диска, каждого в отдельную директорию.

Запуск инсталляционной программы необходимо производить от имени пользователя, который является членом группы Администраторы на данном компьютере.

Инсталляция системы ЛЗ, поставляемая на фирменном DVD-диске, позволяет установить систему “с нуля”, переустановить систему заново, переустановить с существующими параметрами или обновить только ее программную часть.

Вначале мы рассмотрим вариант инсталляции системы “с нуля”. Остальные возможности программы инсталляции будут рассмотрены в Разделе 4 данного руководства.

Если Ваша операционная система поддерживает автозапуск с DVD-дисков, то при установке диска в Ваш DVD-ROM на экране появится меню. Для начала инсталляции выберите пункт “ЗАПУСК” (рис. 1.1).

Рис. 1.1. Меню DVD-диска

Если же опция автозапуска отключена, то Вам необходимо совершить действия, показанные на рис.1.2:

1. Нажать кнопку Start (Пуск) панели задач Windows.
2. Выполнить команду Run (Выполнить).
3. В появившемся окне определить путь к файлу Autorun.exe, который находится на DVD-диске, после чего нажать кнопку OK или перейти к действию 4.
4. Нажать кнопку Browse (Обзор) и в появившемся окне найти и выбрать файл Autorun.exe, после чего нажать кнопку Open (Открыть), в окне 3 нажать кнопку OK.

Рис. 1.2. Запуск файла Autorun.exe с помощью команды Выполнить

Перед началом инсталляции системы желательно завершить все другие приложения, работающие на Вашем компьютере, для снижения нагрузки на компьютер и во избежание потери несохраненных данных.

Электронный ключ защиты, который имеется в комплекте поставки системы, для инсталляции системы не требуется. Однако не забудьте подключить его к LPT-или USB-порту (в зависимости от типа ключа) Вашего компьютера перед первым запуском системы ЛЗ (рис. 1.3).

Рис. 1.3. Схема подключения USB и LPT электронных ключей к соответствующим портам

Внимание!

Системы ЛЗ поставляются на DVD-диске. На диске содержится текстовый файл readme.txt и его гипертекстовая версия index.htm, в которых дана краткая аннотация к диску. Эта же информация доступна из авторана. Файловая структура на DVD-диске показана на рис. 1.4:

DVD-диск | Корневой каталог: файлы с ознакомительной информацией, авторан AutoRun.exe, программы инсталляции, base.exe, base-Na.bin - инсталлятор базы, contens.dst - файл контента дистрибутива, Disk1 – файл-определитель диска
Data | Data - подкаталог с описателями базы В подкаталоге Text_New могут содержаться посылки для пополнения базы.
Doc | "Руководство пользователя" и "Руководство администратора" в электронном виде.
 | ObnovDVD.rtf - инструкция по обновлению системы с помощью DVD-диска. Service_ENTERPRISE.rtf - правила обслуживания системы ЛЗ
Install | Инсталляционные программы для установки Клиента системы Cli_inst.exe и Администратора системы Adm_inst.exe.
 | Специальная инсталляционная программа Cli_inst.msi в папке MSI-install. Используется для дистанционной установки или обновления Клиента системы с помощью групповых политик Active Directory.
 | Инсталляционные программы для установки удаленного Клиента системы Cli_rem.exe и удаленного Администратора системы Adm_rem.exe.
 | LigaInfo.exe - утилита сбора информации об установленной на компьютере пользователя версии системы ЛЗ и ее окружении.
 | LigaSP.exe - сервиспак для обновления версии системы.
 | LM_inst.exe - инсталляционная программа автономной утилиты Liga Mail для автоматической фоновой проверки HTTP-сервера или почтового ящика на наличие новых посылок-обновлений.
 | reg.bat - командный файл, используемый для запуска инсталляции с переносом файлов установленной ранее системы с одного компьютера на другой.
 | wd97vwr32.exe и xlViewer.exe - инсталляционные программы утилит для просмотра MS Word и MS Excel-файлов. Необходимы в случае, если на Вашем компьютере не установлены программы Microsoft Word и Microsoft Excel.
 | Подкаталог Guardant.Drv содержит подкаталоги для Windows 32 и 64 bit с драйверами версии 6.3.112 и grddriversru.msi для установки или удаления драйверов ключа, а так же утилиту GRDEM32.exe для проверки ключей Guardant.
 | Подкаталог dotNet содержит необходимые для установки утилиты Microsoft .NET Framework Version 3.5 Redistributable Package (x86), Microsoft .NET Framework Version 3.5 Redistributable Package (x86) for Windows 8, Microsoft .NET Framework Version 3.5 Redistributable Package (x64) for Windows 8, Runtime Library 9.0, WindowsInstaller31 и хотфикс Windows Windows2000-KB891861-v2-x86-ENU.EXE
KeyFiles | В этом каталоге может быть файл Forall2.usr для обновления даты абонентского обслуживания, который используется во время обновления системы с помощью DVD-диска.

Рис. 1.4. Файловая структура DVD-диска

1.3.1. Инсталляция Сервера системы

Этап 1

Инсталляция системы ЛЗ начинается с выбора языка, который будет использоваться в процессе инсталляции и как язык интерфейса системы (рис. 1.5).

Рис. 1.5. Окно выбора языка интерфейса для инсталляции системы

Выбор русского языка в качестве языка интерфейса означает:

· русские названия пунктов меню, русские информационные сообщения и т. п.;
· поиск документов по русскоязычным реквизитам;
· поиск по ключевым словам на русском языке;
· списки найденных документов на русском языке.

Однако Вы должны учитывать, что тексты документов хранятся в базе на языке оригинала (украинском — нормативные документы украинского законодательства; русском — международные соглашения, конвенции и т. п.). При необходимости Вы можете всегда легко изменить язык интерфейса системы в процессе работы (см. “Руководство пользователя”).

После выбора языка Вам необходимо нажать кнопку ОК, и Вы перейдете к следующему этапу инсталляции. В дальнейшем процесс установки системы рассматривается при выбранном русском языке для инсталляции.

Этап 2

На этом этапе инсталляционная программа предупредит Вас на выбранном Вами языке о необходимости завершения других программ, работающих на Вашем компьютере, а также об ответственности за нелицензионное использование программных продуктов OOO “ЛИГА ЗАКОН” (рис. 1.6).

Рис. 1.6. Окно приветствия

Примечание

После нажатия кнопки Далее> программа определяет, есть ли все необходимые условия для стандартной установки: ключевой файл и файл ParamFTP.txt размещены в каталоге \KeyFiles дистрибутива, протокол TCP\IP установлен в системе, на компьютере присутствует Microsoft .Net Framework версии не ниже 2.0, база в дистрибутиве актуальна и т.п. В этом случае программа установки предлагает пользователю диалоговое окно с выбором типа установки: стандартная либо пользовательская.

При выборе стандартной установки после третьего этапа проводится непосредственно установка, пропуская этапы выбора пользователем параметров установки и работы системы, что дает возможность значительно сократить процесс подготовки к установке. Система устанавливается по стандартному пути, с типовыми настройками связи и обновления. При выборе пользовательской установки будут пройдены все этапы установки, описанные ниже.

Если необходимых условий для стандартной установки недостаточно, то окно выбора типа установки не выводится и программа проводит пользовательскую (полную) установку. Ниже будут описаны все этапы пользовательской установки.

Этап 3

На данном этапе инсталляционная программа предоставит Вашему вниманию лицензионные условия использования системы (рис. 1.7). Для продолжения инсталляции необходимо выбрать пункт "Я принимаю условия соглашения", затем нажать кнопку Далее>. В клиенте системы лицензионные условия можно вызвать, выбрав подпункт Условия лицензионного использования пункта Помощь Главного Меню.

Рис. 1.7. Окно условий лицензионного использования

Этап 4

Следующий этап установки системы ЛЗ связан с выбором пути, по которому будут размещаться программные модули Сервера системы и базы данных системы (рис. 1.8). Если предложенный по умолчанию путь для размещения файлов системы Вас не устраивает, то Вы можете его изменить, воспользовавшись кнопкой Обзор.... После задания пути Вы можете перейти к следующему этапу, щелкнув мышкой кнопку Далее>.

Рис. 1.8. Выбор пути размещения системы

Примечание

1. Для нормальной установки программы должны выполняться требования к свободному месту на жестком диске (см. п. 2.1 данного Раздела). Желательна дефрагментация свободного места перед началом установки. В пункте "Наличие свободного места на дисках" указывается, какой общий объем каждого диска и сколько там свободного места.

2. После установки количество свободного места на диске должно поддерживаться в размере, указанном в окне инсталляции. При установке на один раздел с файлом подкачки операционной системы не забудьте включить в расчеты свободного места максимальный возможный размер этого файла.

3. Общая длина пути размещения системы не должна превышать 260 символов.

Этап 5

На 5-ом этапе инсталляционная программа предложит Вам выбрать имя программной группы, в которой будут размещаться ярлыки (иконки) программ системы ЛЗ (рис. 1.9). Если Вас не устраивает предложенное по умолчанию имя программной группы, то Вы можете либо изменить его, либо выбрать имя существующей программной группы.

Рис. 1.9. Выбор программной группы

Этап 6

На этом этапе программа инсталляции предложит Вам выбрать путь к регистрационной информации (рис. 1.10). По умолчанию ключевые файлы находятся на инсталляционном диске в папке KeyFiles, но если они были переданы Вам отдельно, то Вы можете поменять путь к папке с помощью кнопки Обзор... .

Рис. 1.10. Определение пути к регистрационной информации

Этап 7

Далее инсталляционная программа укажет Вам инсталляционные параметры системы ЛЗ и отобразит Ваши реквизиты:

Рис. 1.11. Инсталляционные параметры системы ЛЗ и Ваши реквизиты

Если показанный Вам вариант конфигурирования системы соответствует конфигурации поставки, предусмотренной в лицензионной карте, то Вы можете перейти к следующему этапу инсталляции, нажав мышкой кнопку Далее>. В противном случае Вам необходимо вернуться к предыдущему этапу, нажав мышкой кнопку Выбрать другой ключ либо кнопку Назад, и выбрать правильный путь к регистрационной информации, содержащейся в соответствующем ключевом файле.

Примечание

Сервер системы, установленный с определенным ключевым файлом, будет работать только с соответствующим ему электронным ключом защиты.

Как правило, ключевой файл ХXXXX.USR находится в каталоге KeyFiles инсталляционного DVD.

Если Вы приобрели несколько лицензий системы ЛЗ, то Вам передадут соответствующее число электронных ключей защиты и к ним - соответствующее число ключевых файлов. При этом каждый из ключевых файлов будет находиться в соответствующем ему каталоге ХХХXХ (имя каталога соответствует номеру электронного ключа). Будьте внимательны при выборе! От этого зависит конфигурация устанавливаемой Вами системы.

Этап 8

На этом этапе инсталляционная программа определит набор сетевых протоколов, установленных на Вашем компьютере, и предложит Вам выбрать те из них, которые будут использоваться системой ЛЗ. Кроме того, на этом же этапе Вы сможете определить режим запуска Сервера системы ЛЗ (рис. 1.12).

Рис. 1.12. Окно определения параметров Сервера системы ЛЗ

Если на Вашем компьютере установлены протоколы TCP/IP и/или IPX/SPX, то Вы можете выбрать либо один из них, либо сразу оба для использования Сервером системы ЛЗ. При выборе обоих протоколов программы-клиенты смогут подключаться к Серверу по любому из них, что может оказаться весьма удобным в сложных гетерогенных сетях.

При выборе протокола TCP/IP Вы должны определить номер порта, который будет использоваться Сервером. В подавляющем большинстве случаев значение, предлагаемое по умолчанию (30583), является приемлемым, однако Вам необходимо убедиться, что никакой другой IP-сервис на Вашем компьютере не использует этот порт. В противном случае возможны конфликты, приводящие к неработоспособности системы ЛЗ и/или соответствующего сервиса. Для справки об используемых на Вашем компьютере номерах IP-портов просмотрите файл SERVICES в каталоге Windows\System32.

При определении режима запуска Сервера системы ЛЗ инсталляционная программа предлагает Вам следующие варианты:

· Запуск в ручном режиме - Вы должны будете запускать Сервер системы “вручную”, используя соответствующий ярлык в программной группе системы ЛЗ.
· Обычная программа - при выборе этого варианта инсталляционная программа регистрирует Сервер системы ЛЗ в операционной системе как программу автоматического запуска (аналог помещения ярлыка программы в группу “Автозагрузка”, или “Startup”). При этом Вы можете задать параметр “АвтоСтарт”, который обеспечивает автоматическую активизацию Сервера при запуске.
· Сервис Windows - этот вариант предполагает регистрацию инсталляционной программой Сервера системы в операционной системе Windows как сервисной (служебной) программы. Если при выборе этого варианта Вы активизируете параметр “АвтоСтарт”, то операционная система будет автоматически загружать и активизировать Сервер каждый раз после перезагрузки Windows. Если при таком режиме запуска Вы попытаетесь загрузить Сервер системы ЛЗ “вручную”, то он запустится только как управляющая программа, поддерживающая связь с сервисом Windows, с помощью которой Вы сможете активизировать или деактивизировать сервис.

Примечание

Параметры Сервера системы ЛЗ, которые определяются на этом этапе инсталляции, Вы всегда сможете изменить, используя режим конфигурирования Сервера (см. п. 4.2 этого Раздела).

Этап 9

На 9-ом этапе инсталляционная программа сообщит Вам, что процесс определения исходных данных для инсталляции завершен (рис. 1.13), и Вы можете переходить к копированию файлов системы на Ваш компьютер с помощью кнопки Установить.

На этом этапе Вы еще можете вернуться к предыдущим этапам для изменения параметров инсталляции, используя кнопку Назад.

Для того, чтобы отказаться от инсталляции системы ЛЗ на Ваш компьютер, нажмите кнопку Отмена.

Рис. 1.13. Начало инсталляции

Примечание

Для работы системы текущей версии необходимо наличие на компьютере пользователя Microsoft .Net Framework версии не ниже 2.0. Установка этой версии фреймворка требует наличие на компьютере пользователя Windows Installer версии не ниже 3.1. Также, в дополнение необходим Microsoft Visual C++ 2008 Redistributable package.

Инсталлятор определяет, установлена ли на компьютере пользователя необходимая версия .Net Framework. В случае, если необходимая версия не обнаружена, при полной инсталляции перед окном, изображенном на рис. 1.13 отображается окно "Установка дополнительных компонент". Чекбоксы компонент, которые необходимо установить, содержат флаг выбора и активны. Если установка компонента не требуется, чекбокс неактивен. По кнопке "Далее" программа производит последовательный запуск инсталляций соответствующих компонент. Только после этого на экран выводится окно о готовности для начала процесса инсталляции, изображенное на рис. 1.13.

Этап 10

После того, как Вы нажмете кнопку Установить, инсталляционная программа начнет копировать файлы системы по указанным Вами путям. Прерывание этого процесса (кнопка Отмена) приведет к завершению инсталляции без установки системы ЛЗ.

В процессе инсталляции Вы можете отключить музыкальное сопровождение, убрав галочку напротив пункта "Звук".

Этап 11

После успешного завершения процесса копирования инсталляционная программа предложит Вам настроить параметры обновления системы ЛЗ (рис. 1.14):

Рис. 1.14. Окно настройки параметров обновления системы

Данный этап можно не осуществлять при инсталляции, для этого нажмите кнопку Пропустить. В таком случае настроить параметры обновления системы можно будет после инсталляции Сервера. Как это сделать, подробно описано в пункте 4.6 данного Раздела.

По умолчанию установлена опция "Интернет". В случае выбора обновления через Интернет производится поиск файла Param_FTP.txt в папке с ключевым файлом. Если такой файл не найден, то предлагается указать путь к этому файлу (рис. 1.15):

Рис. 1.15. Окно выбора пути к файлу Param_FTP.txt

Если файл Param_FTP.txt найден, то открывается окно настройки получения обновлений через Интернет (HTTP-сервер) (рис. 1.16), HTTP-сервер устанавливается как основной способ обновления.

Рис. 1.16. Окно настройки получения обновлений через Интернет (HTTP-сервер)

Поля "Логин" и "Пароль" заполняются из файла Param_FTP.txt. Если файл не был указан, то поля остаются пустыми.

Если выход в глобальную сеть Интернет настроен через proxy-сервер, то настройки proxy-сервера автоматически подставляются из настроек веб-броузера MS Internet Explorer. Логин, пароль, настройки proxy-сервера автоматически переносятся в настройки HTTP-сервера. При нажатии на кнопку Проверить настройки осуществляется проверка соединения с HTTP-сервером и скачивание тестовой посылки.

Если не указаны логин и пароль вручную и нажата кнопка Далее, выдается предупреждение (рис. 1.17).

Рис. 1.17. Окно предупреждения о том, что не указаны логин и пароль

В данном случае для возврата можно нажать кнопку Нет и вручную заполнить необходимые поля.

Если в качестве обновления выбран вариант "DVD/CD-диски", то при нажатии на кнопку Далее> переходим к этапу 12. В соответствии с выбором способа настройки параметров обновления системы ЛЗ автоматически настраивается расписание задач администрирования (см. этап 12).

Этап 12

На данном этапе инсталляционная программа предложит Вам настроить расписание задач администрирования.

Если при инсталляции производилась настройка обновления через HTTP:

При выборе варианта запуска "Ночью" задачи настраиваются следующим образом:

· Групповые задачи - Прием обновлений (Получение обновлений и отправка результатов + ИнформБюро: Прием сообщений) - запуск каждые 120 минут, начальное время 00:30.
· Групповые задачи - Прием и проверка базы (Прием в базу + Проверка библиотек текстов + Общая проверка базы + Эталонная проверка базы) - еженочно в 3:00.
· Групповые задачи - Резервирование (Создание резервной копии + проверка читаемости текстов в библиотеках + Оптимизация базы) - запуск ежемесячно, каждую первую субботу, начальное время 23:00.

При выборе варианта запуска "Днем" задачи настраиваются следующим образом:

· Групповые задачи - Прием обновлений (Получение обновлений и отправка результатов + ИнформБюро: Прием сообщений) - запуск каждые 120 минут, начальное время 00:30.
· Прием в базу - ежедневно в 13:00.
· Общая проверка базы - каждую среду в 16:30.

Рис. 1.18. Окно настройки расписания задач администрирования

Если при инсталляции выбиралось обновление на DVD или этап настройки параметров обновления был пропущен:

При выборе варианта запуска "Ночью" задачи настраиваются следующим образом:

• Общая проверка базы - еженедельно, каждую среду в 6:00

• Проверка читаемости текстов в библиотеках - еженедельно, каждый вторник в 21:00.

При выборе варианта запуска "Днем" задачи настраиваются следующим образом:

• Общая проверка базы - каждая третья среда в 16:30.

После успешного завершения процесса копирования система сообщит Вам об этом и предложит перезагрузить компьютер (рис. 1.19).

После перезагрузки компьютера система ЛЗ будет полностью готова к работе. Система будет функционировать только при подключенном к порту Вашего компьютера электронном ключе защиты.

Рис. 1.19. Окно завершения инсталляции

Примечание

Для предотвращения порчи электронного ключа защиты или выхода из строя LPT-порта Вашего компьютера подключение LPT-ключа необходимо осуществлять к обесточенному компьютеру.

1.3.2. Инсталляция Администратора системы

После установки Сервера системы необходимо установить программную оболочку Администратора, с помощью которой Вы сможете ввести имена и параметры Клиентов системы ЛЗ (как это сделать, описано в п. 4.1 Раздела 2 данного руководства), и только после этого приступать к инсталляции программных оболочек Клиентов.

Для инсталляции Администратора необходимо использовать команду Install LIGA Admin, которая находится в программной группе Liga (название группы могло быть изменено в процессе инсталляции), либо программу Adm_inst.exe, которая находится в подкаталоге INSTALL\ того каталога, в котором установлена система ЛЗ. В этом же каталоге находится файл Setup.inf, который формируется во время инсталляции Сервера системы.

Для инсталляции удаленного Администратора системы используется программа Adm_rem.exe, которая находится на фирменном DVD-диске. Для ее запуска скопируйте указанный файл из каталога INSTALL\ диска в одноименный подкаталог директории Liga, в которой установлена система ЛЗ.

Запуск программы инсталляции Администратора системы ЛІГА:ЗАКОН необходимо производить от имени пользователя, который является членом группы Администраторы на данном компьютере.

Примечание

Администратор системы не обязательно устанавливать на тот же компьютер, на который был установлен Сервер системы.

Этап 1

Инсталляция Администратора системы ЛЗ начинается с выбора языка, который будет использоваться в процессе инсталляции, и языка, используемого для интерфейса системы. Язык диалога при инсталляции может отличаться от языка интерфейса системы. После выбора языка нажмите кнопку ОК, и Вы перейдете к следующему этапу инсталляции. В дальнейшем процесс установки системы рассматривается при выбранном русском языке для инсталляции.

Этап 2

На этом этапе инсталляционная программа предупредит Вас на выбранном Вами языке о необходимости завершения других программ, работающих на Вашем компьютере, а также об ответственности за нелицензионное использование программных продуктов ООО “ЛИГА ЗАКОН” (рис. 1.20).

Рис. 1.20. Добро пожаловать

Этап 3

На этом этапе осуществляется определение параметров соединения Администратора с Сервером системы. Если в том каталоге, откуда была запущена программа установки Администратора, находился файл Setup.inf, то имя компьютера, на котором находится Сервер системы ЛЗ не запрашивается (рис. 1.21).

Рис. 1.21. Этап определения сетевых параметров для Администратора

Если Вы запустили инсталляционную программу из каталога, в котором отсутствует информационный файл Setup.inf, подготовленный при инсталляции Сервера или его переконфигурировании, то Вам придется ввести имя компьютера, на котором установлен Сервер системы ЛЗ (рис. 1.22).

Рис. 1.22. Этап определения сетевых параметров для Администратора (Setup.inf отсутствует)

После того, как Вы укажете требуемые параметры, инсталляционная программа попытается установить связь с Сервером системы ЛЗ и получить от него параметры настройки сетевых протоколов. Если эта попытка закончится успешно, то инсталляционная программа перейдет к этапу 4. В противном случае программа выдаст предупреждающее сообщение (рис. 1.23).

Рис. 1.23. Предупреждение о том, что связь с Сервером не установлена

В этом случае Вы можете попытаться еще раз установить связь с Сервером, нажав кнопку Назад и уточнив имя компьютера, или перейти к следующему этапу инсталляции и продолжить ее без конфигурирования сетевых параметров программной оболочки. Настроить эти параметры Вы сможете позднее, используя программу конфигурации Администратора. Для получения более подробной информации о настройках сетевых параметров смотрите пункты 4.2 и 4.8 этого Раздела.

Примечание

При попытке установить связь с Сервером положительный результат будет получен только при выполнении следующих условий:

1. Сервер системы ЛЗ активизирован на указанном Вами компьютере;

2. Запущен сервис Автоответчик Сервера системы.

Этап 4

Этот этап установки системы ЛЗ связан с выбором пути, по которому будут размещаться программные модули Администратора системы (рис. 1.24).

Если предложенный по умолчанию инсталляционной программой путь для размещения файлов Администратора Вас не устраивает, то Вы можете изменить его, воспользовавшись кнопкой Обзор... . После задания пути Вы можете перейти к следующему этапу, нажав кнопку Далее.

Рис. 1.24. Выбор пути расположения Администратора

Этап 5

На этом этапе инсталляционная программа предложит Вам выбрать имя программной группы, в которой будут размещаться ярлыки (иконки) Администратора системы ЛЗ (рис. 1.25). Если Вас не устраивает предложенное по умолчанию имя программной группы, то Вы можете либо изменить его, либо выбрать имя существующей программной группы. В программной группе с указанным Вами именем будут размещены ярлыки программ: Администратор системы ЛIГА:ЗАКОН (программная оболочка Администратора базы данных), Конфигурация Администратора системы ЛIГА:ЗАКОН (конфигуратор Администратора), Удаление Администратора системы ЛIГА:ЗАКОН (программа деинсталляции Администратора системы ЛЗ), Администратор - Информация о системе ЛIГА:ЗАКОН.

Рис. 1.25. Выбор программной группы

Этап 6

После нажатия Вами кнопки Дальше инсталляционная программа сообщит Вам, что процесс определения исходных данных для инсталляции завершен (рис. 1.26), и Вы можете переходить к копированию файлов системы на Ваш компьютер.

На этом этапе Вы еще можете вернуться к предыдущим этапам для изменения параметров инсталляции.

Рис. 1.26. Начало инсталляции

Этап 7

После того, как Вы нажмете кнопку Далее, инсталляционная программа начнет копировать файлы Администратора системы по указанному Вами пути. Прерывание этого процесса приведет к завершению инсталляции без установки Администратора системы ЛЗ.

Этап 8

По окончании инсталляции система сообщит Вам об успешном завершении процесса копирования файлов (рис. 1.27).

Рис. 1.27. Окно завершения инсталляции

1.3.3. Инсталляция Клиента системы

Для инсталляции Клиента необходимо использовать команду Install LIGA Client, которая находится в программной группе Liga (название группы могло быть изменено в процессе инсталляции), либо программу Cli_inst.exe, которая находится в подкаталоге INSTALL\ того каталога, в котором установлена система ЛЗ). В этом же каталоге находится файл Setup.inf, который формируется во время инсталляции Сервера системы.

Для инсталляции удаленного Клиента системы используется программа Cli_rem.exe, которая находится на фирменном DVD-диске. Для ее запуска скопируйте указанный файл из каталога INSTALL\ диска в одноименный подкаталог (каталог, который был выбран на этапе 10 инсталляции Сервера) директории Liga, в которой установлена система ЛЗ.

Запуск программы инсталляции клиента системы ЛЗ необходимо производить от имени пользователя, который является членом группы Администраторы на данном компьютере.

Этап 1

Инсталляция Клиента системы ЛЗ начинается с выбора языка, который будет использоваться в процессе инсталляции, и языка, используемого для интерфейса системы.

Язык диалога при инсталляции может отличаться от языка интерфейса системы. После выбора языка Вам необходимо нажать кнопку ОК, и Вы перейдете к следующему этапу инсталляции. В дальнейшем процесс установки системы рассматривается при выбранном русском языке для инсталляции.

Примечание

1. Язык диалога при инсталляции может отличаться от языка интерфейса системы.

2. Выбор русского языка в качестве языка интерфейса Клиента означает:

- русские названия пунктов меню, русские информационные

сообщения и т. п.;

- поиск документов по русскоязычным реквизитам;

- поиск по ключевым словам на русском языке;

- списки найденных документов на русском языке.

Однако Вы должны учитывать, что тексты документов хранятся в базе на языке оригинала (украинском - нормативные документы украинского законодательства; русском - международные соглашения, конвенции и т. п.). При необходимости Вы можете всегда легко изменить язык интерфейса системы в процессе работы (см. “Руководство пользователя”, раздел “Дополнительные возможности системы").

Этап 2

На этом этапе инсталляционная программа предупредит Вас на выбранном Вами языке о необходимости завершения других программ, работающих на Вашем компьютере, а также об ответственности за нелицензионное использование программных продуктов ООО “ЛИГА ЗАКОН” (рис. 1.28).

Рис. 1.28. Добро пожаловать

Этап 3

На этом этапе осуществляется определение параметров соединения Клиента с Сервером системы. Если в том каталоге, откуда была запущена программа установки Клиента, находился файл Setup.inf, то программа установки запросит только имя пользователя системы ЛЗ (рис. 1.29). После определения имени Клиента инсталляционная программа переходит к этапу 4.

Рис. 1.29. Запрос имени пользователя

Примечание

На этом этапе можно ввести любое имя Клиента, но прежде чем запустить систему на клиентской машине Вам необходимо обязательно зарегистрировать это имя в системе ЛЗ с помощью Менеджера пользователей в Администраторе (см. п. 4.1 Раздела 2 данного руководства).

Если Вы запустили инсталляционную программу из каталога, в котором отсутствует информационный файл Setup.inf, подготовленный при инсталляции Сервера или его переконфигурировании, то Вам придется дополнительно ввести имя компьютера, на котором установлен Сервер системы ЛЗ (рис. 1.30).

Рис. 1.30. Этап определения сетевых параметров для Клиента (Setup.inf отсутствует)

Программа инсталляции удаленного Клиента системы на данном этапе запросит Интернет-имя или IP-адрес компьютера, на котором установлен Сервер системы ЛЗ с поддержкой удаленных пользователей (рис. 1.31).

Рис. 1.31. Определение параметров доступа для Удаленного клиента

После того, как Вы укажете требуемые параметры, программа установки Клиента попытается установить связь с Сервером системы ЛЗ и получить от него параметры настройки сетевых протоколов. Если эта попытка закончится успешно, то инсталляционная программа перейдет к этапу 4. В противном случае программа выдаст предупреждающее сообщение (рис. 1.32).

Рис. 1.32. Предупреждение о невозможности установить связь с Сервером

В этом случае Вы можете попытаться еще раз установить связь с Сервером, нажав кнопку Назад и уточнив имя компьютера, или перейти к следующему этапу инсталляции и продолжить ее без конфигурирования сетевых параметров программной оболочки. Настроить эти параметры Вы сможете позднее, используя программу конфигурации Клиента. Для более подробной информации о настройкахсетевых параметров смотрите пункты 4.2 “Запуск и настройка Сервера системы” и 4.8 “Запуск и настройка Клиента и Администратора системы”.

Примечание

1. При инсталляции Клиента на этом этапе Вы можете указать произвольное имя Клиента. При получении информации с Сервера о текущих сетевых настройках подключение к нему осуществляется анонимно.

2. При попытке установить связь с Сервером системы ЛЗ положительный результат будет получен только при выполнении следующих условий:

- Сервер системы ЛЗ активизирован на указанном Вами компьютере;

- запущен сервис Автоответчик Сервера системы.

Этап 4

На данном этапе инсталляционная программа предоставит Вашему вниманию лицензионные условия использования системы (рис. 1.33). Для продолжения инсталляции необходимо выбрать пункт "Я принимаю условия соглашения", затем нажать кнопку Далее. В клиенте системы лицензионные условия можно вызвать, выбрав подпункт Условия лицензионного использования пункта Помощь Главного Меню.

Рис. 1.33. Окно условий лицензионного использования

Этап 5

Этот этап установки системы ЛЗ связан с выбором пути, по которому будут размещаться программы клиентской части системы (рис. 1.34).

Если предложенный по умолчанию программой установки путь для размещения модулей Клиента системы ЛЗ Вас не устраивает, то Вы можете изменить его, воспользовавшись кнопкой Обзор... . После задания пути Вы можете перейти к следующему этапу, нажав кнопку Далее.

Рис. 1.34. Выбор размещения Клиента системы

Этап 6

На этом этапе программа установки предложит Вам выбрать имя программной группы, в которой будут размещаться ярлыки (иконки) Клиента системы ЛЗ (рис. 1.35). Если Вас не устраивает предложенное по умолчанию имя программной группы, то Вы можете изменить его либо выбрать имя существующей программной группы. В программной группе с указанным Вами именем будут размещены ярлыки программ Клиент системы ЛІГА:ЗАКОН (программная оболочка Клиента базы данных), Конфигурация Клиента системы ЛIГА:ЗАКОН (конфигуратор Клиента базы данных) и Удаление Клиента системы ЛIГА:ЗАКОН (программа деинсталляции Клиента системы ЛЗ), Клиент - Информация о системе ЛIГА:ЗАКОН.

Рис. 1.35. Выбор программной группы

Этап 7

Далее инсталляционная программа сообщит Вам, что процесс определения исходных данных для инсталляции завершен (рис. 1.36), и можно переходить к копированию файлов системы на Ваш компьютер. На этом этапе Вы еще можете вернуться к предыдущим этапам для изменения параметров инсталляции.

Рис. 1.36. Начало инсталляции

После того, как Вы нажмете кнопку Далее, инсталляционная программа начнет копировать файлы по указанному Вами пути. Прерывание этого процесса приведет к завершению инсталляции без установки Клиента системы ЛЗ.

После успешного завершения процесса копирования система сообщит Вам об этом (рис. 1.37).

Рис. 1.37. Окно завершения инсталляции

1.3.3.1. Централизованная инсталляция клиента

Администраторам крупной локальной сети нет необходимости обходить рабочие места сотрудников компании для установки Клиента системы ЛЗ. Для возможности работы Клиента с ограниченными правами пользователя была создана специальная msi-инсталляция для удаленной установки и дальнейшего обновления Клиента.

Инсталляция входит в поставку системы ЛЗ. Она размещена на DVD-диске в папке Install\MSI-Install в виде файла Cli_inst.msi . Установка или обновление Клиента осуществляется с помощью групповых политик Active Directory. Инструкции по централизованному тиражированию программного обеспечения в локальной сети можно найти в документации к Active Directory используемой операционной системы или на сайте Microsoft. Для того, чтобы максимально автоматизировать процесс установки и настройки Клиента, необходимо в папку с файлом Cli_inst.msi поместить файл Setup.inf, который формируется при инсталляции Сервера системы ЛЗ.

1.3.4. Деинсталляция системы

Если у Вас по каким-либо причинам возникла необходимость удалить систему ЛЗ с Вашего компьютера, то для проведения корректной процедуры деинсталляции необходимо нажать кнопку Пуск (Start) и в меню Программы (Programs) выбрать программную группу Liga. В программной группе необходимо выбрать пункт меню Remove LIGA ZAKON, а в нем один из пунктов: Uninstall LIGA, Удаление Клиента системы ЛІГА:ЗАКОН, Удаление Администратора системы ЛІГА:ЗАКОН.

Другой способ заключается в том, чтобы открыть Панель Управления (Control Panel) и запустить элемент управления “Установка и удаление программ” (Add or Remove Programs), а затем в списке программ выбрать систему ЛЗ и удалить ее.

В обоих случаях будет запущен стандартный деинсталлятор системы ЛЗ.

Удаление Серверной части системы, удаление Клиента и Администратора производятся отдельно. При запуске одного из ярлыков деинсталляции системы программа спросит Вас, действительно ли Вы хотите удалить программу с компьютера. В случае подтвержнения программа запустит процесс удаления необходимых файлов.

После окончания процесса деинсталляции основной каталог системы не удаляется. В нем остаются подкаталоги, содержащие созданную пользователем информацию, в частности, каталог User, в котором находятся портфели и закладки пользователя. Система выводит предупреждение об этом.

Вы можете удалить этот каталог вручную средствами операционной системы, если оставленная информация была сохранена ранее или не нужна Вам.

1.4. Запуск системы

Элементы системы ЛЗ могут функционировать на разных компьютерах Вашей локальной сети, поэтому базовые настройки системы разделяются на настройки клиентских (Клиент и Администратор) и серверной частей. Сервер системы содержит в себе все информационные базы системы и выполняет все задачи администрирования. Функциональность Клиента и Администратора сводится к формированию и отправке Серверу соответствующих запросов, а также получению и обработке ответов, пришедших от Сервера.

1.4.1. Группа LIGA

Рис. 1.38. Программная группа LIGA

1.4.2. Запуск и настройка Сервера системы

Сервер системы ЛЗ можно запустить автоматически или “вручную”. Для загрузки Сервера системы “вручную” необходимо запустить программу Ligasrv.exe, используя ярлык LIGA Server [image]. На рабочей панели системы Windows (рядом с часами) появится изображение параграфа красного цвета. Красный цвет знака параграфа указывает, что Сервер не активен. Для запуска Сервера необходимо подвести курсор к знаку параграфа и нажать правую кнопку мышки. Появится Командное Меню Сервера (рис. 1.39), которое состоит из команд:

Рис. 1.39. Командное меню Сервера

· Старт - запустить (активизировать) Сервер;
· Стоп - остановить (деактивизировать) Сервер;
· Конфигурация - вызвать окно настройки Сервера (эта команда доступна только при неактивном Сервере системы);
· Выход - закрыть (знак параграфа исчезает из рабочей панели системы Windows).

Во время процесса активизации или деактивизации Сервера знак параграфа временно становится серым. При активизированном Сервере знак параграфа имеет зеленый цвет.

Для изменения настроек Сервера системы ЛЗ Вам необходимо загрузить его и выбрать команду Конфигурация из его Командного Меню (доступна только при неактивном Сервере). Настройки Сервера разделяются на Общие, настройки, связанные с размещением файлов системы (Маршруты), настройки параметров связи (Связь), настройки параметров почтового соединения (HTTP/E-mail), настройки параметров модуля “Информационное бюро” (Информационное Бюро).

Запуск программы LIGA Server необходимо производить от имени пользователя, который является членом группы Администраторы на данном компьютере.

Примечание

Если Сервер установлен на компьютере под управлением Windows Vista, 7 с включенным контролем учетных записей (UAC), то при запуске будет выскакивать окно с предупреждением (рис. 1.40).

Рис. 1.40. Окно предупреждения

Для загрузки Сервера необходимо щелкнуть правой кнопкой мыши по ярлыку LIGA Server и в контекстном меню выбрать пункт "Запуск от имени администратора" (рис. 1.41).

Рис. 1.41. Выбор пункта "Запуск от имени администратора" в контекстном меню

Затем в окне предупреждения "Контроль учетных записей" нажать кнопку Разрешить.

1.4.3. Общие настройки Сервера (Общие)

Общие настройки Сервера (рис. 1.42) задают:

· параметры ведения файла-протокола работы Сервера LigaSrv.log, протокола приeма Receive.log, почтового протокола Mail.log и протокола блокировок LocObj.log (группа Протоколирование);
· язык интерфейса (группа Интерфейс);
· параметры резервного копирования перед приемом в базу (группа Автоматическое резервное копирование);
· приоритет выполнения сервисных задач (группа Приоритет выполнения сервисных задач);
· режимы запуска Сервера (группа Регистрировать как);
· режимы запуска сервисов Сервера (группа Автозапуск служб).

Рис. 1.42. Окно общих настроек Сервера

Параметры ведения файлов-протоколов (log-файлов)

работы системы (Протоколирование) задают:

· максимальный размер (Макс. размер(Kb), задаваемый в килобайтах, допустимый для файла протокола. Вид журнала протоколирования выбирается из раскрывающегося списка в группе "Протоколирование" - его системное название отображается рядом. Затем регулируется параметр Макс. размер (Kb). Его значения заданы в пределах от 256 до 10240 Kb с шагом 256 Kb. Если в процессе работы системы файл протокола достигнет заданного значения, то первая (более ранняя) половина записей будет из него удалена. Таким образом, в файле протокола будут содержаться только последние записи, суммарный объем которых не превышает значения рассматриваемого параметра;
· режим ведения протокола, задаваемый опцией “Расширенное протоколирование”. Если эта опция активизирована, то Сервер будет вести расширенное протоколирование работы, которое позволяет легко локализовать причины возможных неисправностей. В противном случае осуществляется стандартное протоколирование, при котором отмечаются только наиболее существенные события в потоке функционирования.

Примечание

1. Установка режима расширенного протоколирования целесообразна только в том случае, когда Вы наблюдаете устойчивую неисправность в работе системы. Необходимо помнить, что этот режим ведения протокола требует большего ресурса и может вызывать снижение производительности системы.

2. Новые сообщения добавляются в конец протокола.

Параметры интерфейса (Интерфейс)

· язык интерфейса (Язык) задает язык, на котором будут вестись протоколы системы, язык диагностических и информационных сообщений.

Приоритет выполнения сервисных задач

В секции "Приоритет выполнения сервисных задач" по умолчанию задано значение "Нормальный". Значения "Выше нормального" и "Наивысший" целесообразно выбирать, если сервисные задачи не стартуют вовремя в связи с загруженностью операционной системы другими одновременно выполняющимися процессами.

Режимы запуска Сервера (Регистрировать как)

Параметры этой группы позволяют Вам определить, что Сервер стартует как:

· в ручном режиме (Не регистрировать). В этом случае Вам необходимо будет запускать Сервер “вручную”, используя соответствующий ярлык в программной группе системы ЛЗ. После запуска Вам будет необходимо самостоятельно активизировать Сервер, используя его Командное Меню;
· обычная программа. В этом случае Сервер регистрируется в операционной системе как программа автоматического запуска (аналог помещения его ярлыка в программную группу “Автозагрузка” или “Startup”) и будет загружаться при каждой загрузке операционной системы. Если Вы активизируете опцию “АвтоЗапуск”, то сразу после загрузки операционной системы Сервер будет автоматически активизироваться. В противном случае Вам будет необходимо активизировать его “вручную”;
· сервис Windows. При этом способе загрузки Сервер регистрируется в операционной системе как служебная программа (service), активизацией которой управляет операционная система. Если Вы активизируете опцию “АвтоЗапуск”, то при каждой загрузке операционной системы Сервер будет автоматически активизироваться. При этом Вам нет необходимости открывать пользовательский сеанс на этом компьютере. Если Вы установите данный режим запуска Сервера, то загруженный “вручную” Сервер будет работать только как программа, управляющая работой соответствующего сервиса операционной системы, т. е. позволяющая активизировать, деактивизировать или конфигурировать его.

Режимы запуска сервисов Сервера (Автозапуск служб)

Эта группа общих настроек Сервера определяет режимы запуска его служб (сервисов), к которым относятся Планировщик задач и Автоответчик. Активизация соответствующих опций настроек обеспечивает автоматический запуск указанных служб при каждой активизации Сервера системы ЛЗ. Планировщик задач обеспечивает выполнение по расписанию задач, связанных с обслуживанием базы данных системы, а Автоответчик обеспечивает автоматическое конфигурирование коммуникационных параметров Клиентов системы ЛЗ. Подробнее о назначении указанных служб говорится в пункте 4.8 “Запуск и настройка Клиента и Администратора системы” этого Pаздела.

1.4.4. Настройки Сервера, связанные с размещением файлов (Маршруты)

Настройки Сервера, связанные с размещением файлов системы (Маршруты) (рис. 1.43):

Рис. 1.43. Окно настройки Маршрутов

· Program - путь, по которому размещаются исполняемые модули;
· Data - путь, по которому размещаются главная таблица базы данных, служебные таблицы и описатели;
· Index - путь, по которому размещаются индексные таблицы базы данных, обеспечивающие функционирование поисковой системы;
· Log - по этому пути размещаются файлы протоколов работы системы. Имена этих файлов соответствуют именам программ, которыми они формируются, и функциям, выполнение которых они регистрируют:

- LigaSrv.LOG - протокол работы Сервера системы,

- LMail.LOG - для программы Liga Mailer,

- Receive.LOG - протокол приема в базу,

- Mail.LOG - протокол обработки почтового ящика,

- LocObj.LOG - протокол работы с объектами собственных баз данных,

- 000XХXXX.CHK - протокол проверки целостности базы, где ХХХХХ - регистрационный номер;

· Work - каталог, в котором размещаются системные временные файлы. После нормального завершения работы системы этот каталог должен быть пустым;
· User - в этом каталоге создаются и поддерживаются настроечные файлы и таблицы пользовательского интерфейса (закладки, портфели и т. п.);
· Session - по этому пути размещаются временные файлы, связанные с поддержкой текущего пользовательского сеанса. После нормального завершения работы системы этот каталог должен быть пустым. В существующей версии системы Администратором этот каталог не используется;
· Texts - в этом каталоге находятся библиотеки текстов документов базы данных;
· Output - в этом каталоге помещаются файлы, предназначенные для Локальной БД;
· New Texts - по этому пути система ищет посылки при обработке новых поступлений в базу данных (по умолчанию этот параметр указывает на каталог Text_new\);
· Custom Base - в этом каталоге создаются и поддерживаются промежуточные файлы и таблицы, используемые при работе с собственными базами данных (по умолчанию этот параметр указывает на каталог SelfBase\);
· Save Sends - в каталоге, задаваемом этим параметром, сохраняются успешно обработанные стандартные посылки для модификации баз данных системы и собственных баз данных (по умолчанию этот параметр указывает на каталог SaveArc\);
· NetInstall - в каталоге, задаваемом этим параметром, будет размещаться информационный файл Setup.inf, содержащий коммуникационные настройки Сервера и используемый при автоматическом конфигурировании коммуникационных параметров Клиента и Администратора системы ЛЗ;
· BackUp - в каталоге, задаваемом этим параметром, будут размещаться папки DATA, INDEX, TEXTS, скопированные в результате выполнения задачи "Создание резервной копии".

Система ЛЗ допускает размещение указанных каталогов на разных дисках Вашего компьютера. Если Вы желаете переместить любой из указанных каталогов на другой диск, то Вам необходимо скопировать все его содержимое в выбранное место и установить значение соответствующего параметра.

Внимание!

Мы настоятельно не рекомендуем Вам размещать какие-либо из указанных каталогов на сетевых файловых ресурсах, так как это может привести к существенному снижению производительности системы.

При изменениях значений этих параметров Вы можете воспользоваться кнопками:

- позволяет выбрать любой из существующих на Вашем компьютере каталогов;

- устанавливает значение параметра по умолчанию.

1.4.5. Настройка параметров связи (Связь)

Параметры связи определяют, по каким из установленных на Вашем компьютере сетевым протоколам будет работать Сервер системы ЛЗ, а также задается необходимость создания информационного файла (Setup.inf) для автоматической настройки Клиента и Администратора системы (опция “Создать INF-файл”), см. рис. 1.44.

Рис. 1.44. Окно настройки параметров связи

В настоящее время сетевой вариант системы ЛЗ обеспечивает обмен между своими элементами через унифицированный сетевой интерфейс Windows Socket по протоколам IPX/SPX и/или TCP/IP в редакции Microsoft. Для настройки указанных протоколов в Вашей локальной сети обращайтесь к соответствующим разделам технической документации на операционные системы Windows. (Краткая справочная информация дана в п. 4.6 текущего Pаздела).

Выбор протокола при конфигурировании Сервера

При конфигурировании Сервера системы ЛЗ Вы можете выбрать любой или оба из указанных выше протоколов для организации обмена между элементами системы.

Если Вы планируете устанавливать Клиентов системы ЛЗ на рабочие станции, одни из которых используют протокол TCP/IP, а другие IPX/SPX, то Вам придется использовать оба протокола. При этом Сервер системы будет организовывать обмен по обоим протоколам, а Клиенты - только по одному из них. Если подобной необходимости не возникает, то лучше конфигурировать Сервер для использования только одного протокола, так как это существенно снизит нагрузку на Сервер.

При выборе протокола IPX/SPX Вам, как правило, нет необходимости описывать какие-либо дополнительные параметры (начиная с Windows Vista и Windows Server 2003 x64 Microsoft не поддерживает протокол IPX/SPX). При выборе TCP/IP Вы обязаны установить номер порта, который будет использоваться Сервером системы ЛЗ. В подавляющем большинстве случаев значение, предлагаемое по умолчанию (30583), является приемлемым, однако Вам необходимо убедиться, что никакой другой IP-сервис на Вашем компьютере не использует этот порт. В противном случае возможны конфликты, приводящие к неработоспособности системы ЛЗ и (или) соответствующего сервиса. Для справки об используемых на Вашем компьютере номерах IP-портов просмотрите файл SERVICES в каталоге Windows\System32.

Расширенные настройки параметров сетевых протоколов

Если по каким-либо причинам Вас не устраивает качество сетевого обмена в системе ЛЗ, либо возникают сложности при организации обмена в многосегментной локальной сети, то Вы можете воспользоваться расширенными сетевыми настройками, которые вызываются нажатием кнопки Расширение >>. После нажатия на эту кнопку появится окно, в котором рекомендуется детально изучить документацию по этому режиму (рис. 1.45).

Рис. 1.45. Окно-предупреждение

Нажав кнопку OK, Вы получите доступ к расширенным сетевым настройкам (рис. 1.46):

Рис. 1.46. Расширенные настройки параметров связи Сервера

Внимание!

Изменять расширенные настройки Сервера без предварительной консультации Службы технической поддержки компании "ЛИГА:ЗАКОН" НЕ РЕКОМЕНДУЕТСЯ!

Необходимо отметить, что в подавляющем большинстве случаев при правильно сконфигурированных локальной сети и рабочих станциях пользователей необходимости в этом не возникает.

После перехода в расширенный режим сетевых настроек Вам будет предложен список всех протоколов, входящих в семейства IPX/SPX и TCP/IP и доступных через сетевой интерфейс Windows Socket. Имена протоколов в этом списке соответствуют именам, зарегистрированным в операционной системе и описанным в технической документации на нее. Система ЛЗ может использовать только потокоориентированные (Stream) и псевдопотокоориентированные (Pseudo Stream) протоколы.

Вы можете выбрать по одному протоколу из каждого представленного семейства, дважды щелкнув мышкой на имени протокола. Выбранные протоколы будут отмечены знаком “+” в левой колонке списка. В правой колонке Вы можете задать для каждого из выбранных протоколов номер порта, который будет использоваться Сервером. Для протоколов семейства IPX/SPX значение этого параметра в общем случае может быть произвольным.

Выбранный в списке протокол будет представлен в строке над списком расширенной записью вида:

для TCP/IP:

TCPIP, Address: 192.168.11.31, Protocol type: 0006, Socket type:

0001, Port: 30583, где

TCPIP - наименование семейства протоколов;

Address: ХХХ.ХХХ.ХХХ.ХХХ - адрес сетевого интерфейса (контроллера) в нотации IP, который будет использоваться Сервером для коммуникаций;

Protocol type: ХХХХ - системный идентификатор типа протокола;

Socket type: ХХХХ - системный идентификатор типа открываемого соединения;

Port: ХХХХХ - номер порта, используемого Сервером для коммуникаций;

для IPX/SPX:

IPX, Net: 00000112, Node: 009027519A89, Protocol type: 04E8,

Socket type: 0005, Port: 30583, где

IPX - наименование семейства протоколов;

Net: ХХХХХХХХ - адрес подсети IPX или номер сегмента локальной сети, в которой установлен Сервер;

Node: ХХХХХХХХХХХХ - уникальный (в рамках сегмента) идентификатор или

MAC-адрес сетевого контроллера;

Protocol type: ХХХХ - системный идентификатор типа протокола;

Socket type: ХХХХ - системный идентификатор типа открываемого соединения;

Port: ХХХХХ - номер порта, используемого Сервером для коммуникаций.

Любой протокол может быть активизирован одновременно на нескольких сетевых адаптерах (интерфейсах). По умолчанию все выбранные протоколы будут активизироваться на всех доступных интерфейсах.

Опция Автоматическое связывание адресов (по умолчанию активизирована) связывает явным образом все существующие сетевые интерфейсы со всеми определенными ранее протоколами.

Рис. 1.47. Окно выбора использования сетевых интерфейсов

При нажатии на кнопку Определить открывается окно со списком существующих интерфейсов и используемых протоколов, рис. 1.47. По умолчанию опция Использовать все доступные включена. Если ее отключить, становится доступной возможность отключить (включить) отдельные сетевые интерфейсы. Отключение всех интерфейсов означает, что будут использованы все существующие интерфейсы.

Если сервер системы установлен на компьютере с несколькими сетевыми интерфейсами (адаптерами), то в файл ..\Liga\Install\Setup.inf запишутся все определенные при конфигурации сервера интерфейсы соединений. После инсталляции Клиентов системы они будут настроены на первый по порядку интерфейс. Для настройки Клиентов того сегмента сети, интерфейс которого является не первым в списке возможных, следует запустить программу Конфигурация Клиента ЛІГА:ЗАКОН, на закладке "Связь" нажать кнопку Расширение и установить тот интерфейс, который используется в данном сегменте сети. Подробно о самостоятельном конфигурировании Клиента и Администратора будет рассказано в п. 4.8 этого Раздела.

В случае использования сервером протокола NWLink IPX/SPX на компьютере под Windows XP, 2003 или Vista c несколькими сетевыми интерфейсами, в настройках этого протокола необходимо установить ненулевой внутренний номер сети (Internal network number).

Начиная с Windows Vista и Windows Server 2003 x64 Microsoft не поддерживает протокол IPX/SPX.

Примечание

Если в Вашей локальной сети используется сервер DHCP (Dynamic Host Configure Protocol) для динамического назначения IP-адресов, то Вам необходимо обеспечить назначение фиксированного адреса для компьютера, на котором установлен Сервер системы ЛЗ. Это связано с тем, что Клиенты системы осуществляют соединение с фиксированным адресом Сервера. Если он будет периодически меняться, то Вам потребуется каждый раз переконфигурировать коммуникационные параметры Клиентов.

Последняя группа расширенных настроек сетевых протоколов (рис. 1.46), к которым относятся размер пакета (Размер пакета), время ожидания при приеме (Время ожидания) и параметр разделения потоков (Разд. потоков), позволят Вам добиться устойчивой связи между элементами системы при эксплуатации их в нагруженной локальной сети с малопроизводительными рабочими станциями. Необходимо сразу отметить, что потребность в манипулировании этими параметрами может возникнуть только в крайних случаях, когда на одном слабопроизводительном компьютере установлены одновременно Сервер и Клиент системы ЛЗ с обменом по протоколу IPX/SPX. В подавляющем большинстве случаев значения этих параметров, установленные по умолчанию, обеспечивают устойчивое соединение.

Рассмотрим физический смысл этих параметров:

· Размер пакетов - задаваемый в байтах размер пакетов, которыми осуществляется обмен между элементами системы. Увеличение этого параметра обеспечивает повышение скорости обмена в слабонагруженных или скоростных (100 Mb/s) локальных сетях. Для очень нагруженных или непроизводительных сетей целесообразно снижать значение этого параметра, что обеспечивает повышение устойчивости связи и уменьшает количество потерянных пакетов;
· Время ожидания - задаваемое в секундах максимальное время ожидания очередного пакета. Если при обмене передаваемая порция информации имеет объем больший, чем размер пакета, то она будет фрагментироваться. При этом Время ожидания задает максимальное значение временного интервала между пакетами одной порции информации. Если это время будет превышено, то Сервер сгенерирует соответствующее сообщение об ошибке и прекратит прием порции. Для медленных локальных сетей целесообразно повышать значение этого параметра в случае, когда наблюдается частое появление указанной ситуации в течение сеанса работы. Чрезмерное повышение этого параметра может приводить к замедлению реакции Сервера на обрывы связи, вызванные неработоспособностью Клиента или локальной сети;
· Разд. потоков - параметр разделения потоков позволяет повышать равномерность распределения процессорного времени между вычислительными потоками Сервера. Сервер системы ЛЗ является многопоточной программой, обеспечивающей одновременное выполнение нескольких вычислительных потоков, связанных с обслуживанием нескольких пользовательских сеансов. Если какой-либо из этих потоков будет на длительное время захватывать процессорное время, то это может приводить к блокированию других потоков и возникновению состояния превышения времени ожидания очередного пакета. Повышение значения этого параметра обеспечит более равномерное распределение процессорного времени между потоками Сервера. Однако чрезмерное увеличение его значения может привести к увеличению времени реакции Сервера на запросы Клиентов.

Как уже указывалось выше, потребность в изменении значений этих параметров может возникнуть крайне редко. Если у Вас возникают какие-либо проблемы, связанные с устойчивостью соединений, постарайтесь в первую очередь проверить правильность конфигурирования Вашей локальной сети и рабочих станций, на которых устанавливаются элементы системы ЛЗ. Если Вы изменили значения указанных параметров и диагностируете ухудшение ситуации, то Вы всегда можете установить их значения, рекомендуемые системой ЛЗ для Вашего компьютера. Для этого Вам необходимо просто нажать на кнопку [image].

1.4.5.1. Особенности настройки параметров связи при использовании файерволла

В случае использования файерволла между Клиентом и Сервером в Конфигурации Клиента системы ЛІГА:ЗАКОН, в поле «Порт» необходимо ввести пятизначный номер порта, разрешенного в настройках файерволла для связи Клиента системы ЛЗ и Сервера.

В настройках политик файерволла рекомендуется создать следующие правила:

· Разрешение исходящего трафика для удаленного по отношению к Клиенту адреса, который задан в Конфигурации Клиента системы ЛІГА:ЗАКОН в секции настроек протокола запросов TCP/IP, поддерживаемого Сервером.
· Разрешение входящего трафика для локального по отношению к Клиенту порта, номер которого задан в секции настроек протокола ответов TCP/IP, поддерживаемого Клиентом, в левом поле «Порт».
· Разрешение входящего трафика для локального по отношению к Клиенту порта, номер которого задан в секции настроек протокола ответов TCP/IP, поддерживаемого Клиентом, в правом поле «Порт».

При создании правил рекомендуется использовать настройки глобальных политик, а не политики для конкретного приложения.

1.4.6. Настройка параметров НТТР- и почтового соединения (HTTP/E-mail)

Вы можете настроить автоматический прием обновлений с HTTP-сервера и из почтового ящика электронной почты, (в зависимости от выбранного Вами варианта получения обновлений) и автоматическую отсылку проверочных файлов поставщику системы, а также отсылку информации о неудачно завершившихся задачах обслуживания на свой контрольный адрес. Примеры заполнения параметров настройки автоматического приема обновлений соединения показаны на рис. 1.48 – 1.51.

1.4.6.1. Прием обновлений

На закладке HTTP/E-mail в группе Прием обновлений (см. рис. 1.48, 1.49) две подгруппы - HTTP и E-mail. Определите, какой из способов будет для Вашей системы основным (постоянным), и активизируйте опцию "Основной способ приема".

Примечание

Если Вы впервые приобрели и установили систему ЛЗ, пришлите письмо-заявку на получение обновлений электронными средствами в Службу поддержки Абонентов Сети по электронной почте. Подробней - см. Раздел 3 "Способы получения обновлений электронными средствами".

Автоматическое получение обновлений с HTTP-сервера (рис. 1.48)

Рекомендуем использовать получение посылок-обновлений с HTTP-сервера как основной способ обновления. Преимущество данного способа заключается в надежности и простоте настройки. Этот способ обновления также удобен если компьютер, на котором установлен Сервер ЛЗ не имеет прямой доступ к Internet и Вы используете proxy-сервер.

Если у Вас возникают вопросы относительно настройки, обращайтесь в Службу технической и информационной поддержки Абонентов по т. (044) 585-24-01.

Рис. 1.48. Настройка параметров HTTP-соединения

Для настройки автоматического приема обновлений с HTTP-сервера на закладке HTTP/E-mail выберите подгруппу параметров Прием обновлений, HTTP (рис. 1.48) и задайте следующие параметры:

· Имя HTTP-сервера - имя HTTP-сервера, с которого будут отбираться файлы-обновления, по умолчанию - update.liga.net.
· Порт - номер порта, с которым установлено соединение на сервере (по умолчанию - 80).
· Логин - имя пользователя, полученное в ответ на Ваш запрос в ООО "ЛИГА ЗАКОН" (доступ к серверу - авторизованный).
· Пароль - Ваш пароль для входа на HTTP-сервер, полученный из ООО "ЛИГА ЗАКОН".

Если у Вас выход в глобальную сеть Интернет настроен через Proxy-сервер, то Вы можете активизировать опцию:

· Использовать HTTP Proxy-сервер и заполнить следующие параметры, значения которых Вы можете получить у Вашего системного администратора:

- Имя Proxy - имя Proxy-сервера (IP-адрес), который будет использоваться для HTTP-соединения.

- Порт - номер порта, с которым установлено соединение на сервере (по умолчанию - 3128).

- Логин и Пароль доступа к Proxy-серверу. Эти поля могут быть не заполнены.

Кнопка Проверить используется для проверки правильности заданных пользователем параметров. Проверка будет успешной только при возможности прямого соединения с HTTP-сервером.

Если прием обновлений через HTTP-сервер выбран в качестве основного, то автоматическая отправка CHK-файлов и получение недостающих документов проводится через HTTP-сервер.

Опция "Принять, начиная с даты..." активизируется вручную при необходимости выбрать посылки в интервале времени, начиная с определенной даты по текущий день. При успешном завершении выборки обновлений с таким параметром указание даты сбрасывается и опция отключается. Рекомендуется использовать эту опцию в случае, если система ЛЗ установлена на Ваш компьютер по прошествии определенного времени после ее приобретения.

Опция "Принимать обновления перед выполнением задачи "Прием в базу"" позволяет включить (отключить) первый этап задачи "Прием в базу" - "Прием обновлений электронными средствами".

Автоматический отбор посылок при выполнении задач "Прием в базу" и "Получение обновлений и отправка результатов" (подробнее см. Раздел 2, п. 2.1.1 и п. 2.1.2) будет осуществляться с HTTP-сервера с помощью встроенного HTTP-клиента, если опция "Основной способ приема" активизирована в группе настроек HTTP.

Отбор файлов-обновлений с HTTP-сервера осуществляется на основании анализа истории принятия посылок history.ldx и списка принимаемых Вашей системой типов посылок PostList.avl (эти файлы находятся в каталоге Data). При этом отбираются и пропущенные ранее посылки в соответствии с историей посылок. В случае, если файл истории принятия посылок разрушен и создан новый, выборка осуществляется из множества посылок за текущий день. При необходимости воспользуйтесь опцией "Принять, начиная с даты..." для получения объема посылок за определенный период времени.

Отбор посылок *.bbs для приема в "Бюро новостей" и "Горячую линию" осуществляется только за текущий день, причем в истории приема новостей ftpnews.ini фиксируются имена успешно принятых посылок для последующего анализа и отбора только свежих новостей при повторном входе на HTTP-сервер в один и тот же день.

Если активизирована опция "Основной способ приема" в группе настроек HTTP, то при проведении задач "Прием в базу", "Общая проверка базы" или "Эталонная проверка базы" имена пропущенных посылок в CHK-файле не фиксируются. Они будут выбраны с HTTP-сервера на основании анализа истории посылок history.ldx.

Внимание!

Если в качестве основного приема обновлений выбран прием обновлений по E-mail, то автоматическая отправка CHK-файлов и получение недостающих документов проводится только по E-mail. Не забудьте настроить параметры почтового соединения в группе Отправка, результатов проверки.

Автоматический прием обновлений из почтового ящика (рис. 1.49)

Для активизации этой возможности должны быть заданы следующие параметры подгруппы E-Mail группы Прием обновлений в настройках Сервера HTTP/E-mail:

Рис. 1.49. Пример настройки параметров почтового соединения для приема

· POP-Сервер - интернет-имя или IP-адрес почтового сервера, на котором открыт почтовый ящик клиента, используемый для приема посылок;
· Порт - номер порта, с которым установлено соединение на сервере входящей почты (по умолчанию - 110);
· Учетная запись - имя почтового ящика клиента;
· Пароль - пароль для доступа к почтовому ящику;
· Отправитель - электронный адрес, с которого приходят обновления (по умолчанию это адрес robot@liga.kiev.ua). Если же Вы получаете обновления от дилера, то в этом поле должен стоять тот адрес, который он использует для отсылки обновлений;
· Тема - если указана, то будут загружаться только те письма, строка ТЕМА: (SUBJECT:) которых совпадает с приведенной в этом параметре (по умолчанию пусто). Этот параметр удобно использовать, если Вы получаете обновления от дилера, и он указывает определенную тему писем с обновлениями. При указании этого параметра поле Отправитель может быть пустым.

Примечание

Программа будет обрабатывать все письма, пришедшие с адреса, указанного в поле Отправитель (по умолчанию robot@liga.kiev.ua). Если необходимо обрабатывать письма с нескольких адресов, то можно вносить адреса в поле "Отправитель" через разделитель ";".

Опция "Осуществлять прием обновлений порциями по N писем" позволяет настроить прием таким образом, чтобы за один сеанс соединения с почтовым сервером принимать из почтового ящика по N писем. После успешного приема сеанс соединения закрывается и сообщения из почтового ящика удаляются. Соединение с почтовым сервером повторяется до тех пор, пока в ящике есть необработанные сообщения. Включение этой опции может оказаться полезным после длительного перерыва между приемами обновлений, когда в почтовом ящике накопилось много сообщений и их обработка может занять продолжительное время, или при плохом качестве связи (особенно при работе по модему).

При активизированной опции "Оставлять копию письма на сервере" письма из почтового ящика клиента не удаляются. Однако программа не осуществляет контроль уже принятых писем и, если эта опция активна, при каждом приеме все содержимое почтового ящика будет копироваться и уже принятые посылки будут обрабатываться повторно. Использовать эту опцию целесообразно только в том случае, когда Вы желаете продублировать прием писем с помощью другой почтовой программы.

Опция "Принимать обновления перед выполнением задачи "Прием в базу"" позволяет включить (отключить) первый этап задачи "Прием в базу" - "Автоматический прием обновлений" (подробнее см. Раздел 2, п. 2.1.1).

Кнопка Проверить используется для проверки правильности заданных пользователем параметров. Проверка будет успешной только при возможности прямого соединения с POP-сервером.

Опция "Основной способ приема" предназначена для выбора одного из основных способов автоматического приема обновлений - HTTP или с помощью электронной почты. Опция может быть активизирована только на одной из групп настроек - HTTP или E-mail.

Примечание

Если для связи с провайдером, предоставляющим Вам услуги электронной почты, Вы используете удаленное соединение по модему (Dial-up connection), то Вам необходимо настроить соответствующее соединение.

1.4.6.2. Отправка результатов

В группе Отправка на закладке HTTP/E-mail определяются параметры для двух подгрупп - отправки результатов проверки и результатов выполнения задач (рис. 1.50, 1.51).

Автоматическая отправка проверочных файлов (рис. 1.50)

Для активизации этой возможности должны быть заданы следующие параметры группы Отправка, результатов проверки в настройках Сервера HTTP/E-mail:

· SMTP-Сервер - интернет-имя или IP-адрес почтового сервера доставки (SMTP), который используется клиентом для отправки корреспонденции;
· Порт - номер порта, с которым установлено соединение на сервере исходящей почты (по умолчанию - 25);
· Почтовый адрес - почтовый адрес клиента, который используется для его идентификации на SMTP-сервере;
· Получатель - электронный адрес, на который необходимо отсылать проверочный файл, по умолчанию это адрес check@liga.kiev.ua. Если же Вы получаете обновления от дилера, то в этом поле должен стоять тот адрес, который Ваш поставщик системы использует для получения от Вас проверочных файлов;
· SMTP Логин - Ваш логин на SMTP-сервере. Заполняется в случае, если Вы пользуетесь SMTP-сервером с авторизованным доступом;
· SMTP Пароль - Ваш пароль доступа на SMTP-сервер. Заполняется в случае, если Вы пользуетесь SMTP-сервером с авторизованным доступом.

Рис. 1.50. Пример настройки параметров почтового соединения для отправки проверочных файлов

Опция "Автоматически отправлять CHK-файл при проверке" позволяет включить (отключить) этап "Автоматическая отправка проверочного файла по электронной почте" при выполнении задач "Общая проверка базы" и "Эталонная проверка базы" (подробнее см. Pаздел 2, п. 2.2.1 и 2.2.2).

При активизированной опции “Удалить CHK-файл после отправки” проверочный файл после успешной отправки будет удаляться. Отключать эту опцию целесообразно в том случае, если Вы желаете сохранить проверочный файл. Если опция отключена, после автоматической отправки проверочного файла расширение этого файла изменяется на ^CHK. Необходимо помнить, что наличие проверочного файла в каталоге, задаваемом параметром “Log”, является одним из условий для активизации почтового соединения при выполнении задачи “Общая проверка базы”. Файл отправляется в виде вложения в письмо в кодировке UUEncode.

Кнопка Проверить используется для проверки правильности заданных пользователем параметров. Проверка будет успешной только при возможности прямого соединения с SMTP-сервером.

Опция “Время ожидан. (sec)” задает максимальный интервал, в течение которого Сервер ожидает ответа от почтового сервера на отправленный запрос.

Автоматическая отправка результатов выполнения задач (рис. 1.51)

Для активизации этой возможности должны быть заданы следующие параметры группы Отправка, результатов выполнения задач в настройках Сервера HTTP/E-mail:

· SMTP-Сервер - интернет-имя или IP-адрес почтового сервера доставки (SMTP), который используется клиентом для отправки корреспонденции;
· Порт - номер порта, с которым установлено соединение на сервере исходящей почты (по умолчанию - 25);
· Почтовый адрес - почтовый адрес клиента, который используется для его идентификации на SMTP-сервере;

Рис. 1.51. Пример настройки параметров почтового соединения для отправки уведомлений

· Получатель - электронный адрес, на который необходимо отсылать информацию в случае неудачного завершения выполняемых задач, может быть адресом для отсылки SMS-сообщений через электронную почту;
· SMTP Логин - Ваш логин на SMTP-сервере. Заполняется в случае, если Вы пользуетесь SMTP-сервером с авторизованным доступом;
· SMTP Пароль - Ваш пароль доступа на SMTP-сервер. Заполняется в случае, если Вы пользуетесь SMTP-сервером с авторизованным доступом.

Кнопка Проверить используется для проверки правильности заданных пользователем параметров. Проверка будет успешной только при возможности прямого соединения с SMTP-сервером.

Опция “Время ожидан. (sec)” задает максимальный интервал, в течение которого Сервер ожидает ответа от почтового сервера на отправленный запрос.

1.4.7. Настройка параметров модуля “Информационное бюро”

Параметры системы, связанные с функционированием “Информационного бюро” (рис. 1.52):

· Интервал проверки новостей - этим параметром устанавливается частота проверки каталога Text_new на наличие посылок с сообщениями (посылки *.BBS) для рубрик “Горячая линия” и “Бюро новостей” и фоновый прием их в систему (по умолчанию - 60 минут);
· Время жизни сообщений по каналам - срок, в течение которого сообщение находится в системе. Устанавливается для каждой из рубрик. По истечении срока сообщения удаляются из системы автоматически;
· Оригинальное - срок “жизни” сообщения в соответствии с датой, указанной в посылке (по умолчанию - 14 дней);
· Другое - срок “жизни” сообщения, устанавливаемый вручную.

Рис. 1.52. Настройка параметров Информационного бюро

1.4.8. Запуск и настройка Клиента и Администратора системы

Параметры, используемые при конфигурировании сетевых Клиента и Администратора системы ЛЗ, в основном совпадают. Поэтому их настройки будут рассматриваться на примере конфигурирования Клиента, с указанием особенностей конфигурирования Администратора. Настройки разделяются на общие (Общие), настройки, связанные с размещением файлов системы (Маршруты), и настройки параметров связи (Связь).

Для конфигурирования сетевых Клиента и Администратора используется программа Ligacfg.exe, которая запускается с соответствующими параметрами, указанными в ярлыках этой программы Конфигурация Администратора системы ЛІГА:ЗАКОН и Конфигурация Клиента системы ЛІГА:ЗАКОН, помещаемых в программную группу LIGA при инсталляции Клиента и Администратора.

Запуск программ Конфигурация Администратора системы ЛІГА:ЗАКОН и Конфигурация Клиента системы ЛІГА:ЗАКОН необходимо производить от имени пользователя, который является членом группы Администраторы на данном компьютере.

Примечание

Если Клиент или Администратор установлен на компьютере под управлением Windows Vista с включенным контролем учетных записей (UAC), то при запуске программы. Конфигурации будет выскакивать окно с предупреждением (рис. 1.53).

Чтобы запустить программу Конфигурации необходимо щелкнуть правой кнопкой мыши по ярлыку Конфигурация Клиента ЛІГА:ЗАКОН (или Конфигурация Администратора ЛІГА:ЗАКОН) и в контекстном меню выбрать пункт "Запуск от имени администратора" (рис.1.54).

Затем в окне предупреждения "Контроль учетных записей" нажать кнопку Разрешить.

Рис. 1.53. Окно предупреждения

Рис. 1.54. Выбор пункта "Запуск от имени администратора" в контекстном меню

К общим настройкам (Общие) сетевых Клиента и Администратора относятся параметры протокола работы системы (Протоколирование) и некоторые параметры интерфейса (Интерфейс) (рис. 1.55).

Рис. 1.55. Окно общих настроек параметров Клиента

Параметры ведения файла-протокола (log-файла)

работы системы (Протоколирование) задают:

· максимальный размер (Макс. размер (Kb), задаваемый в килобайтах, допустимый для файла протокола. Если в процессе работы системы файл протокола достигнет заданного значения, то первая (ранняя) половина записей будет из него удалена. Таким образом, в протоколе будут содержаться только последние записи, суммарный объем которых не превышает значения рассматриваемого параметра;
· режим ведения протокола, задаваемый опцией “Расширенное протоколирование”. Если эта опция активизирована, то система будет вести расширенное протоколирование работы, которое позволяет легко локализовать причины возможных неисправностей. В противном случае система осуществляет стандартное протоколирование, отмечая только наиболее существенные события в потоке функционирования.

Примечание

1. Установка режима расширенного протоколирования целесообразна только в том случае, когда Вы наблюдаете устойчивую неисправность в работе системы. Необходимо помнить, что этот режим ведения протокола требует большего ресурса и может вызывать снижение производительности системы.
2. Новые сообщения система добавляет в конец протокола.

Параметры интерфейса (Интерфейс):

· язык интерфейса (Язык) задает язык, на котором будет вестись протокол системы, язык диагностических и информационных сообщений, заголовков окон, пунктов меню и т. п. программных оболочек системы. Этот параметр Вы можете задавать и из программной оболочки Клиента непосредственно.

В настоящее время система поддерживает три языка - украинский (основной), русский и английский. При этом поисковая система поддерживает поиск только по украинским и русскоязычным реквизитам.

Настройки сетевых Клиента и Администратора, связанные с размещением файлов (Маршруты), содержат существенно меньшее количество параметров и их смысл несколько отличается от соответствующих параметров Сервера системы ЛЗ (рис. 1.56):

Рис. 1.56. Окно путей размещения файлов Клиента

Program - путь, по которому размещаются программные модули Клиента или Администратора;

· Data - путь, по которому размещаются служебные таблицы и описатели;
· Index - зарезервированный параметр, в существующей версии системы не используется;
· Log - по этому пути размещаются файлы-протоколы (лог-файлы) работы системы. Имена этих файлов соответствуют именам программ, которыми они формируются:

- Liga.LOG - для оболочки Клиента;

- Ligaadm.LOG - для оболочки Администратора;

· Work - каталог, в котором размещаются системные временные файлы. После нормального завершения работы Клиента и/или Администратора этот каталог должен быть пустым;
· User - в этом каталоге создаются и поддерживаются настроечные файлы и таблицы пользовательского интерфейса (закладки, портфели и т. п.). В существующей версии системы Администратором этот каталог не используется;
· Session - по этому пути размещаются временные файлы, связанные с поддержкой текущего пользовательского сеанса. После нормального завершения работы системы этот каталог должен быть пустым. В существующей версии системы Администратором этот каталог не используется;
· NetInstall - этим параметром задается путь, по которому находится информационный файл Setup.inf, содержащий коммуникационные настройки Сервера и используемый при автоматическом конфигурировании коммуникационных параметров Клиента и Администратора системы ЛЗ.

Настройки параметров связи (Связь) Клиента и Администратора системы ЛЗ (рис. 1.57) практически полностью совпадают. Отличие заключается только в возможности задать Имя Пользователя при конфигурировании Клиента. Это имя используется для идентификации и проверки прав при подключении Клиента к Серверу. При подключении Администратора используется зарезервированное имя Administrator, которое всегда присутствует в системе и не может быть изменено.

Рис. 1.57. Окно настройки параметров связи Клиента

Примечание

Вы можете ввести любое имя Клиента, но прежде чем запустить систему на клиентской машине Вам необходимо обязательно зарегистрировать это имя в системе ЛЗ с помощью Менеджера пользователей (см. п. 4.1 Раздела 2 данного руководства).

Для конфигурирования параметров связи Клиента и Администратора можно использовать три способа:

· информационный файл Setup.inf, подготовленный Сервером (для удаленного Клиента этот способ недоступен);
· непосредственный опрос Сервера;
· самостоятельное (“ручное”) назначение параметров связи.

Первые два способа являются автоматизированными и в подавляющем большинстве случаев обеспечивают правильную настройку коммуникационных параметров Клиента и Администратора. Третий способ целесообразно использовать только при невозможности успешной настройки параметров связи первыми двумя способами, что может иметь место в локальных сетях сложной конфигурации.

Использование информационного файла Setup.inf

Для конфигурирования параметров связи первым способом Вам необходимо выбрать команду Получить из INF-файла и нажать кнопку Выполнить. После этого программа конфигурации попытается найти и прочитать файл Setup.inf по пути, заданному параметром “Маршруты: NetInstall”. В этом файле содержится информация о сетевом адресе, номере порта и типе соединения по каждому из протоколов, установленных на Сервере. Если операция чтения файла пройдет успешно и параметры настройки Сервера, записанные в этом файле, согласуются с текущими сетевыми настройками компьютера, на котором установлен Клиент (Администратор) системы ЛЗ, то программа конфигурации установит соответствующие значения коммуникационных параметров. Под согласованностью понимается поддержка операционной системой клиентского компьютера хотя бы одного из протоколов, установленных на Сервере.

Примечание

При настройке параметров связи этим способом не требуется активизация Сервера системы ЛЗ.

Непосредственный опрос Сервера

При конфигурировании параметров связи Клиента (Администратора) вторым способом Вам необходимо выбрать команду Получить с сервера, набрать в появившемся окне (Имя сервера) имя компьютера, на котором установлен Сервер, и нажать кнопку Выполнить (рис. 1.58). Для удаленного Клиента Вам необходимо ввести интернет-имя сервера или его IP-адрес (рис. 1.59).

Примечание

При этом Сервер системы ЛЗ должен быть активизирован и на нем должен быть запущен сервис Автоответчик (для конфигурации параметров связи удаленного Клиента - не обязательно).

Программа конфигурации попытается установить связь с Сервером системы ЛЗ, установленном на указанном Вами компьютере, с использованием сетевого интерфейса MailSlot, который является протокольно независимым. Если связь будет установлена успешно, то Сервер передаст программе конфигурации свои текущие сетевые настройки. Если эти настройки согласуются с текущими системными сетевыми настройками компьютера Клиента, то программа конфигурации попытается установить связь с Сервером по этим протоколам. При успешном установлении связи программа конфигурации установит соответствующие значения коммуникационных параметров.

Рис. 1.58. Окно параметров связи сетевого Клиента

Рис. 1.59. Окно параметров связи удаленного Клиента

Самостоятельное (“ручное”) назначение параметров связи

Для того, чтобы самостоятельно установить параметры связи Клиента (Администратора), Вам необходимо нажать кнопку Расширение>>. После нажатия на эту кнопку появится окно, в котором рекомендуется детально изучить документацию по этому режиму (рис. 1.60). Нажав кнопку OK, Вы получите доступ к расширенным сетевым настройкам (рис. 1.61). Прежде чем перейти к ее описанию, необходимо рассмотреть основные принципы организации обмена между элементами системы ЛЗ.

При запуске сетевой Клиент (Администратор) устанавливает прослушивание некоторого свободного порта по заданному протоколу, после чего пытается установить соединение на заданный порт Сервера и передает ему параметры своего порта, которые Сервер запоминает. В дальнейшем все запросы Клиента передаются на порт, прослушиваемый Сервером, а результаты обработки запросов Сервером передаются на порт, прослушиваемый Клиентом. Такая схема позволяет минимизировать на Сервере количество одновременно поддерживаемых соединений, что позволяет Серверу с гораздо большей эффективностью поддерживать большое число Клиентов. Кроме того, при такой организации обмена появляется возможность передавать Клиентам сообщения и уведомления по инициативе Сервера.

Рис. 1.60. Окно-предупреждение

Рис. 1.61. Расширенная настройка параметров связи Клиента

Параметры порта, прослушиваемого Клиентом, определяются им автоматически при каждом запуске с учетом выбранного протокола, который задается параметром “Протокол ответов”. При установке этого параметра Вам предоставляется возможность выбрать любой из установленных на Вашем компьютере протоколов. При этом необходимо, чтобы выбранный Вами протокол поддерживался Сервером.

Используя опцию “Фикс. адрес”, Вы можете навязать привязку прослушиваемого Клиентом порта к заданному адресу сетевого интерфейса (контроллера) из списка установленных на Вашем компьютере. Этот параметр полностью аналогичен соответствующему параметру сетевых настроек Сервера системы ЛЗ. Мы настоятельно не рекомендуем использовать жесткую привязку к адресу для протокола TCP/IP, если в Вашей локальной сети для выделения IP-адресов используется сервер DHCP (Dynamic Host Configure Protocol).

Если Вами был предварительно получен (одним из рассмотренных выше двух способов) список протоколов, поддерживаемых Сервером, то, используя параметр “Протокол запросов”, Вы можете выбрать из этого списка один из них. В противном случае список будет пуст и Вам придется описать протоколы, поддерживаемые Сервером, “вручную”. Для этого Вам необходимо нажать кнопку Вручную, выбрать тип протокола в поле “Протокол запросов” (рис. 1.62) и повторно нажать кнопку Вручную. После этого Вы должны определить все параметры, описывающие порт, установленный на прослушивание Сервером. Эти параметры рассматривались при описании сетевых настроек Сервера. Формы для их установки показаны: для TCP/IP на рис. 1.63, для IPX/SPX на рис. 1.64.

После того, как Вы зададите значения всех параметров, Вам необходимо нажать на кнопку Изменить, и Ваш выбор будет закреплен в параметре “Протокол запроса”.

Рис. 1.62. Окно выбора протокола

Рис. 1.63. Окно параметров порта для TCP/IP

Рис. 1.64. Окно параметров порта для IPX/SPX

Примечание

При использовании этого способа конфигурирования сетевых настроек Клиента (Администратора) активизация Сервера ЛЗ не требуется.

Кроме описанных трех способов существует еще один, представляющий собой модификацию второго способа. Для его использования Вам необходимо нажать кнопку Найти сервер..., после чего перед Вами откроется поисковое окно (рис. 1.65). При нажатии кнопки Поиск программа конфигурации начнет искать Сервер системы ЛЗ, опрашивая все активные компьютеры Вашей локальной сети. Так как опрос ведется с использованием унифицированного сетевого интерфейса MailSlot, то при большом количестве компьютеров в Вашей сети он может продолжаться очень долго. Как только Сервер будет обнаружен, программа конфигурации произведет настройку в соответствии со вторым способом.

Рис. 1.65. Окно поиска Сервера системы

Вы можете также:

· указать имя компьютера, на котором установлен Сервер, “вручную”, набрав его имя в строке Компьютер сервера или выбрав из списка активных компьютеров Вашей сети;
· указать IP-адрес компьютера, на котором установлен Сервер, и номер прослушиваемого им порта (в шестнадцатиричном виде), если Сервер поддерживает протокол TCP/IP.

После нажатия кнопки OK программа конфигурации попытается установить связь с выбранным Вами компьютером и произвести настройку сетевых параметров.

Из описанных способов конфигурирования сетевых параметров Клиента и Администратора системы ЛЗ наиболее предпочтительным является первый способ, так как он обеспечивает достаточно точную настройку параметров и не требует активизации сервиса Автоответчик, что облегчает функционирование Сервера.

Расширенные настройки сетевых параметров позволяют Вам также установить значения времени ожидания при приеме (Время ожидан.) и параметра разделения потоков (Разд. потоков), которые имеют тот же смысл, что и соответствующие параметры настроек Сервера, и подробно описаны в предыдущем пункте. Значение параметра “Размер пакета” для Клиента (Администратора) не устанавливается, так как оно навязывается Клиенту Сервером при установлении соединения.

Для удаленного Клиента системы окно расширенной настройки параметров связи несколько отличается от окна сетевого Клиента (рис. 1.66).

Удаленный Клиент поддерживает связь с сервером только по протоколу TCP/IP. Поэтому в окне расширенной настройки удаленного Клиента указывается только один протокол для связи и не требуется описания параметров собственного гнезда для прослушивания. Для настройки удаленного Клиента вводится еще один параметр - частота опроса (в секундах) активности сервера, которая осуществляется независимо от времени последней активности сервера.

Рис. 1.66. Расширенная настройка параметров связи удаленного Клиента

Настройка прокси-сервера для Системы анализа судебных решений VERDICTUM

Рис. 1.67. Окно настройки прокси-сервера

Закладка Прокси-сервер появляется в Конфигурации Клиента только в том случае, если в вашей системе ЛЗ открыт доступ к Системе анализа судебных решений VERDICTUM.

· Использовать системные настройки прокси - рекомендованная настройка, установлена по умолчанию. В этом случае они читаются из настроек операционной системы.
· Не использовать прокси.
· Самостоятельная настройка прокси - здесь необходимо ввести имя прокси, номер порта и, при необходимости, логин и пароль.

По окончании настроек нажмите на кнопку "Проверить связь" и добейтесь получения положительного результата проверки. Сохраните настройки.

Для каждого пользователя ПК настройка прокси (при необходимости) производится персонально. Для настройки прокси-сервера необходимо иметь права Администратора системы для данной учетной записи.


2. АДМИНИСТРИРОВАНИЕ СИСТЕМЫ

2.1. Описание приложения Администратора

Администрирование системы ЛЗ осуществляется из программной оболочки Администратора Ligaadm.exe и представляет собой управление:

· выполнением задач обслуживания базы данных системы;
· базой пользователей системы;
· сессиями;
· сервисами.

Запуск программы Администратор системы ЛIГА:ЗАКОН необходимо производить от имени пользователя, который является членом группы Администраторы на данном компьютере.

Необходимо понимать, что оболочка Администратора лишь посылает команду на выполнение какой-либо задачи. Непосредственно исполнение задачи протекает под управлением Сервера системы, на той машине, где установлен Сервер. При запуске оболочки Администратора Вам предоставляется возможность выбора функции администрирования.

Примечание

Если Администратор установлен на компьютере под управлением Windows Vista, 7 с включенным контролем учетных записей (UAC), то при запуске будет выскакивать окно с предупреждением (рис. 2.1).

Чтобы запустить программную оболочку Администратора необходимо щелкнуть правой кнопкой мыши по ярлыку Администратора и в контекстном меню выбрать пункт "Запуск от имени администратора" (рис. 2.2).

Затем в окне предупреждения "Контроль учетных записей" нажать кнопку Разрешить.

Рис. 2.1. Окно предупреждения

Рис. 2.2. Выбор пункта "Запуск от имени администратора" в контекстном меню

Перечень кнопок главного окна Администратора системы представлен в таблице 2.1.

Таблица 2.1

Перечень кнопок главного окна Администратора системы

Вид кнопки | Название функции администрирования и ее описание
 | Менеджер задач - позволяет запускать задачи обслуживания базы данных на выполнение, останавливать и изменять их параметры
 | Просмотр протоколов работы - позволяет в удобном виде просмотреть log-файлы системы определенной структуры и историю приема посылок
 | Менеджер пользователей - позволяет добавлять пользователей в систему, редактировать их права и удалять. Возможно создание групп пользователей с определенными свойствами
 | База удаленных пользователей - режим управления базой пользователей, которым открыта возможность удаленного доступа к системе (через интернет-соединение)
 | Менеджер базы прав - управление доступом к Собственным базам данных пользователя, а также к документам этих баз
 | Менеджер сеансов представляет собой окно, в котором отображается список активных пользователей сессий. Этот режим позволяет управлять сессиями пользователей, направлять им сообщения, просматривать состояния отдельных сеансов
 | Информационное бюро - включает информационные сообщения "горячей линии" и деловые новости в режиме реального времени
 | Корпоративные портфели - режим предназначен для администрирования Корпоративных портфелей пользователей, размещенных на сервере. Администратор управляет правами доступа пользователей к Портфелям и их разделам, создает резервные архивы, подключает или отключает отдельные Корпоративные портфели
 | Сервисы - окно управления Планировщиком задач и Автоответчиком
 | Завершение работы приложения Администратора

2.2. Задачи обслуживания баз данных системы

Управление задачами обслуживания базы данных системы осуществляется из окна Менеджера задач, который позволяет запускать задачи на выполнение, останавливать и изменять их параметры. При открытии окна перед Вами появляется список задач, которые могут выполняться системой. В настоящее время система ЛЗ поставляется с набором задач, который условно можно классифицировать:

· Общие задачи – задачи модификации и проверки баз данных, работы с электронной почтой (рис. 2.3);
· Сервисные задачи – задачи резервирования и восстановления работоспособности базы в случае повреждений (рис. 2.4);

Рис. 2.3. Окно Менеджера задач с закладкой “Общие”

Рис. 2.4. Окно Менеджера задач с закладкой “Сервисные”

· Собственные базы – задачи создания, модифицирования и сопровождения собственных баз данных.
· Группы заданий – возможность создавать группы заданий, назначая в группе очередность выполнения каждой задачи сразу после выполнения предыдущей. Более подробно создание групп заданий описано в п. 2.6.2 данного Раздела.

В левой колонке списка отображается состояние соответствующей задачи:

- задача находится в состоянии ожидания (синий флажок);

- задача выполняется (зеленый флажок);

- задача отключена.

В графе Название задания поясняется смысл задачи обслуживания. Графа Название этапа отображает текущий этап выполняемой задачи. В графах % Этап и % Задание отображается процент выполнения этапа и задачи целиком соответственно для выполняемой задачи. В графе Последний старт указывается дата и время последнего запуска задачи. В графе Длительность для неактивной задачи указывается продолжительность последнего выполнения, а для выполняемой - текущее время выполнения задачи. Графа Последний результат содержит значение кода возврата, полученное при последнем выполнении неактивной задачи или текущее для этапа выполняемой задачи. В графе Следующий старт указывается дата и время следующего старта задачи по расписанию.

Примечание

1. Завершение работы оболочки Администратора во время выполнения какой-либо задачи обслуживания не приводит к ее остановке, выполнение задачи продолжается под управлением Планировщика задач.
2. Вы можете настраивать расписание выполнения задач. Выполнение задач по расписанию производится сервисом Планировщик задач.
3. Все задачи обслуживания базы данных (кроме задач "Получение обновлений и отправка результатов" и “Информбюро: прием сообщений”) выполняются в режиме монопольного захвата базы, поэтому при запуске задачи все активные Клиенты (в том числе и Администратор) получают уведомление о блокировке базы и их запросы не обслуживаются. Клиент при попытке подключиться к Серверу во время выполнения задач обслуживания получит отказ. После завершения выполнения задачи активные Клиенты получают уведомление о разблокировке базы и доступ к данным открывается. (В окне с сообщением системы имеется кнопка Выход, которая позволяет закрыть это окно).
4. Если выполняется одна из задач: “Прием в базу”, "Восстановление полнотекстового индекса", "Оптимизация базы”, “Создание и прием собственных посылок”, “Создание резервной копии базы собственных документов”, “Восстановление резервной копии базы собственных документов”, то без особых причин эти задачи прерывать не рекомендуется.
5. Если двум задачам задать одно и то же стартовое время или стартовое время одной задачи окажется меньше, чем время окончания другой, то Сервер выполнит по расписанию только одну задачу.

Для запуска на выполнение выбранной в списке задачи Вам достаточно нажать кнопку [image], а для ее остановки [image]. Для отключения задачи Вам достаточно установить на нее курсор и нажать кнопку [image]. Это целесообразно в том случае, если у Вас настроен запуск задач по расписанию и Вы хотите отключить выполнение данной задачи. Повторное нажатие на эту кнопку вернет задачу в состояние ожидания и сделает ее доступной для запуска. Кнопка [image] используется для просмотра и изменения параметров выбранной задачи. Подробно работа с Редактором задач и Группами заданий описана в п. 2.6 этого Раздела.

2.2.1. Прием обновлений

2.2.1.1. Прием в базу

Задача "Прием в базу" относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Эта задача предназначена для пополнения базы данных Вашей системы документами, поступающими из ООО "ЛИГА ЗАКОН" в виде отдельных файлов-обновлений (посылок).

Получение обновлений с помощью электронных средств подробно описано в Разделе 3 данного руководства. Обновление системы с помощью DVD-диска будет рассмотрено в Разделе 4.

Вы можете изменить способ получения обновлений в любой момент. Эти вопросы решаются в рабочем порядке в Службе поддержки Абонентов Всеукраинской сети ЛІГА:ЗАКОН (тел. (044) 538-01-03 - многоканальный, http://support.ligazakon.ua).

Посылки передаются Вам электронным способом. Обновление системы также можно проводить с помощью DVD-дисков.

Файлы-обновления имеют расширение ADD, BBS, CMP (стандартные посылки) или PVT (индивидуальные посылки), которые содержат тексты новых или измененных документов. Они предназначены для приема в базу данных системы ЛЗ. Файлы обновлений необходимо поместить в каталог, задаваемый параметром “New Texts” настроек Сервера системы ЛЗ. По умолчанию этот каталог имеет имя Text_new\ и является подкаталогом того каталога, в котором расположена система ЛЗ.

В системе предусмотрена возможность автоматического приема обновлений электронными средствами: с HTTP-сервера и по электронной почте. Настройка параметров автоматического приема обновлений электронными средствами детально рассмотрена в п. 4.6.1 Раздела 1 данного руководства. Автоматический прием обновлений может осуществляться на этапе 1 выполнения задачи “Прием в базу” или при запуске отдельной задачи "Получение обновлений и отправка результатов" (см. п. 2.1.2 этого Раздела).

Посылки-обновления из ООО "ЛИГА ЗАКОН" поступают ежедневно (в рабочие дни, в ночное время), поэтому, если Вы получаете обновления электронными средствами, необходимо запускать задачу "Прием в базу" раз в сутки. Для настройки автоматического запуска задачи воспользуйтесь Планировщиком (см. п. 2.6.1 данного Раздела).

Выполнение задачи “Прием в базу” осуществляется в несколько этапов:

Этап 1

Прием обновлений электронными средствами

Этот этап выполняется, если в настройках Сервера активизирована опция "Принимать обновления перед выполнением задачи "Прием в базу"" и на закладке HTTP/E-mail вписаны параметры для приема обновлений электронными средствами.

Если основным способом приема выбран прием с HTTP-сервера, то файлы, необходимые для приема, скачиваются в каталог для приема обновлений (обычно это каталог Text_new).

Если основным способом приема выбран прием по электронной почте (опция "Основной способ приема" установлена в группе E-mail), то осуществляется соединение с почтовым сервером (POP) и забираются все письма, пришедшие с адреса, заданного параметром "Отправитель" (по умолчанию - robot@liga.kiev.ua), на адрес абонента. Письма складываются в рабочий каталог (задается параметром "Work", обычно это каталог Work). Далее осуществляется разборка писем, во время которой из них извлекаются вложения (attachments).

Все файлы с расширениями ADD, PVT и BBS из каталога Work перемещаются в каталог для приема обновлений (задается параметром "New Texts", обычно это каталог Text_new).

Если в настройках Сервера на закладке HTTP/E-mail не установлена опция "Принимать обновления перед выполнением задачи "Прием в базу", то этап 1 приема обновлений пропускается.

Этап 2

Поиск обновлений

В каталоге, заданном параметром “New Texts” (по умолчанию Text_new\), производится поиск файлов-посылок.

Этап 3

Обработка посылок

Состоит из 3-х основных стадий

3.1 Неблокирующая работу пользователей стадия приема (80-90% от общего времени приема):

а) прием карточек в базу данных без реального изменения базы, в журнал \Data\ хххх.db3-journal,

б) прием текстов во временные библиотеки \Work\TextUpdate\хххххххх.llb

в) индексация текстов во временный индекс \Index\ ..._new.dat

3.2 Блокирующая работу пользователей стадия (10-20% от общего времени приема):

а) запись изменений в карточках в базу данных

б) копирование измененных библиотек текстов в основное хранилище

в) замена полнотекстового индекса модифицированной копией

г) фиксация имен посылок, обработанных в первой подзадаче, с удалением из приемного директория

Стадии 1 и 2 могут повторяться, если количество карточек документов в посылках превышает граничное число (вычисляемое в зависимости от памяти компъютера).

3.3 Стадия "Проверка по истории посылок" (1-2% от общего времени приема)

Запускается только при успешном выполнении первых двух стадий приема.

Примечание

Все успешно принятые посылки сохраняются в каталоге, задаваемом параметром “Save Sends” настроек Сервера системы ЛЗ (по умолчанию - каталог SaveArc). Вам необходимо обеспечить достаточный объем дискового пространства для поддержки этой функции. В служебном файле \Data\Common.ini в секции BackUp можно настраивать, сохранять ли посылки в этой папке и в течение какого времени их хранить. По умолчанию система сохраняет принятые посылки в течение 60 дней.

В конце приема в базу система производит проверку по истории посылок, и в том случае, если есть пропущенные посылки, в каталоге Log будет сформирован проверочный файл (файл с именем вида 000xxxxx.CHK, где xxxxx - регистрационный номер Вашего комплекта системы), содержащий список пропущенных посылок. Если в качестве основного способа приема выбран HTTP, то имена пропущенных посылок в CHK-файле не фиксируются. Они будут выбраны с HTTP-сервера на основании анализа истории посылок history.ldx.

Протокол приема посылок Receive.LOG, на основании которого можно проанализировать, какие из посылок были успешно обработаны системой, а какие нет, хранится в каталоге, заданном параметром “Log” настроек Сервера системы ЛЗ (по умолчанию - каталог Log\).

Кроме приема стандартных посылок (файлы с расширениями ADD, BBS) при выполнении задачи “Прием в базу” осуществляется также обработка индивидуальных посылок (файлы с расширением PVT), передаваемых Вам при обработке проверочных файлов, а также посылок, предназначенных для Собственных баз данных системы ЛЗ (если у Вас вариант системы с Конструктором Баз Данных).

Примечание

1. Вы можете настроить автоматическую отправку сообщений на Ваш E-mail в случаях, когда при выполнении задачи "Прием в базу" возникли ошибки или были обнаружены отсутствующие файлы. Для этого необходимо установить опцию "Отправлять сообщения по e-mail при аварийном завершении" в настройках параметров задачи (см. п. 2.6.1), а также задать параметры в Конфигурации Сервера на закладке HTTP/E-mail в группе Отправка, результатов выполнения задач (см. п. 4.6.2 Раздела 1).
2. При нормальном завершении задачи каталог, задаваемый параметром "New_Texts" (по умолчанию - каталог Text_new\), должен быть пустым, а резервные копии посылок должны находиться в каталоге, задаваемом параметром “Save Sends” (по умолчанию - каталог SaveArc\).
3. В случае, когда в каталоге Text_new\ остаются посылки (расширение посылок, которые не могут быть приняты в систему, изменяется на BAD), рекомендуем посмотреть последние сообщения системы в протоколе Receive.LOG (новые сообщения добавляются в конец файла).

Перечень типов посылок, которые принимаются Вашей системой, Вы можете видеть внизу в окне Менеджера задач. Виды посылок перечислены в таблице 2.2.

Каждый пользователь получает определенный набор посылок в зависимости от того, какую версию системы он приобрел.

В результате обработки Вашего проверочного файла для Вас будут сформированы индивидуальные посылки, например, 00248*.PVT, если “248” - регистрационный номер Вашего комплекта системы.

Таблица 2.2

Виды посылок

Тип посылки | Название Информационного ресурса или механизма, для которых предназначены посылки
ALLxxxxx.add | СЛУЖЕБНАЯ БАЗА (ДЛЯ ВЕРСИИ 9)
BIZxxxxx.add | БИЗНЕС
BKDxxxxx.add | ЭНЦИКЛОПЕДИЯ БУХГАЛТЕРА
BKPxxxxx.add | ПУТЕВОДИТЕЛЬ ПО ПРОЦЕДУРЕ БАНКРОТСТВА
BKTxxxxx.add | БАНКРОТСТВО И ЛИКВИДАЦИЯ ПРЕДПРИЯТИЙ
BMIxxxxx.add | ВЕДОМОСТИ БУХГАЛТЕРА
BSTxxxxx.add | СИТУАЦИИ ДЛЯ БУХГАЛТЕРА
BUHxxxxx.add | БУХГАЛТЕР
BZIxxxxx.add | БУХГАЛТЕР & ЗАКОН
DGNxxxxx.add | ТИПОВЫЕ ДОГОВОРЫ
DIGxxxxx.add | КОНСУЛЬТАЦИИ
FNCxxxxx.add | ФИНАНСОВАЯ ИНФОРМАЦИЯ
FRMxxxxx.add | ФОРМЫ ДЛЯ БУХГАЛТЕРА
GBHxxxxx.add | ГЛАВНЫЙ БУХГАЛТЕР
GORxxxxx.add | СТОЛИЧНОЕ ЗАКОНОДАТЕЛЬСТВО
IZAxxxxx.add | ЮРИСТ & ЗАКОН
IZBxxxxx.add | ДЕБЕТ-КРЕДИТ
IZCxxxxx.add | УПРАВЛЕНИЕ ПЕРСОНАЛОМ
IZDxxxxx.add | АДВОКАТ БУХГАЛТЕРА
JIGxxxxx.add | ЮРИДИЧЕСКИЕ КОНСУЛЬТАЦИИ
KDKxxxxx.add | КОММЕНТИРОВАННЫЕ КОДЕКСЫ
KDXxxxxx.add | КОДЕКСЫ
KNOxxxxx.add | НАЛОГОВЫЕ ЗНАНИЯ
LAWxxxxx.add | ОБЩЕЕ ЗАКОНОДАТЕЛЬСТВО
LINxxxxx.add | ПУТЕВОДИТЕЛЬ ПО НАЛОГООБЛОЖЕНИЮ
LZUxxxxx.add | УРОКИ ЛІГА:ЗАКОН
MBHxxxxx.add | БУХГАЛТЕР
MITxxxxx.add | ТАМОЖЕННОЕ ПPАВО
MONxxxxx.add | МОНИТОРИНГ ЗАКОНОДАТЕЛЬСТВА
NKUxxxxx.add | НАЛОГОВЫЙ КОНСУЛЬТАНТ
OBLxxxxx.add | PЕГИОНЫ
OSTxxxxx.add | БАЗА ОШИБОК И СПОРНЫХ СИТУАЦИЙ
PRExxxxx.add | СУДЕБНЫЕ ПРЕЦЕДЕНТЫ
PRKxxxxx.add | ЗАКОНОПРОЕКТЫ И КОММЕНТАРИИ
RZNxxxxx.add | PАЗНОЕ
SFOxxxxx.add | БИБЛИОТЕКА МСФО
SITxxxxx.add | СИТУАЦИИ ДЛЯ БИЗНЕСА
SLPxxxxx.add | СЛУЖБА ПЕРСОНАЛА
SPLxxxxx.add | ЮРИДИЧЕСКИЕ СПРАВОЧНИКИ
SPRxxxxx.add | СПPАВОЧНИКИ
SUBxxxxx.add | СУДЕБНАЯ ПРАКТИКА ДЛЯ БУХГАЛТЕРА
SUDxxxxx.add | СУДЕБНАЯ ПРАКТИКА
TAXxxxxx.add | НАЛОГИ В УКPАИНЕ
TOGxxxxx.add | ИСКУССТВО ОБОРОНЫ
TOZxxxxx.add | ЗАЩИТА БИЗНЕСА
TPRxxxxx.add | ПРОВОДКИ
TRMxxxxx.add | ТЕРМИНОЛОГИЧЕСКИЙ СЛОВАРЬ
UGDxxxxx.add | МЕЖДУНАPОДНЫЕ СОГЛАШЕНИЯ
VLUxxxxx.add | ВЛАСТЬ УКРАИНЫ
ZORxxxxx.add | ИТОГИ НЕДЕЛИ
NWSxxxxx.bbs | ИнформБюро: новости
BBSxxxxx.bbs | ИнформБюро: горячая линия
ETLxxxxx.cmp | Системные посылки для ведения эталонного списка документов
хxxxxnnn.pvt | Индивидуальные посылки. Используются для устранения рассогласований с Эталонной базой данных (xxxxx - регистрационный номер системы, nnn - порядковый номер посылки)

2.2.1.2. Получение обновлений и отправка результатов

Данная задача относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Задача не блокирует работу с системой.

Выполнение этой задачи осуществляется в два этапа:

· прием обновлений с HTTP-сервера или из почтового ящика электронной почты;
· отправка проверочных файлов поставщику системы.

Настройка параметров HTTP и почтового соединения осуществляется в настройках Сервера на закладке HTTP/E-mail и детально рассмотрена в пункте 4.6 Раздела 1 данного Руководства.

Примечание

Для закачивания новостийных сообщений (файлы с расширением BBS) задачу "Получение обновлений и отправка результатов" целесообразно выполнять ежечасно перед автоматическим приемом их в ИнформБюро (см. Раздел 1, п. 4.7.) или перед выполнением задачи "ИнформБюро:Прием сообщений". Как настроить Планировщик описано в п. 2.6.1.

Автоматическое получение обновлений с HTTP-сервера

Если прием обновлений c HTTP-сервера выбран в качестве основного, то на этом этапе осуществляется соединение с HTTP-сервером (по умолчанию - update.liga.net) и файлы-обновления с расширениями ADD, BBS и PVT с HTTP-сервера выгружаются в каталог для приема обновлений.

Автоматический прием обновлений из почтового ящика

На этом этапе осуществляется соединение с почтовым сервером (POP) и забираются все письма, пришедшие с адреса, заданного параметром "Отправитель" (по умолчанию - robot@liga.kiev.ua), на адрес абонента. Письма складываются в подкаталог MailBox каталога для приема обновлений (задается параметром "New Texts", обычно это каталог Text_new). Подкаталог MailBox создается автоматически.

Далее осуществляется разборка писем, во время которой из них извлекаются вложения (attachments). Они накапливаются в подкаталоге MailTexts каталога для приема обновлений. Подкаталог MailTexts создается автоматически.

Все файлы с расширениями ADD, BBS и PVT из подкаталога MailTexts перемещаются в каталог для приема обновлений.

Примечание

Опция "Принимать обновления перед выполнением задачи "Прием в базу" в настройках Сервера HTTP/E-mail не влияет на выполнение задачи "Получение обновлений и отправка результатов". Она предназначена только для отключения/включения 1 этапа выполнения задачи "Прием в базу".

Автоматическая отсылка проверочных файлов

Если в каталоге после выполнения задачи образовался проверочный файл, то на втором этапе выполнения задачи "Получение обновлений и отправка результатов" осуществляется отправка этого файла в ООО "ЛИГА ЗАКОН".

Если прием обновлений с HTTP-сервера выбран в качестве основного, то автоматическая отправка CHK-файлов проводится на HTTP-сервер.

Если в качестве основного приема обновлений выбран прием обновлений по E-mail, то автоматическая отправка CHK-файлов проводится по адресу, указанному в поле "Получатель" (по умолчанию - check@liga.kiev.ua) окна настроек Сервера, после чего его расширение меняется на ^chk. Файл отправляется в виде вложения в письмо в кодировке UUEncode.

Примечание

Опция "Автоматически отправлять CHK-файл при проверке" в настройках Сервера HTTP/E-mail не влияет на выполнение задачи "Получение обновлений и отправка результатов". Она предназначена только для отключения/включения 3 этапа выполнения задачи “Общая проверка базы”.

Если для связи с провайдером, предоставляющим Вам услуги электронной почты, Вы используете удаленное соединение по модему (Dial-up connection), то Вам необходимо настроить соответствующее соединение.

При запуске в Администраторе задачи "Получение обновлений и отправка результатов" устанавливается удаленное соединение с провайдером и по соответствующим настройкам параметров почтового соединения Сервера системы ЛЗ происходит отбор почтовых сообщений из Вашего почтового ящика и отсылка проверочного файла, полученного в результате выполнения задачи “Общая проверка базы”. Если при выполнении задачи произошел разрыв соединения с провайдером, дождитесь завершения задачи и запустите ее снова.

2.2.1.3. ИнформБюро: Прием сообщений

Данная задача относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Задача не блокирует работу с системой.

Эта задача предназначена для приема в базу сообщений для рубрик “Горячая линия” и “Бюро новостей”.

Посылки передаются Вам электронным способом. Обновления для этих рубрик - это файлы с расширением BBS. Файлы обновлений необходимо поместить в каталог, задаваемый параметром “New Texts” настроек Администратора системы ЛЗ. По умолчанию этот каталог имеет имя Text_new\ и является подкаталогом того каталога, в котором расположена система ЛЗ. Автоматически обновления помещаются в Text_new\ после выполнения задачи "Получение обновлений и отправка результатов" (см. п. 2.1.2).

Задача выполняется автоматически в фоновом режиме, если установлена опция "Интервал проверки новостей" на закладке Информационное бюро в настройках Сервера (см. п. 4.7 Раздела 1).

2.2.2. Проверка целостности базы

2.2.2.1. Общая проверка базы

Задача "Общая проверка базы" относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Задача блокирует работу с системой.

Эта задача предназначена для проверки информационной целостности Вашей базы данных.

Рекомендуем выполнять общую проверку базы раз или два раза в неделю для того, чтобы поддерживать систему в актуальном состоянии.

Проверка производится в несколько этапов:

Этап 1

Проверка согласованности главной таблицы

базы данных и библиотек текстов документов

На этом этапе обнаруживаются и фиксируются ситуации отсутствия текста документа для записи в главной таблице базы данных.

Этап 2

Обработка таблицы истории принятых посылок

На этом этапе в проверочном файле фиксируются все пропуски приема посылок, вызванные их поврежденностью либо отсутствием.

Если по окончании работы рассматриваемой задачи Вы получили код возврата, свидетельствующий об ошибке, то в каталоге, задаваемом параметром “Log”, формируется так называемый проверочный файл (файл с именем вида 000хxxxx.CHK, где xxxхx - регистрационный номер Вашего комплекта системы). Этот файл необходимо передать Вашему поставщику системы ЛЗ (дилеру или непосредственно в ООО "ЛИГА ЗАКОН"), после чего для Вас будут сформированы индивидуальные посылки (файлы с именем XXXXXnnn.PVT, где XXXXX - регистрационный номер комплекта системы, а nnn - порядковый номер посылки). Когда эти посылки будут обработаны задачей “Прием в базу”, целостность Вашей базы данных будет восстановлена.

Этап 3

Автоматическая отправка проверочного файла

Если в настройках Сервера HTTP/E-mail установлена опция "Автоматически отправлять CHK-файл при проверке" и при проверке базы был сформирован проверочный файл, то осуществляется отправка этого файла в ООО "ЛИГА ЗАКОН".

Если прием обновлений с HTTP-сервера выбран в качестве основного, то автоматическая отправка CHK-файлов проводится на HTTP-сервер. Если в качестве основного приема обновлений выбран E-mail, то автоматическая отправка CHK-файлов проводится по адресу, указанному в поле "Получатель" (по умолчанию - check@liga.kiev.ua) окна настроек Сервера, после чего его расширение меняется на ^chk.

Автоматическая отправка проверочного файла также осуществляется при выполнении отдельной задачи "Получение обновлений и отправка результатов" (см. п. 2.1.2).

2.2.2.2. Эталонная проверка базы

Задача "Эталонная проверка базы" относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Задача блокирует работу с системой.

В процессе выполнения этой задачи производятся проверка по эталонному списку и три этапа Общей проверки.

Эталонный список формируется ООО "ЛИГА ЗАКОН" и передается клиентам в инсталляционном пакете, а затем поддерживается в актуальном состоянии на машинах пользователей с помощью посылок вида ETL*.CMP.

Посылки на модификацию эталонного списка имеют жесткую сквозную нумерацию. Они принимаются в систему как и обычные посылки, но только в порядке строгой очередности.

При проведении проверки по эталонному списку контролируются только те документы, дата модификации которых меньше либо равна дате выпуска последней принятой посылки, модифицировавшей эталонный список. Если разница между датой обновления эталонного списка и датой последнего приема документов составляет более 7 дней, то такой эталонный список считается устаревшим и проверка по нему не производится, о чем делается соответствующая запись в лог-файле.

Выполнение задачи “Эталонная проверка базы” занимает порядка 40 - 80 минут. Оптимальная частота ее проведения составляет один раз в неделю или один раз в две недели.

2.2.2.3. Проверка библиотек текстов

Данная задача относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач. Данную задачу необходимо выполнять для выявления причины сбоев в системе, чтобы локализовать возникшую проблему.

Задача блокирует работу с системой.

При выполнении этой задачи осуществляется проверка целостности библиотек текстов документов. Если в результате проверки будут обнаружены поврежденные библиотеки, то они удаляются из базы, а задачей формируется соответствующий код возврата. При последующей общей проверке базы рассогласование будет обнаружено и сформируется проверочный файл с запросом на пополнение базы данных.

2.2.2.4. Оптимизация базы

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Рекомендуется запускать для уменьшения размеров и для увеличения производительности работы с базой. Делает vacuum файла базы LZBase.db3. Проверяет дубли в библиотеках текстов. Проводится полная дефрагментация полнотекстного индекса.

2.2.2.5. Проверка читаемости текстов в библиотеках

Задача "Проверка читаемости текстов в библиотеках" относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Эта задача предназначена для проверки читаемости текстов в библиотеках. Рекомендуется запускать в том случае, если при приеме обновлений возникают проблемы с записью текстов в библиотеки.

В процессе выполнения задачи происходит проверка каждой библиотеки, которая заключается в последовательном выполнении следующих этапов:

- получение списка файлов библиотеки;

- распаковка содержимого библиотеки в каталог Work;

- сверка списка файлов библиотеки и содержимого каталога Work;

- распаковка каждого файла библиотеки в памяти.

Если результат выполнения хотя бы одного из этапов не является успешным, то дальнейшая проверка библиотеки прерывается, библиотека считается поврежденной и автоматически удаляется. В этом случае после выполнения задачи "Проверка читаемости текстов в библиотеках" автоматически запускается общая проверка базы и создается проверочный файл с отсутствующими текстами. Результатом выполнения задачи является сообщение "Есть отсутствующие файлы".

Для того, чтобы отключить автоматическое удаление поврежденной библиотеки, в файле Common.ini каталога Data установите следующее значение параметра:

[Common]

LongCheckDelBad=0

В этом случае после выполнения задачи "Проверка читаемости текстов в библиотеках" также автоматически запускается общая проверка базы и создается проверочный файл с отсутствующими текстами. Результатом выполнения задачи является сообщение "Есть отсутствующие файлы".

2.2.3. Индексация базы

2.2.3.1. Восстановление полнотекстового индекса

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Задача “Восстановление полнотекстового индекса" является наиболее длительной и ресурсоемкой из всех сервисных задач системы ЛЗ. Эту задачу необходимо выполнять ТОЛЬКО в тех случаях, когда по каким-либо причинам полнотекстовый индекс базы данных был разрушен. Внешне это может выражаться в неправильном поиске по словам из текстов либо словам из названий документов. В ходе полнотекстовой индексации базы полностью перестраивается значительный массив информации, включающий в себя несколько служебных файлов, размер которых достигает сотен мегабайт. Поэтому мы рекомендуем Вам перед проведением этой задачи обеспечить достаточно свободного места на диске (согласно техническим требованиям) и с помощью дефрагментации диска обеспечить непрерывность свободного участка. На момент выполнения задачи компьютер должен быть максимально разгружен. Выгрузите из памяти все неиспользуемые программы. Желательно приостановить работу антивирусного монитора, так как его контроль над файловыми операциями значительно замедляет выполнение задачи.

Если по каким-либо причинам восстановление полнотекстового индекса было прервано, то будет недоступен поиск по словам из текста и словам из названий документов.

Внимание!

Во время выполнения задачи "Восстановление полнотекстового индекса" мы не рекомендуем запускать другие приложения на Вашем компьютере.

2.2.3.2. ИнформБюро: Восстановление индексов

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача не блокирует работу с системой.

Эта задача предназначена для восстановления поврежденных индексов “Информационного бюро” системы ЛЗ. При этом все прочитанные соообщения устанавливаются как “непрочитанные”.

2.2.4. Резервное копирование

2.2.4.1. Создание резервной копии

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Задача создания резервной копии предусматривает копирование содержимого папок DATA, INDEX, TEXTS в отдельный каталог, который определяется параметром [BackUp] на закладке "Маршруты" в Конфигурации Сервера (по умолчанию это каталог \BackUp).

Выполнение задачи резервного копирования производится в несколько этапов:

Этап 1

Производится сбор информации о суммарном размере копируемых файлов, проверяется наличие требуемого свободного места на диске, на который будет производиться копирование.

Объем копируемых файлов зависит от того, какая система ЛЗ у Вас установлена и может составлять до 16,5 Гб дискового пространства.

Этап 2

Если в файле common.ini в группе [FullBackUp] переменная CheckData не установлена в 0, задача проверяет целостность главного файла данных. На этом этапе задача также проверяет целостность полнотекстового индекса. При наличии ошибок задача завершает работу.

Этап 3

Копируются директории DATA, INDEX, TEXTS со всеми поддиректориями. По завершении копирования создается файл Restore.lst в каталоге BackUp\Data\, содержащий имена скопированных файлов и их контрольные суммы. Восстановление резервной копии будет производиться при наличии всех файлов, указанных в этом списке со сверкой их контрольных сумм.

2.2.4.2. Восстановление из резервной копии

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Задача восстановления из резервной копии позволяет (при наличии корректно созданной резервной копии и необходимого свободного места на диске) вернуть базу данных в состояние, при котором создавалась копия.

Местоположение резервной копии определяется параметром [BackUp] на закладке "Маршруты" в Конфигурации Сервера (по умолчанию это каталог \BackUp).

При выполнении задачи восстановления из резервной копии проверяется корректность резервной копии по файлу Restore.lst в каталоге BackUp\Data\. При отсутствии файлов из списка или несоответствии их контрольных сумм задача прекращает свою работу. Копии каталогов DATA, INDEX, TEXTS со всеми подкаталогами переписываются в соответствующие каталоги, указанные в настройках сервера (сетевая версия) / администратора (локальная версия).

Внимание!

Запуск задачи восстановления из резервной копии НЕЛЬЗЯ включать по расписанию и в групповые задачи. Данная задача предназначена для восстановления работоспособности системы в ручном режиме в аварийных ситуациях.

Прерывание задачи "Восстановление из резервной копии", особенно на этапе копирования отдельных файлов, может привести к невозможности дальнейшего корректного функционирования БД.

Задачи создания резервной копии и восстановления из резервной копии так же, как и деинсталлятор системы, не удаляют файлы созданной резервной копии.

После восстановления из резервной копии системы ЛЗ анализируется папка SaveArc на наличие посылок, принятых после даты создания резервной копии, найденные посылки переносятся в папку Text_New и принимаются в базу при следующем приеме.

2.2.5. Просмотр протоколов работы

Для просмотра протоколов работы (лог-файлов) системы определенной структуры - LigaSrv.log, Liga.log, LigaAdm.log, Receive.log, Mail.log и истории приема посылок используется кнопка просмотра протоколов работы, доступная из главного окна Администратора системы, или кнопка [image] в Менеджере задач.

Режимы просмотра протоколов

Центральное окно содержит закладки для просмотра истории приема обновлений, почтового протокола, протоколов поступлений, Администратора, Клиента, Сервера (рис. 2.5). Для просмотра отдельно выбранного файла используется кнопка [image], при этом открывается закладка с именем выбранного файла.

Рис. 2.5. Просмотр протоколов работы системы

Каждая закладка содержит окно дерева и окно списка или графика сообщений (в зависимости от режима). Исключение составляют закладки "Протокол поступлений" и "Протокол Mail, FTP" - в них предоставляется возможность просмотра текстовых файлов Receive.log и Mail.log.

Содержимое дерева сообщений зависит от режима просмотра дерева (управляется кнопками Панели Инструментов) и служит для быстрого перехода на соответствующее сообщение.

Окно дерева отображает даты (а в некоторых режимах и время) сообщений. Выбор элемента дерева позволяет найти первое сообщение из списка на конкретную дату (а в некоторых режимах и на конкретное время).

Содержимое списка сообщений зависит от того, какая опция просмотра сообщений выбрана (задается включением/отключением пункта “Полный перечень сообщений” в меню “Опции”). Если включен “Полный перечень сообщений”, то в списке всегда отображаются все сообщения независимо от того, какой режим просмотра выбран в дереве сообщений.

Меню “Опции” состоит из следующих пунктов:

§ “Выделять сообщения цветом” - позволяет отключить/включить режим использования цветов в списке сообщений;
§ “Полный перечень сообщений” - установка/отключение этой опции влияет на то, будет ли в списке отображаться весь перечень сообщений, или только тех, которые относятся к текущему режиму просмотра дерева;
§ “Показывать с последнего дня” - установка/отключение этой опции влияет на то, будет ли при переходе в новый режим курсор устанавливаться на первое сообщение из списка или на первое сообщение последнего дня.

При первом выборе закладки с необходимым протоколом всегда отображается полный список сообщений.

Существует два режима просмотра протоколов:

Просмотр списка сообщений

§ перечень сообщений о приеме посылок,
§ перечень сообщений об ошибках,
§ перечень сообщений о соединениях пользователей,
§ перечень сообщений, относящихся к администрированию пакета,
§ полный перечень сообщений,
§ перечень сообщений, отобранных по указанному критерию.

Статистика сообщений

§ статистика приемов (график),
§ статистика индексаций базы данных (график).

В этих режимах доступны такие виды отображений:

- перечень сообщений о приеме посылок

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений, относящихся к приему пополнений.

Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к приему пополнений, если данная опция отключена.

- перечень сообщений об ошибках

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений об ошибках.

Выбор элемента дерева позволяет найти соответствующее сообщение об ошибке в списке.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к сообщениям об ошибках, если данная опция отключена.

- перечень сообщений о соединениях пользователей

Если нажата эта кнопка, то окно дерева отбражает даты и время сообщений, относящихся к соединению и разъединению пользователей.

Выбор элемента дерева позволяет найти соответствующее соединение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции "Полный список сообщений" или перечень сообщений, относящихся только к обращению пользователей к системе, если данная опция отключена.

- перечень сообщений, относящихся к администрированию пакета

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений, относящихся к административным сообщениям (сообщения проверок, индексации базы, проверок библиотек и т. п.).

Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к административным задачам, если данная опция отключена.

- все сообщения в этом файле

Если нажата эта кнопка, то окно дерева отображает даты сообщений.

Окно списка содержит полный перечень сообщений данного файла вне зависимости от состояния опции “Полный список сообщений”.

- перечень сообщений, отобранных по указанному критерию

Если нажата эта кнопка, то окно списка содержит только перечень отобранных сообщений.

Данный режим позволяет отобрать сообщения из общего списка по следующим критериям:

· по тексту сообщения,
· по имени функции,
· по дате,
· по времени,
· по коду.

Окно дерева отображает даты и время отобранных сообщений.

· Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень только отобранных сообщений, если данная опция отключена.

- статистика сообщений

Выбор данного режима позволяет построить график приемов посылок в базу данных и график индексаций базы на основе сообщений из данного файла.

График статистики приемов можно посмотреть в режиме всех приемов или на конкретную дату, выбрав соответствующий пункт дерева сообщений (рис. 2.6).

Рис. 2.6. Статистика приемов посылок

График статистики индексаций базы данных можно построить в разрезе всех индексаций или по дням.

В режиме статистики доступны следующие клавиши (слева направо):

Опции просмотра графиков

· печать текущей страницы графика на текущий принтер;
· показать график на одной/нескольких страницах;
· спрятать/показать ярлыки элементов графика;
· уменьшить масштаб графика;
· нормальный масштаб графика;
· увеличить масштаб графика;
· переход на первую страницу графика;
· переход на предыдущую страницу графика;
· переход на следующую страницу графика;
· переход на последнюю страницу графика.

Дополнительными возможностями манипулирования графиком являются:

· при нажатой правой клавише мышки можно производить скроллинг графика в любом направлении;
· при нажатой левой клавише мышки:

• при движении вниз и вправо - увеличить масштаб;

• при движении вверх и влево - восстановить нормальный масштаб.

При передвижении курсора над графиком в нижней панели отображаются атрибуты текущего элемента графика.

2.2.6. Планировщик и Группы заданий

2.2.6.1. Выполнение задач администрирования по расписанию

С помощью Планировщика Вы можете настроить ту или иную задачу, а также группу заданий на выполнение по расписанию: в определенное время и с указанной периодичностью.

Для просмотра и изменения параметров выбранной задачи используется кнопка [image] на панели Менеджера задач. При нажатии на нее перед Вами откроется окно "Настройка параметров" (рис. 2.7) с закладкой Параметры задачи, на которой Вы можете изменить параметры "Время ожидания завершения задачи" и "Период обновления информации в Менеджере задач" и настроить расписание выполнения задачи Планировщиком. Закладка Параметры группы служит для формирования и редактирования групп заданий и рассматривается в п. 2.6.2.

Рис. 2.7. Окно настройки параметров с закладкой “Параметры задачи”

"Время ожидания завершения задачи" (в минутах) задает максимальный интервал, в течение которого Администратор ожидает завершения задачи. Если задача не завершится в течение указанного интервала, то она принудительно снимается с выполнения и формируется соответствующий код возврата, который документируется в протоколе работы системы. Этот механизм позволяет избежать “зацикливания” задачи.

По умолчанию для всех задач установлены заведомо большие интервалы, которые гарантированно обеспечивают нормальное выполнение задачи на слабопроизводительных компьютерах. Вы можете изменить этот параметр в соответствии с оцененным для Вашего компьютера временем выполнения задачи.

"Период обновления информации в Менеджере задач" (в секундах) задает частоту опрашивания Администратором текущего состояния выполняемой задачи. Этот параметр также целесообразно устанавливать после оценки времени выполнения задачи на Вашем компьютере.

Слишком частый опрос состояния задачи может приводить к замедлению ее исполнения, а чрезмерно редкий - не позволит зафиксировать последовательность выполнения отдельных этапов задачи.

"Поведение после ошибки" дает возможность выбора автоматического запуска задачи повторно, если при первом выполнении задача прошла с ошибками.

Для одиночной задачи параметр имеет значения "Прервать выполнение" и "Повторить задание". Первое значение установлено по умолчанию и в случае ошибки не будет предприниматься никаких действий. В случае выбора повторного запуска задача будет запускаться ещё дважды, если первый перезапуск не даст положительный результат.

Для групповой задачи больший выбор действий после ошибки:

· Прервать выполнение - установлено по умолчанию;
· Продолжить выполнение;
· Повторить задание и прервать;
· Повторить задание и продолжить.

Опция "Отправлять сообщения по e-mail при аварийном завершении" устанавливается для того, чтобы получать на e-mail, указанный в настройках Сервера на закладке HTTP/E-mail в группе Отправка, результатов выполнения задач (см. Раздел 1, п. 4.6.2), сообщение в случае, если в результате выполнения задачи были выявлены ошибки или произошел сбой в процессе ее выполнения. По умолчанию опция установлена на всех задачах.

Расписание выполнения задачи Планировщиком.

При планировании выполнения задач по расписанию Вам необходимо учитывать, что одновременное выполнение нескольких задач невозможно, то есть расписание должно обеспечивать нормальное завершение очередной задачи перед запуском последующей. Запуск задачи при уже выполняющейся другой задаче не происходит. Исключение составляют задачи "Получение обновлений и отправка результатов", “ИнформБюро: Восстановление индексов” и “ИнформБюро: Прием сообщений”, которые могут выполняться одновременно с другой задачей. Для того чтобы избежать временных накладок, рекомендуем Вам воспользоваться группированием заданий, подробно описанном в п. 2.6.2 “Создание групп заданий”.

2.2.6.2. Создание групп заданий

В Менеджере задач существует возможность группировать задания в пакеты для последовательного выполнения, при этом сразу же по окончании отработки одной задачи стартует следующая. Это позволяет избежать временных нестыковок при запуске задач по расписанию. Просмотр и редактирование групп заданий доступно из закладки Группы заданий Менеджера задач (рис. 2.8).

Рис. 2.8. Окно Менеджера задач с закладкой Группы заданий

Группа заданий трактуется Менеджером задач как одна задача и может быть поставлена на выполнение по расписанию с помощью Планировщика точно так же, как и любая задача из раздела Общие или Сервисные задачи ("Настройка параметров", закладка Параметры задачи). Если какая-либо из задач пакета аварийно завершается, то прерывается выполнение всего пакета.

Для того чтобы создать новую группу, необходимо нажать кнопку [image]. Перед вами откроется окно Настройки параметров (рис. 2.9) с закладкой Параметры группы. В поле Название задачи вписывается название создаваемой группы, а в поле Состав группы с помощью кнопки [image] добавляются задачи, которые можно выбрать в открывающемся окне выбора задания (рис. 2.10).

Рис. 2.9. Окно настройки параметров с закладкой “Параметры группы”

Порядок следования задач в поле Состав группы определяет последовательность их выполнения. Его можно изменить с помощью кнопок [image] и [image], предварительно выделив перемещаемую задачу щелчком мыши. Если Вы хотите удалить какую-то задачу из группы, воспользуйтесь для этого кнопкой [image]. Для сохранения созданной группы (если состав группы и порядок следования задач удовлетворяют Вас), необходимо нажать кнопку Сохранить.

Для редактирования ранее созданной группы необходимо открыть Менеджер задач, перейти на закладку Группы заданий, выделить группу для редактирования и нажать кнопку [image]. В открывшемся окне Настройки параметров необходимо перейти на закладку Параметры группы. Далее действия по изменению состава группы и порядка следования задач аналогичны действиям по созданию новой группы.

Рис. 2.10. Окно выбора задания

Для удаления ранее созданной группы заданий необходимо выделить ее и нажать кнопку [image] в окне Менеджера задач.

2.3. Обновление статистики пользовательских запросов

При использовании интеллектуального поиска Клиента системы ЛЗ формируются и запоминаются поисковые запросы всех пользователей. Для отображения наиболее популярных запросов используется статистика их популярности.

Обновить неиспользующиеся поисковые запросы в базовой поисковой форме Клиента системы ЛЗ можно с помощью задачи "Обновление статистики пользовательских запросов", которая запускается из Менеджера задач на закладке "Сервисные".

Задача предназначена для очистки неиспользуемых и устаревших популярных поисковых запросов из истории запросов, а также для обновления статистики их популярности.

С помощью Планировщика задач задача настроена на выполнение один раз в месяц, каждый второй четверг месяца в 11:00. При необходимости, пользователь может изменить время и частоту запуска данной задачи (рис. 2.11).

Рис. 2.11. Настройка задачи "Обновление статистики пользовательских запросов"

2.4. Управление пользователями системы

2.4.1. Менеджер пользователей

Для управления базой пользователей системы выберите пункт [image] Менеджер пользователей из меню Администратора. Перед Вами откроется окно с именами пользователей и названиями групп (рис. 2.12).

Вы можете добавлять пользователей и группы в систему, редактировать их свойства и удалять, а также импортировать в базу пользователей домена Windows и групп Active Directory. Система не устанавливает ограничение на количество пользователей, введенных в базу, но ограничивает количество одновременно работающих пользователей.

Рис. 2.12. Окно Менеджера пользователей

2.4.1.1. Добавление и редактирование пользователей

Для того, чтобы добавить пользователя, Вам необходимо нажать кнопку [image], после чего откроется окно (рис. 2.13) редактора параметров пользователя.

В закладке Пользователь Вы можете задать:

· Имя пользователя (обязательный параметр), которое используется для идентификации при входе пользователя в систему;
· Описание (необязательный параметр), используемое для расширенной идентификации пользователя Администратором;
· Пароль (обязательный параметр, который может принимать пустое значение), используемый при входе пользователя в систему.

Рис. 2.13. Окно параметров пользователя

Рис. 2.14. Окно, определяющее принадлежность пользователя к уже существующим группам

В закладке Группа задается принадлежность пользователя к существующим группам (рис. 2.14) (пользователь всегда входит в группу Everyone).

В закладке Права задаются права пользователя (рис. 2.15) (необязательный параметр), которые регламентируют рабочее время пользователя в системе.

Если Вами был приобретен вариант поставки системы с Корпоративными портфелями, то Вы также можете установить права доступа к ним:

· Разрешено отправлять сетевые сообщения - доступ на обмен сообщениями средствами системы ЛЗ;
· Разрешено создавать Корпоративные портфели - доступ на создание Корпоративных портфелей.

Рис. 2.15. Окно, определяющее права пользователя

Для изменения параметров пользователя Вам необходимо нажать кнопку [image], после чего откроется описанное выше окно редактора, в котором будут представлены текущие параметры выбранного в списке пользователя.

Для удаления выбранного пользователя из списка достаточно нажать кнопку [image].

2.4.1.2. Импорт в базу пользователей системы имен пользователей домена Windows и групп Active Directory

Возможность импортировать в базу пользователей домена Windows доступна только в том случае, если Сервер системы установлен на Windows XP, 2003, 7 или Vista и запущен с правами пользователя, имеющего доступ к базе пользователей домена (Active Directory).

После нажатия кнопки [image] Импорт пользователей домена, откроется окно импорта пользователей домена (см. рис. 2.16). В секции "Домен Windows" необходимо выбрать домен из выпадающего списка всех сетевых доменов. После чего в секции "Список пользователей/групп" отобразится список всех пользователей выбранного домена. Можно выбрать отдельного пользователя, нескольких или всех пользователей данного домена, выделив их стандартными средствами Windows. Для подтверждения вашего выбора нажмите кнопку [image] Импорт. После чего выбранные пользователи домена и их описание будут добавлены в список пользователей системы.

Редактирование параметров пользователей домена осуществляется аналогично пользователям, введенным вручную. Пользователи домена автоматически входят в группу Everyone.

Рис. 2.16. Окно импорта пользователей домена

После нажатия на кнопку [image] Добавить группы Active Directory в секции «Группы Active Directory» добавление групп происходит аналогично импорту пользователей домена. После нажатия на кнопку [image] Импорт выбранные группы с описанием будут добавлены в список групп в этой секции.

ВАЖНО! При наличии групп Active Directory в списке авторизация доменных пользователей будет осуществляться исключительно на основании членства в этих группах.

Пользователи групп Active Directory будут добавлены в список пользователей после первого удачного входа в систему.

Клиент при подключении всегда в первую очередь пытается подсоединиться как пользователь домена (логин и пароль при этом не запрашиваются). Сервер проверяет на контроллере домена наличие такого пользователя (при наличии хотя бы одной группы Active Directory в списке проверяется наличие группы в домене и членство пользователя в данной группе). Если пользователь не найден (или не является участником группы Active Directory), то появляется стандартное окно авторизации входа в систему, в котором пользователь должен ввести свои имя и пароль (нельзя использовать имя и пароль пользователя домена для авторизации в системе). При подключении должна обеспечиваться связь сервера с контроллером домена.

Примечание

Если пользователь записан в базе пользователей системы как доменный, но Сервер не может получить подтверждения от контроллера домена (нет связи, пользователя удалили из домена, пользователь не включен в группу Active Directory или что-либо другое), то при входе Клиент запросит ввести имя и пароль. Такая ситуация не записывается в протокол Сервера, и администратор должен устранить проблему доменной регистрации или добавить пользователя с обычными именем и паролем в Менеджере пользователей.

Если включена опция "Разрешить первичную авторизацию", при входе нового пользователя в базу будут вноситься реквизиты доменного пользователя.

В окне Менеджера пользователей обычные и доменные имена пользователей помечаются различными иконками (пользователи, которые добавлены через группы Active Directory, помечаются иконками как у пользователей домена Windows).

Для пользователя из домена Windows запрещается редактировать пароль в оболочке Администратора системы.

2.4.1.3. Группы пользователей

Все пользователи системы ЛЗ автоматически входят в группу Everyone. Если Вы впервые инсталлируете систему, то всем пользователям будут даны максимальные права: отправлять сетевые сообщения, создавать Корпоративные портфели, если Вы приобрели этот дополнительный сервис, доступ к Реестру, если Вы приобрели отдельный модуль доступа к Реестру. Максимальные права открыты в группе Everyone.

Для того, чтобы создать группу пользователей, необходимо нажать кнопку [image]. При этом откроется окно редактора параметров группы (рис. 2.17).

Рис. 2.17. Окно редактора параметров группы

В этом окне Вы можете задать следующие параметры:

· Название группы (обязательный параметр), которое однозначно идентифицирует группу;
· Описание (необязательный параметр), которое содержит дополнительную информацию о группе;
· Состав группы (рис. 2.18) (необязательный параметр), который задает список существующих пользователей, входящих в группу;
· Права членов группы (рис. 2.19) (необязательный параметр), которыми может регламентироваться дата и время входа членов группы в систему, а также дополнительные права. Права, которые можно назначать всем членам группы аналогичные правам, которые устанавливаются для отдельных пользователей и описаны выше.

Для изменения и просмотра текущих параметров выбранной в списке группы необходимо нажать кнопку [image], после чего откроется описанное выше окно редактора параметра группы. Для удаления выбранной группы из списка достаточно нажать кнопку [image].

Рис. 2.18. Окно определения состава группы

Рис. 2.19. Окно, определяющее права члена группы

Примечание

1. Пользователь с именем Administrator является системным и его удаление из базы пользователей не допускается. Вам предоставляется возможность изменять только пароль этого пользователя. Этот пользователь обладает всей совокупностью прав в системе независимо от принадлежности его к какой-либо группе.
2. При идентификации пользователя в системе регистр символов в его имени игнорируется, а в пароле - учитывается.
3. Одновременный вход в систему двух пользователей с одинаковым именем не допускается. Исключение составляет пользователь Administrator, который имеет право войти в систему из оболочки Клиента и из оболочки Администратора.
4. Если права пользователя не определены, то ему приписываются права группы, в которую он входит. Если пользователь входит в состав одной или нескольких групп, то ему присваиваются консолидированные права, являющиеся объединением всех прав, заданных для этих групп, и его собственных. Например, если время работы пользователя ограничено интервалом 10:00 - 12:00 и он входит в состав двух групп, время работы в которых ограничивается интервалами 8:00 - 10:00 и 12:00 - 14:00, то этому пользователю будет разрешено работать в интервале 8:00 - 14:00.
5. Удаление группы не приводит к удалению входящих в нее пользователей.

Создание и восстановление резервной копии списка пользователей

Для того чтобы создать резервную копию списка пользователей, Вам необходимо нажать кнопку [image], после чего откроется окно Backup выбора пути и имени файла для резервной копии списка пользователей.

Примечание

При создании резервной копии списка пользователей сохраняется информация об имени пользователя, описании пользователя, пароль и его права. Имена пользователей из домена получаются с сервера системы, т.е. только те, которые зарегистрированы сервером, а не администратором сети. Принадлежность пользователей к группам и список групп не сохраняется.

Для того чтобы восстановить резервную копию списка пользователей, Вам необходимо нажать кнопку [image], после чего откроется окно Restore выбора пути к резервной копии списка пользователей.

Примечание

Вы можете экспортировать список пользователей из текстового файла. Для этого необходимо создать текстовый файл с расширением *.udb и записать в отдельных строках имена пользователей системы. После этого откройте полученный файл как резервную копию списка пользователей для восстановления. После экспорта списка пользователей не забудьте установить пароли и права доступа!

Экспорт базы пользователей в текстовый файл

Для того, чтобы сохранить список пользователей в txt-файл, необходимо нажать кнопку [image], после чего откроется окно выбора пути и имени файла.

Примечание

Полученный текстовый файл удобно просматривать в редакторе Microsoft Excel. При таком просмотре имена пользователей и их описания будут располагаться в отдельных ячейках. Такой вариант является более удобным для просмотра и печати.

2.4.1.4. Группа пользователей системы VERDICTUM

В системах ЛЗ с доступом к системе анализа судебных решений VERDICTUM в списке групп пользователей присутствует группа VERDICTUM.

При первой инсталляции системы группа не содержит ни одного пользователя. Для того, чтобы пользователь получил доступ к системе VERDICTUM, которая вызывается из Клиента системы ЛЗ, необходимо чтобы он являлся членом данной группы.

Количество пользователей этой группы ограничено и определяется количеством приобретенных Вами пользователей. Количество присоединенных к группе пользователей и количество возможных указывается в свойствах группы на закладке "Состав".

В случае уменьшения Вами количества приобретенных доступов к системе VERDICTUM, количество присоединенных ранее пользователей может превышать количество доступных. Тогда информация о количестве пользователей группы будет отображаться красным шрифтом. В этой ситуации необходимо отредактировать список входящих в группу пользователей с помощью кнопки "Удалить".

2.4.2. Менеджер базы прав

Если в поставку системы входят Собственные базы данных пользователя, назначение прав на эти базы и документы, входящие в эти базы, Вы можете осуществить при помощи Менеджера базы прав Администратора системы. Вызов этого режима осуществляется при помощи кнопки [image] главного меню Администратора (табл. 2.1). Детальная работа с Менеджером базы прав описывается в “ЛІГА:Конструктор. Руководство по созданию собственных баз данных в системе ЛIГА:ЗАКОН”.

2.4.3. Менеджер сеансов

Каждый подключившийся к системе пользователь организует сеанс (сессию), который поддерживается на Сервере. Для управления пользовательскими сеансами Вам необходимо активизировать Менеджер сеансов, нажав соответствующую кнопку на панели оболочки Администратора. Менеджер сеансов представляет собой окно (рис. 2.20), в котором отображается список активных пользовательских сеансов.

Крайняя левая колонка этого списка служит для выбора соответствующего сеанса. В графе Пользователь указывается имя пользователя, открывшего сеанс.

Следующая колонка отображает состояние сеанса (заблокирован или нет).

Рис. 2.20. Менеджер сеансов

В графе Подключение указывается время входа пользователя в систему, а в графе Активность - время его последнего обращения к системе.

С помощью Менеджера сеансов Вы можете:

· заблокировать любой сеанс, кроме сеанса пользователя Administrator, открытого из программной оболочки Администратора. При этом соответствующему пользователю передается сообщение о блокировке сеанса, после чего ему запрещается доступ к базе данных, но он может обмениваться сообщениями с другими пользователями;
· разблокировать ранее заблокированный сеанс. При этом пользователю передается соответствующее сообщение и восстанавливается его доступ к базе данных;
· завершить любой сеанс, кроме сеанса пользователя Administrator, открытого из программной оболочки Администратора. При этом пользователю передается сообщение о завершении сеанса и сетевой интерфейс программной оболочки Клиента закрывается;
· послать сообщение одному, нескольким или всем пользователям.

Список активных сеансов в окне Менеджера сеансов обновляется с периодичностью примерно два раза в минуту. Если Вам необходимо принудительно обновить список (получить от Сервера информацию о подключенных пользователях), то Вам достаточно нажать кнопку [image].

В верхнем правом углу окна Менеджера сеансов отображается информация о количестве подключенных к системе пользователей и о максимально допустимом количестве подключений.

Примечание

1. Ограничение на максимально допустимое количество подключений распространяется только на подключения, производимые из оболочки Клиента. Если Вы приобрели сетевой вариант системы ЛЗ с 25 пользовательскими лицензиями, то система позволяет одновременное подключение 25 оболочек Клиента и одной оболочки Администратора.
2. При передаче сообщений из оболочки Администратора (в отличие от оболочки Клиента) возможны два способа:
a. - передача прямого сообщения - для этого Вам необходимо набрать текст сообщения, отметить пользователей, которым Вы хотите его передать, и нажать кнопку [image] . При этом сообщение будет отправлено непосредственно выбранным пользователям;
b. - передача отложенного сообщения - для этого Вам необходимо нажать кнопку [image] и перед Вами откроется окно, содержащее список всех пользователей системы, причем активные пользователи (подключенные в данный момент к Серверу) будут выделены красным цветом. Вы можете выбрать любое количество пользователей (в том числе и неактивных) и передать им сообщение. При этом сообщение передается на Сервер, который транслирует его активным пользователям непосредственно, а для неактивных сохраняет в базе сообщений. При последующем подключении пользователя к Серверу проверяется наличие сообщений для него и, если таковые имеются, они транслируются ему, после чего они удаляются из базы сообщений. В программной оболочке Клиента используется именно этот механизм передачи сообщений.

2.5. Управление сервисами

2.5.1. Корпоративные портфели

Если в поставку системы включена возможность создавать Корпоративные портфели, то для их администрирования Вы можете воспользоваться разделом “Корпоративные портфели”. Чтобы открыть этот раздел, необходимо нажать кнопку [image] в меню Администраторa. Основные команды администрирования всех портфелей расположены в контекстном меню раздела, которое можно вызвать щелчком правой кнопки мыши на пункте “Портфели” (рис. 2.21):

Рис. 2.21. Контекстное меню администрирования всех портфелей

Импортировать Портфель - команда предназначена для импорта Личных портфелей в Корпоративные. При вызове этой команды открывается окно выбора файла Портфеля для импорта. Импорт Портфелей из системы с другим номером электронного ключа невозможен (необходима их сертификация в ООО "ЛИГА ЗАКОН").

Подключить Портфель - команда предназначена для подключения/отключения Портфелей или Личных портфелей, перемещенных в каталог с Корпоративными портфелями вручную (файлы Корпоративных портфелей находятся в каталоге Liga\User и имеют формат имени файла LFld000x.fld). При вызове этой команды открывается окно выбора Портфеля для подключения (рис. 2.22). В окне отображается список портфелей с реквизитами (Файл портфеля, Название портфеля и Автор портфеля) для подключения. Подключение Портфелей из системы с другим номером электронного ключа невозможно (необходима их сертификация в ООО "ЛИГА ЗАКОН").

Рис. 2.22. Окно выбора Портфеля для подключения

Подключить Портфель из архива - команда предназначена для подключения из архивов отключенных Портфелей или из архивов Личных портфелей, перемещенных в каталог с Корпоративными портфелями вручную (файлы Корпоративных портфелей находятся в каталоге Liga\User и имеют формат имени файла LFld000x.fld). При вызове этой команды открывается окно выбора Портфеля для подключения (рис. 2.22). В окне отображается список Портфелей с реквизитами (Файл портфеля, Название портфеля и Автор портфеля) для подключения. После выбора Портфеля для подключения появляется окно со списком архивов этого Портфеля (рис. 2.23). Подключение из архивов отключенных Портфелей из системы с другим номером электронного ключа невозможно (необходима их сертификация в ООО "ЛИГА ЗАКОН").

Рис. 2.23. Окно выбора архива Портфеля для подключения

Удалить права на Портфели - команда предназначена для удаления прав доступа ко всем портфелям.

Контекстное меню для Портфеля имеет несколько другой вид, рис. 2.24:

Рис. 2.24. Контекстное меню тома “Портфели”

Описание команд контекстного меню для работы с портфелем:

· Отключить Портфель - при выборе этой команды выбранный портфель удаляется из списка подключенных, но при этом файлы портфеля не удаляются и его можно потом подключить снова;
· Удалить Портфель - при выборе этой команды портфель будет удален, после чего его уже нельзя будет восстановить;
· Сохранить в архиве - при выборе этой команды создается архив для выбранного портфеля;
· Восстановить из архива - при выборе этой команды появляется окно со списком архивов для выбранного портфеля (рис. 2.23), в котором можно выбрать архив для восстановления или удалить его;
· Права на раздел - команда предназначена для назначения прав доступа только к выбранному портфелю или разделу;
· Права на раздел с вложениями - команда предназначена для назначения прав доступа к выбранному портфелю, а также его разделам или разделу с подразделами.

На каждый портфель (раздел), а также портфель с разделами могут быть назначены права “Владелец”, “Разрешен просмотр”, “Разрешена модификация”. При создании портфеля (раздела) создатель автоматически становится его владельцем.

· “Владелец” Портфеля (раздела) имеет право создавать разделы, редактировать и удалять Портфель (раздел) и назначать права на него;
· “Разрешен просмотр” - пользователь может только читать содержимое Портфеля;
· “Разрешена модификация” - пользователь может редактировать содержимое

Портфеля, но не может удалить его целиком.

Окно назначения прав доступа в Корпоративный портфель, вызываемое из пунктов контекстного меню "Права на раздел" и "Права на раздел с вложениями" аналогично тому, которое вызывается из Клиента системы при создании нового Корпоративного портфеля и при переводе Личного портфеля в Корпоративный (рис. 2.25). Подробно назначение прав и работа с Портфелями описана в "Руководстве пользователя".

Рис. 2.25. Окно установки прав доступа к Корпоративному портфелю

2.5.2. Сервисы

В настоящее время Сервер системы ЛЗ поддерживает два сервиса (службы) - “Планировщик задач” (см. п. 2.2.6) и “Автоответчик” (см. Раздел 1, п. 4.3). Из оболочки Администратора системы Вы можете просматривать текущее состояние этих сервисов, а также активизировать и деактивизировать их. Для управления сервисами Вам необходимо нажать кнопку Сервисы на панели оболочки Администратора системы. После этого перед Вами откроется окно (рис. 2.26), в котором отображается список сервисов и их состояние.

Рис. 2.26. Окно “Сервисы”

Используя кнопку Пуск, Вы можете активизировать выбранный сервис, а используя кнопку Стоп - деактивизировать его. Режимы запуска сервисов при старте Сервера задаются при настройках Сервера системы ЛЗ (см. п. 4.3 Раздела 1 данного руководства). С помощью оболочки Администратора Вы можете изменить текущее состояние сервисов системы.

Примечание

1. При деактивизированном Планировщике выполнение задач обслуживания базы данных невозможно даже из оболочки Администратора системы. Отключать Планировщик целесообразно в тех случаях, когда Вы желаете исключить выполнение задач в течение некоторого промежутка времени.
2. При деактивизированном Автоответчике невозможно автоматическое конфигурирование сетевых параметров Клиентов и Администратора системы путем получения настроек с Сервера. Если система в Вашей сети работает устойчиво и конфигурация сети не изменяется, целесообразно отключать этот сервис, так как при его функционировании потребляется вычислительный ресурс, что снижает производительность Сервера.

2.6. Информационное бюро

“Hot line” состоит из двух рубрик:

· “Горячая линия” - информационные сообщения, поступающие из компании "ЛИГА ЗАКОН";
· “Бюро новостей” - деловые новости в режиме реального времени, которые реплицируются с WEB-сайта ЛIГА.Новости http://news.liga.net/, анонсы информационно-аналитических материалов сайта "Правовые известия" со ссылкой на полный текст на портале ligazakon.ua.

Чтобы открыть этот раздел, необходимо нажать кнопку [image] в меню Администраторa. Перед Вами появится окно “Hot line”, показанное на рис. 2.27. Восклицательный знак в красном кружочке означает наличие непрочитанных сообщений.

Поступающая информация накапливается в рубриках “Горячая линия” и “Бюро новостей” в соответствии с тематическим содержанием их подрубрик.

Содержание рубрики открывается двойным щелчком мышки на ее названии (то же действие выполняется при нажатии мышкой на значок [image]). В верхнем окне справа появляется Список сообщений рубрики.

Рис. 2.27. Содержание подпункта “Сообщения” пункта меню Просмотр

Если выбрать с помощью мышки одно из названий сообщения, его текст откроется в нижнем окне. Анонсы информационно-аналитических материалов сайта "Правовые известия" открываются на портале ligazakon.ua (требуется подключение к Интернету).

В окне, содержащем названия сообщений, можно просматривать все поступившие сообщения или только непрочитанные. Внешний вид списка сообщений можно изменять при помощи подпунктов меню “Большие иконки”, “Маленькие иконки”, “Список” и “Детально” (рис. 2.27).

Сообщения Информационного бюро также можно сортировать по различным признакам: по названию, по статусу, по дате, по автору, по рубрике.

Каждое сообщение можно “Установить как прочитанное” или “Установить как непрочитанное”, см. рис. 2.27.

Описанные выше действия можно также выполнять при помощи контекстного меню, которое вызывается по правой кнопке мышки в окне со списком сообщений.

Вы можете изменить цвет рубрики, воспользовавшись командой “Цвет...” в контекстном меню для рубрики или в подменю пункта меню Редактировать.

Пользователь может обновлять рубрики “Горячая линия” и “Бюро новостей” принудительно с помощью:

· команды “Обновить” (рубрики, сообщения) пункта меню Просмотр;
· кнопки “Обновить” окна “Hot line”;
· пункта “Обновить” контекстного меню.

При этом могут появиться новые подрубрики, которые будут содержать актуальные новости.

Вы можете также выделить фрагмент текста сообщения (курсором мышки) или все сообщение (команда контекстного меню "Выделить все сообщение"), после чего воспользоваться командой "Скопировать в Clipboard". Текст сообщения или его выделенный фрагмент будет занесен в буфер обмена - его можно вставлять в текст в любом текстовом редакторе, например, Word. Заметим, что иллюстрации в буфер обмена не копируются.

В подпункте “Настройки” пункта меню Просмотр можно:

· выбрать шрифт и его размер для каждого из окон Информационного бюро;
· определить для рубрик и подрубрик, каким образом будет отображаться количество прочитанных и непрочитанных сообщений в них;
· на закладке “Настройки” можно установить интервал проверки поступления новых сообщений, а также определить необходимость отображения рубрик. Если опции “Показывать при старте сообщения...” отключены, окно Информационного бюро не появляется первым при старте системы ЛЗ.


2.2. Задачи обслуживания баз данных системы

Управление задачами обслуживания базы данных системы осуществляется из окна Менеджера задач, который позволяет запускать задачи на выполнение, останавливать и изменять их параметры. При открытии окна перед Вами появляется список задач, которые могут выполняться системой. В настоящее время система ЛЗ поставляется с набором задач, который условно можно классифицировать:

· Общие задачи – задачи модификации и проверки баз данных, работы с электронной почтой (рис. 2.3);
· Сервисные задачи – задачи резервирования и восстановления работоспособности базы в случае повреждений (рис. 2.4);

Рис. 2.3. Окно Менеджера задач с закладкой “Общие”

Рис. 2.4. Окно Менеджера задач с закладкой “Сервисные”

· Собственные базы – задачи создания, модифицирования и сопровождения собственных баз данных.
· Группы заданий – возможность создавать группы заданий, назначая в группе очередность выполнения каждой задачи сразу после выполнения предыдущей. Более подробно создание групп заданий описано в п. 2.6.2 данного Раздела.

В левой колонке списка отображается состояние соответствующей задачи:

- задача находится в состоянии ожидания (синий флажок);

- задача выполняется (зеленый флажок);

- задача отключена.

В графе Название задания поясняется смысл задачи обслуживания. Графа Название этапа отображает текущий этап выполняемой задачи. В графах % Этап и % Задание отображается процент выполнения этапа и задачи целиком соответственно для выполняемой задачи. В графе Последний старт указывается дата и время последнего запуска задачи. В графе Длительность для неактивной задачи указывается продолжительность последнего выполнения, а для выполняемой - текущее время выполнения задачи. Графа Последний результат содержит значение кода возврата, полученное при последнем выполнении неактивной задачи или текущее для этапа выполняемой задачи. В графе Следующий старт указывается дата и время следующего старта задачи по расписанию.

Примечание

1. Завершение работы оболочки Администратора во время выполнения какой-либо задачи обслуживания не приводит к ее остановке, выполнение задачи продолжается под управлением Планировщика задач.
2. Вы можете настраивать расписание выполнения задач. Выполнение задач по расписанию производится сервисом Планировщик задач.
3. Все задачи обслуживания базы данных (кроме задач "Получение обновлений и отправка результатов" и “Информбюро: прием сообщений”) выполняются в режиме монопольного захвата базы, поэтому при запуске задачи все активные Клиенты (в том числе и Администратор) получают уведомление о блокировке базы и их запросы не обслуживаются. Клиент при попытке подключиться к Серверу во время выполнения задач обслуживания получит отказ. После завершения выполнения задачи активные Клиенты получают уведомление о разблокировке базы и доступ к данным открывается. (В окне с сообщением системы имеется кнопка Выход, которая позволяет закрыть это окно).
4. Если выполняется одна из задач: “Прием в базу”, "Восстановление полнотекстового индекса", "Оптимизация базы”, “Создание и прием собственных посылок”, “Создание резервной копии базы собственных документов”, “Восстановление резервной копии базы собственных документов”, то без особых причин эти задачи прерывать не рекомендуется.
5. Если двум задачам задать одно и то же стартовое время или стартовое время одной задачи окажется меньше, чем время окончания другой, то Сервер выполнит по расписанию только одну задачу.

Для запуска на выполнение выбранной в списке задачи Вам достаточно нажать кнопку [image], а для ее остановки [image]. Для отключения задачи Вам достаточно установить на нее курсор и нажать кнопку [image]. Это целесообразно в том случае, если у Вас настроен запуск задач по расписанию и Вы хотите отключить выполнение данной задачи. Повторное нажатие на эту кнопку вернет задачу в состояние ожидания и сделает ее доступной для запуска. Кнопка [image] используется для просмотра и изменения параметров выбранной задачи. Подробно работа с Редактором задач и Группами заданий описана в п. 2.6 этого Раздела.

2.2.1. Прием обновлений

2.2.1.1. Прием в базу

Задача "Прием в базу" относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Эта задача предназначена для пополнения базы данных Вашей системы документами, поступающими из ООО "ЛИГА ЗАКОН" в виде отдельных файлов-обновлений (посылок).

Получение обновлений с помощью электронных средств подробно описано в Разделе 3 данного руководства. Обновление системы с помощью DVD-диска будет рассмотрено в Разделе 4.

Вы можете изменить способ получения обновлений в любой момент. Эти вопросы решаются в рабочем порядке в Службе поддержки Абонентов Всеукраинской сети ЛІГА:ЗАКОН (тел. (044) 538-01-03 - многоканальный, http://support.ligazakon.ua).

Посылки передаются Вам электронным способом. Обновление системы также можно проводить с помощью DVD-дисков.

Файлы-обновления имеют расширение ADD, BBS, CMP (стандартные посылки) или PVT (индивидуальные посылки), которые содержат тексты новых или измененных документов. Они предназначены для приема в базу данных системы ЛЗ. Файлы обновлений необходимо поместить в каталог, задаваемый параметром “New Texts” настроек Сервера системы ЛЗ. По умолчанию этот каталог имеет имя Text_new\ и является подкаталогом того каталога, в котором расположена система ЛЗ.

В системе предусмотрена возможность автоматического приема обновлений электронными средствами: с HTTP-сервера и по электронной почте. Настройка параметров автоматического приема обновлений электронными средствами детально рассмотрена в п. 4.6.1 Раздела 1 данного руководства. Автоматический прием обновлений может осуществляться на этапе 1 выполнения задачи “Прием в базу” или при запуске отдельной задачи "Получение обновлений и отправка результатов" (см. п. 2.1.2 этого Раздела).

Посылки-обновления из ООО "ЛИГА ЗАКОН" поступают ежедневно (в рабочие дни, в ночное время), поэтому, если Вы получаете обновления электронными средствами, необходимо запускать задачу "Прием в базу" раз в сутки. Для настройки автоматического запуска задачи воспользуйтесь Планировщиком (см. п. 2.6.1 данного Раздела).

Выполнение задачи “Прием в базу” осуществляется в несколько этапов:

Этап 1

Прием обновлений электронными средствами

Этот этап выполняется, если в настройках Сервера активизирована опция "Принимать обновления перед выполнением задачи "Прием в базу"" и на закладке HTTP/E-mail вписаны параметры для приема обновлений электронными средствами.

Если основным способом приема выбран прием с HTTP-сервера, то файлы, необходимые для приема, скачиваются в каталог для приема обновлений (обычно это каталог Text_new).

Если основным способом приема выбран прием по электронной почте (опция "Основной способ приема" установлена в группе E-mail), то осуществляется соединение с почтовым сервером (POP) и забираются все письма, пришедшие с адреса, заданного параметром "Отправитель" (по умолчанию - robot@liga.kiev.ua), на адрес абонента. Письма складываются в рабочий каталог (задается параметром "Work", обычно это каталог Work). Далее осуществляется разборка писем, во время которой из них извлекаются вложения (attachments).

Все файлы с расширениями ADD, PVT и BBS из каталога Work перемещаются в каталог для приема обновлений (задается параметром "New Texts", обычно это каталог Text_new).

Если в настройках Сервера на закладке HTTP/E-mail не установлена опция "Принимать обновления перед выполнением задачи "Прием в базу", то этап 1 приема обновлений пропускается.

Этап 2

Поиск обновлений

В каталоге, заданном параметром “New Texts” (по умолчанию Text_new\), производится поиск файлов-посылок.

Этап 3

Обработка посылок

Состоит из 3-х основных стадий

3.1 Неблокирующая работу пользователей стадия приема (80-90% от общего времени приема):

а) прием карточек в базу данных без реального изменения базы, в журнал \Data\ хххх.db3-journal,

б) прием текстов во временные библиотеки \Work\TextUpdate\хххххххх.llb

в) индексация текстов во временный индекс \Index\ ..._new.dat

3.2 Блокирующая работу пользователей стадия (10-20% от общего времени приема):

а) запись изменений в карточках в базу данных

б) копирование измененных библиотек текстов в основное хранилище

в) замена полнотекстового индекса модифицированной копией

г) фиксация имен посылок, обработанных в первой подзадаче, с удалением из приемного директория

Стадии 1 и 2 могут повторяться, если количество карточек документов в посылках превышает граничное число (вычисляемое в зависимости от памяти компъютера).

3.3 Стадия "Проверка по истории посылок" (1-2% от общего времени приема)

Запускается только при успешном выполнении первых двух стадий приема.

Примечание

Все успешно принятые посылки сохраняются в каталоге, задаваемом параметром “Save Sends” настроек Сервера системы ЛЗ (по умолчанию - каталог SaveArc). Вам необходимо обеспечить достаточный объем дискового пространства для поддержки этой функции. В служебном файле \Data\Common.ini в секции BackUp можно настраивать, сохранять ли посылки в этой папке и в течение какого времени их хранить. По умолчанию система сохраняет принятые посылки в течение 60 дней.

В конце приема в базу система производит проверку по истории посылок, и в том случае, если есть пропущенные посылки, в каталоге Log будет сформирован проверочный файл (файл с именем вида 000xxxxx.CHK, где xxxxx - регистрационный номер Вашего комплекта системы), содержащий список пропущенных посылок. Если в качестве основного способа приема выбран HTTP, то имена пропущенных посылок в CHK-файле не фиксируются. Они будут выбраны с HTTP-сервера на основании анализа истории посылок history.ldx.

Протокол приема посылок Receive.LOG, на основании которого можно проанализировать, какие из посылок были успешно обработаны системой, а какие нет, хранится в каталоге, заданном параметром “Log” настроек Сервера системы ЛЗ (по умолчанию - каталог Log\).

Кроме приема стандартных посылок (файлы с расширениями ADD, BBS) при выполнении задачи “Прием в базу” осуществляется также обработка индивидуальных посылок (файлы с расширением PVT), передаваемых Вам при обработке проверочных файлов, а также посылок, предназначенных для Собственных баз данных системы ЛЗ (если у Вас вариант системы с Конструктором Баз Данных).

Примечание

1. Вы можете настроить автоматическую отправку сообщений на Ваш E-mail в случаях, когда при выполнении задачи "Прием в базу" возникли ошибки или были обнаружены отсутствующие файлы. Для этого необходимо установить опцию "Отправлять сообщения по e-mail при аварийном завершении" в настройках параметров задачи (см. п. 2.6.1), а также задать параметры в Конфигурации Сервера на закладке HTTP/E-mail в группе Отправка, результатов выполнения задач (см. п. 4.6.2 Раздела 1).
2. При нормальном завершении задачи каталог, задаваемый параметром "New_Texts" (по умолчанию - каталог Text_new\), должен быть пустым, а резервные копии посылок должны находиться в каталоге, задаваемом параметром “Save Sends” (по умолчанию - каталог SaveArc\).
3. В случае, когда в каталоге Text_new\ остаются посылки (расширение посылок, которые не могут быть приняты в систему, изменяется на BAD), рекомендуем посмотреть последние сообщения системы в протоколе Receive.LOG (новые сообщения добавляются в конец файла).

Перечень типов посылок, которые принимаются Вашей системой, Вы можете видеть внизу в окне Менеджера задач. Виды посылок перечислены в таблице 2.2.

Каждый пользователь получает определенный набор посылок в зависимости от того, какую версию системы он приобрел.

В результате обработки Вашего проверочного файла для Вас будут сформированы индивидуальные посылки, например, 00248*.PVT, если “248” - регистрационный номер Вашего комплекта системы.

Таблица 2.2

Виды посылок

Тип посылки | Название Информационного ресурса или механизма, для которых предназначены посылки
ALLxxxxx.add | СЛУЖЕБНАЯ БАЗА (ДЛЯ ВЕРСИИ 9)
BIZxxxxx.add | БИЗНЕС
BKDxxxxx.add | ЭНЦИКЛОПЕДИЯ БУХГАЛТЕРА
BKPxxxxx.add | ПУТЕВОДИТЕЛЬ ПО ПРОЦЕДУРЕ БАНКРОТСТВА
BKTxxxxx.add | БАНКРОТСТВО И ЛИКВИДАЦИЯ ПРЕДПРИЯТИЙ
BMIxxxxx.add | ВЕДОМОСТИ БУХГАЛТЕРА
BSTxxxxx.add | СИТУАЦИИ ДЛЯ БУХГАЛТЕРА
BUHxxxxx.add | БУХГАЛТЕР
BZIxxxxx.add | БУХГАЛТЕР & ЗАКОН
DGNxxxxx.add | ТИПОВЫЕ ДОГОВОРЫ
DIGxxxxx.add | КОНСУЛЬТАЦИИ
FNCxxxxx.add | ФИНАНСОВАЯ ИНФОРМАЦИЯ
FRMxxxxx.add | ФОРМЫ ДЛЯ БУХГАЛТЕРА
GBHxxxxx.add | ГЛАВНЫЙ БУХГАЛТЕР
GORxxxxx.add | СТОЛИЧНОЕ ЗАКОНОДАТЕЛЬСТВО
IZAxxxxx.add | ЮРИСТ & ЗАКОН
IZBxxxxx.add | ДЕБЕТ-КРЕДИТ
IZCxxxxx.add | УПРАВЛЕНИЕ ПЕРСОНАЛОМ
IZDxxxxx.add | АДВОКАТ БУХГАЛТЕРА
JIGxxxxx.add | ЮРИДИЧЕСКИЕ КОНСУЛЬТАЦИИ
KDKxxxxx.add | КОММЕНТИРОВАННЫЕ КОДЕКСЫ
KDXxxxxx.add | КОДЕКСЫ
KNOxxxxx.add | НАЛОГОВЫЕ ЗНАНИЯ
LAWxxxxx.add | ОБЩЕЕ ЗАКОНОДАТЕЛЬСТВО
LINxxxxx.add | ПУТЕВОДИТЕЛЬ ПО НАЛОГООБЛОЖЕНИЮ
LZUxxxxx.add | УРОКИ ЛІГА:ЗАКОН
MBHxxxxx.add | БУХГАЛТЕР
MITxxxxx.add | ТАМОЖЕННОЕ ПPАВО
MONxxxxx.add | МОНИТОРИНГ ЗАКОНОДАТЕЛЬСТВА
NKUxxxxx.add | НАЛОГОВЫЙ КОНСУЛЬТАНТ
OBLxxxxx.add | PЕГИОНЫ
OSTxxxxx.add | БАЗА ОШИБОК И СПОРНЫХ СИТУАЦИЙ
PRExxxxx.add | СУДЕБНЫЕ ПРЕЦЕДЕНТЫ
PRKxxxxx.add | ЗАКОНОПРОЕКТЫ И КОММЕНТАРИИ
RZNxxxxx.add | PАЗНОЕ
SFOxxxxx.add | БИБЛИОТЕКА МСФО
SITxxxxx.add | СИТУАЦИИ ДЛЯ БИЗНЕСА
SLPxxxxx.add | СЛУЖБА ПЕРСОНАЛА
SPLxxxxx.add | ЮРИДИЧЕСКИЕ СПРАВОЧНИКИ
SPRxxxxx.add | СПPАВОЧНИКИ
SUDxxxxx.add | СУДЕБНАЯ ПРАКТИКА
TAXxxxxx.add | НАЛОГИ В УКPАИНЕ
TOGxxxxx.add | ИСКУССТВО ОБОРОНЫ
TPRxxxxx.add | ПРОВОДКИ
TRMxxxxx.add | ТЕРМИНОЛОГИЧЕСКИЙ СЛОВАРЬ
UGDxxxxx.add | МЕЖДУНАPОДНЫЕ СОГЛАШЕНИЯ
VLUxxxxx.add | ВЛАСТЬ УКРАИНЫ
ZORxxxxx.add | ИТОГИ НЕДЕЛИ
NWSxxxxx.bbs | ИнформБюро: новости
BBSxxxxx.bbs | ИнформБюро: горячая линия
ETLxxxxx.cmp | Системные посылки для ведения эталонного списка документов
хxxxxnnn.pvt | Индивидуальные посылки. Используются для устранения рассогласований с Эталонной базой данных (xxxxx - регистрационный номер системы, nnn - порядковый номер посылки)

2.2.1.2. Получение обновлений и отправка результатов

Данная задача относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Задача не блокирует работу с системой.

Выполнение этой задачи осуществляется в два этапа:

· прием обновлений с HTTP-сервера или из почтового ящика электронной почты;
· отправка проверочных файлов поставщику системы.

Настройка параметров HTTP и почтового соединения осуществляется в настройках Сервера на закладке HTTP/E-mail и детально рассмотрена в пункте 4.6 Раздела 1 данного Руководства.

Примечание

Для закачивания новостийных сообщений (файлы с расширением BBS) задачу "Получение обновлений и отправка результатов" целесообразно выполнять ежечасно перед автоматическим приемом их в ИнформБюро (см. Раздел 1, п. 4.7.) или перед выполнением задачи "ИнформБюро:Прием сообщений". Как настроить Планировщик описано в п. 2.6.1.

Автоматическое получение обновлений с HTTP-сервера

Если прием обновлений c HTTP-сервера выбран в качестве основного, то на этом этапе осуществляется соединение с HTTP-сервером (по умолчанию - update.liga.net) и файлы-обновления с расширениями ADD, BBS и PVT с HTTP-сервера выгружаются в каталог для приема обновлений.

Автоматический прием обновлений из почтового ящика

На этом этапе осуществляется соединение с почтовым сервером (POP) и забираются все письма, пришедшие с адреса, заданного параметром "Отправитель" (по умолчанию - robot@liga.kiev.ua), на адрес абонента. Письма складываются в подкаталог MailBox каталога для приема обновлений (задается параметром "New Texts", обычно это каталог Text_new). Подкаталог MailBox создается автоматически.

Далее осуществляется разборка писем, во время которой из них извлекаются вложения (attachments). Они накапливаются в подкаталоге MailTexts каталога для приема обновлений. Подкаталог MailTexts создается автоматически.

Все файлы с расширениями ADD, BBS и PVT из подкаталога MailTexts перемещаются в каталог для приема обновлений.

Примечание

Опция "Принимать обновления перед выполнением задачи "Прием в базу" в настройках Сервера HTTP/E-mail не влияет на выполнение задачи "Получение обновлений и отправка результатов". Она предназначена только для отключения/включения 1 этапа выполнения задачи "Прием в базу".

Автоматическая отсылка проверочных файлов

Если в каталоге после выполнения задачи образовался проверочный файл, то на втором этапе выполнения задачи "Получение обновлений и отправка результатов" осуществляется отправка этого файла в ООО "ЛИГА ЗАКОН".

Если прием обновлений с HTTP-сервера выбран в качестве основного, то автоматическая отправка CHK-файлов проводится на HTTP-сервер.

Если в качестве основного приема обновлений выбран прием обновлений по E-mail, то автоматическая отправка CHK-файлов проводится по адресу, указанному в поле "Получатель" (по умолчанию - check@liga.kiev.ua) окна настроек Сервера, после чего его расширение меняется на ^chk. Файл отправляется в виде вложения в письмо в кодировке UUEncode.

Примечание

Опция "Автоматически отправлять CHK-файл при проверке" в настройках Сервера HTTP/E-mail не влияет на выполнение задачи "Получение обновлений и отправка результатов". Она предназначена только для отключения/включения 3 этапа выполнения задачи “Общая проверка базы”.

Если для связи с провайдером, предоставляющим Вам услуги электронной почты, Вы используете удаленное соединение по модему (Dial-up connection), то Вам необходимо настроить соответствующее соединение.

При запуске в Администраторе задачи "Получение обновлений и отправка результатов" устанавливается удаленное соединение с провайдером и по соответствующим настройкам параметров почтового соединения Сервера системы ЛЗ происходит отбор почтовых сообщений из Вашего почтового ящика и отсылка проверочного файла, полученного в результате выполнения задачи “Общая проверка базы”. Если при выполнении задачи произошел разрыв соединения с провайдером, дождитесь завершения задачи и запустите ее снова.

2.2.1.3. ИнформБюро: Прием сообщений

Данная задача относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Задача не блокирует работу с системой.

Эта задача предназначена для приема в базу сообщений для рубрик “Горячая линия” и “Бюро новостей”.

Посылки передаются Вам электронным способом. Обновления для этих рубрик - это файлы с расширением BBS. Файлы обновлений необходимо поместить в каталог, задаваемый параметром “New Texts” настроек Администратора системы ЛЗ. По умолчанию этот каталог имеет имя Text_new\ и является подкаталогом того каталога, в котором расположена система ЛЗ. Автоматически обновления помещаются в Text_new\ после выполнения задачи "Получение обновлений и отправка результатов" (см. п. 2.1.2).

Задача выполняется автоматически в фоновом режиме, если установлена опция "Интервал проверки новостей" на закладке Информационное бюро в настройках Сервера (см. п. 4.7 Раздела 1).

2.2.2. Проверка целостности базы

2.2.2.1. Общая проверка базы

Задача "Общая проверка базы" относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Задача блокирует работу с системой.

Эта задача предназначена для проверки информационной целостности Вашей базы данных.

Рекомендуем выполнять общую проверку базы раз или два раза в неделю для того, чтобы поддерживать систему в актуальном состоянии.

Проверка производится в несколько этапов:

Этап 1

Проверка согласованности главной таблицы

базы данных и библиотек текстов документов

На этом этапе обнаруживаются и фиксируются ситуации отсутствия текста документа для записи в главной таблице базы данных.

Этап 2

Обработка таблицы истории принятых посылок

На этом этапе в проверочном файле фиксируются все пропуски приема посылок, вызванные их поврежденностью либо отсутствием.

Если по окончании работы рассматриваемой задачи Вы получили код возврата, свидетельствующий об ошибке, то в каталоге, задаваемом параметром “Log”, формируется так называемый проверочный файл (файл с именем вида 000хxxxx.CHK, где xxxхx - регистрационный номер Вашего комплекта системы). Этот файл необходимо передать Вашему поставщику системы ЛЗ (дилеру или непосредственно в ООО "ЛИГА ЗАКОН"), после чего для Вас будут сформированы индивидуальные посылки (файлы с именем XXXXXnnn.PVT, где XXXXX - регистрационный номер комплекта системы, а nnn - порядковый номер посылки). Когда эти посылки будут обработаны задачей “Прием в базу”, целостность Вашей базы данных будет восстановлена.

Этап 3

Автоматическая отправка проверочного файла

Если в настройках Сервера HTTP/E-mail установлена опция "Автоматически отправлять CHK-файл при проверке" и при проверке базы был сформирован проверочный файл, то осуществляется отправка этого файла в ООО "ЛИГА ЗАКОН".

Если прием обновлений с HTTP-сервера выбран в качестве основного, то автоматическая отправка CHK-файлов проводится на HTTP-сервер. Если в качестве основного приема обновлений выбран E-mail, то автоматическая отправка CHK-файлов проводится по адресу, указанному в поле "Получатель" (по умолчанию - check@liga.kiev.ua) окна настроек Сервера, после чего его расширение меняется на ^chk.

Автоматическая отправка проверочного файла также осуществляется при выполнении отдельной задачи "Получение обновлений и отправка результатов" (см. п. 2.1.2).

2.2.2.2. Эталонная проверка базы

Задача "Эталонная проверка базы" относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач.

Задача блокирует работу с системой.

В процессе выполнения этой задачи производятся проверка по эталонному списку и три этапа Общей проверки.

Эталонный список формируется ООО "ЛИГА ЗАКОН" и передается клиентам в инсталляционном пакете, а затем поддерживается в актуальном состоянии на машинах пользователей с помощью посылок вида ETL*.CMP.

Посылки на модификацию эталонного списка имеют жесткую сквозную нумерацию. Они принимаются в систему как и обычные посылки, но только в порядке строгой очередности.

При проведении проверки по эталонному списку контролируются только те документы, дата модификации которых меньше либо равна дате выпуска последней принятой посылки, модифицировавшей эталонный список. Если разница между датой обновления эталонного списка и датой последнего приема документов составляет более 7 дней, то такой эталонный список считается устаревшим и проверка по нему не производится, о чем делается соответствующая запись в лог-файле.

Выполнение задачи “Эталонная проверка базы” занимает порядка 40 - 80 минут. Оптимальная частота ее проведения составляет один раз в неделю или один раз в две недели.

2.2.2.3. Проверка библиотек текстов

Данная задача относится к общим задачам администрирования и находится на закладке Общие в Менеджере задач. Данную задачу необходимо выполнять для выявления причины сбоев в системе, чтобы локализовать возникшую проблему.

Задача блокирует работу с системой.

При выполнении этой задачи осуществляется проверка целостности библиотек текстов документов. Если в результате проверки будут обнаружены поврежденные библиотеки, то они удаляются из базы, а задачей формируется соответствующий код возврата. При последующей общей проверке базы рассогласование будет обнаружено и сформируется проверочный файл с запросом на пополнение базы данных.

2.2.2.4. Оптимизация базы

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Рекомендуется запускать для уменьшения размеров и для увеличения производительности работы с базой. Делает vacuum файла базы LZBase.db3. Проверяет дубли в библиотеках текстов. Проводится полная дефрагментация полнотекстного индекса.

2.2.2.5. Проверка читаемости текстов в библиотеках

Задача "Проверка читаемости текстов в библиотеках" относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Эта задача предназначена для проверки читаемости текстов в библиотеках. Рекомендуется запускать в том случае, если при приеме обновлений возникают проблемы с записью текстов в библиотеки.

В процессе выполнения задачи происходит проверка каждой библиотеки, которая заключается в последовательном выполнении следующих этапов:

- получение списка файлов библиотеки;

- распаковка содержимого библиотеки в каталог Work;

- сверка списка файлов библиотеки и содержимого каталога Work;

- распаковка каждого файла библиотеки в памяти.

Если результат выполнения хотя бы одного из этапов не является успешным, то дальнейшая проверка библиотеки прерывается, библиотека считается поврежденной и автоматически удаляется. В этом случае после выполнения задачи "Проверка читаемости текстов в библиотеках" автоматически запускается общая проверка базы и создается проверочный файл с отсутствующими текстами. Результатом выполнения задачи является сообщение "Есть отсутствующие файлы".

Для того, чтобы отключить автоматическое удаление поврежденной библиотеки, в файле Common.ini каталога Data установите следующее значение параметра:

[Common]

LongCheckDelBad=0

В этом случае после выполнения задачи "Проверка читаемости текстов в библиотеках" также автоматически запускается общая проверка базы и создается проверочный файл с отсутствующими текстами. Результатом выполнения задачи является сообщение "Есть отсутствующие файлы".

2.2.3. Индексация базы

2.2.3.1. Восстановление полнотекстового индекса

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Задача “Восстановление полнотекстового индекса" является наиболее длительной и ресурсоемкой из всех сервисных задач системы ЛЗ. Эту задачу необходимо выполнять ТОЛЬКО в тех случаях, когда по каким-либо причинам полнотекстовый индекс базы данных был разрушен. Внешне это может выражаться в неправильном поиске по словам из текстов либо словам из названий документов. В ходе полнотекстовой индексации базы полностью перестраивается значительный массив информации, включающий в себя несколько служебных файлов, размер которых достигает сотен мегабайт. Поэтому мы рекомендуем Вам перед проведением этой задачи обеспечить достаточно свободного места на диске (согласно техническим требованиям) и с помощью дефрагментации диска обеспечить непрерывность свободного участка. На момент выполнения задачи компьютер должен быть максимально разгружен. Выгрузите из памяти все неиспользуемые программы. Желательно приостановить работу антивирусного монитора, так как его контроль над файловыми операциями значительно замедляет выполнение задачи.

Если по каким-либо причинам восстановление полнотекстового индекса было прервано, то будет недоступен поиск по словам из текста и словам из названий документов.

Внимание!

Во время выполнения задачи "Восстановление полнотекстового индекса" мы не рекомендуем запускать другие приложения на Вашем компьютере.

2.2.3.2. ИнформБюро: Восстановление индексов

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача не блокирует работу с системой.

Эта задача предназначена для восстановления поврежденных индексов “Информационного бюро” системы ЛЗ. При этом все прочитанные соообщения устанавливаются как “непрочитанные”.

2.2.4. Резервное копирование

2.2.4.1. Создание резервной копии

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Задача создания резервной копии предусматривает копирование содержимого папок DATA, INDEX, TEXTS в отдельный каталог, который определяется параметром [BackUp] на закладке "Маршруты" в Конфигурации Сервера (по умолчанию это каталог \BackUp).

Выполнение задачи резервного копирования производится в несколько этапов:

Этап 1

Производится сбор информации о суммарном размере копируемых файлов, проверяется наличие требуемого свободного места на диске, на который будет производиться копирование.

Объем копируемых файлов зависит от того, какая система ЛЗ у Вас установлена и может составлять до 16,5 Гб дискового пространства.

Этап 2

Если в файле common.ini в группе [FullBackUp] переменная CheckData не установлена в 0, задача проверяет целостность главного файла данных. На этом этапе задача также проверяет целостность полнотекстового индекса. При наличии ошибок задача завершает работу.

Этап 3

Копируются директории DATA, INDEX, TEXTS со всеми поддиректориями. По завершении копирования создается файл Restore.lst в каталоге BackUp\Data\, содержащий имена скопированных файлов и их контрольные суммы. Восстановление резервной копии будет производиться при наличии всех файлов, указанных в этом списке со сверкой их контрольных сумм.

2.2.4.2. Восстановление из резервной копии

Данная задача относится к сервисным задачам администрирования и находится на закладке Сервисные в Менеджере задач.

Задача блокирует работу с системой.

Задача восстановления из резервной копии позволяет (при наличии корректно созданной резервной копии и необходимого свободного места на диске) вернуть базу данных в состояние, при котором создавалась копия.

Местоположение резервной копии определяется параметром [BackUp] на закладке "Маршруты" в Конфигурации Сервера (по умолчанию это каталог \BackUp).

При выполнении задачи восстановления из резервной копии проверяется корректность резервной копии по файлу Restore.lst в каталоге BackUp\Data\. При отсутствии файлов из списка или несоответствии их контрольных сумм задача прекращает свою работу. Копии каталогов DATA, INDEX, TEXTS со всеми подкаталогами переписываются в соответствующие каталоги, указанные в настройках сервера (сетевая версия) / администратора (локальная версия).

Внимание!

Запуск задачи восстановления из резервной копии НЕЛЬЗЯ включать по расписанию и в групповые задачи. Данная задача предназначена для восстановления работоспособности системы в ручном режиме в аварийных ситуациях.

Прерывание задачи "Восстановление из резервной копии", особенно на этапе копирования отдельных файлов, может привести к невозможности дальнейшего корректного функционирования БД.

Задачи создания резервной копии и восстановления из резервной копии так же, как и деинсталлятор системы, не удаляют файлы созданной резервной копии.

После восстановления из резервной копии системы ЛЗ анализируется папка SaveArc на наличие посылок, принятых после даты создания резервной копии, найденные посылки переносятся в папку Text_New и принимаются в базу при следующем приеме.

2.2.5. Просмотр протоколов работы

Для просмотра протоколов работы (лог-файлов) системы определенной структуры - LigaSrv.log, Liga.log, LigaAdm.log, Receive.log, Mail.log и истории приема посылок используется кнопка просмотра протоколов работы, доступная из главного окна Администратора системы, или кнопка [image] в Менеджере задач.

Режимы просмотра протоколов

Центральное окно содержит закладки для просмотра истории приема обновлений, почтового протокола, протоколов поступлений, Администратора, Клиента, Сервера (рис. 2.5). Для просмотра отдельно выбранного файла используется кнопка [image], при этом открывается закладка с именем выбранного файла.

Рис. 2.5. Просмотр протоколов работы системы

Каждая закладка содержит окно дерева и окно списка или графика сообщений (в зависимости от режима). Исключение составляют закладки "Протокол поступлений" и "Протокол Mail, FTP" - в них предоставляется возможность просмотра текстовых файлов Receive.log и Mail.log.

Содержимое дерева сообщений зависит от режима просмотра дерева (управляется кнопками Панели Инструментов) и служит для быстрого перехода на соответствующее сообщение.

Окно дерева отображает даты (а в некоторых режимах и время) сообщений. Выбор элемента дерева позволяет найти первое сообщение из списка на конкретную дату (а в некоторых режимах и на конкретное время).

Содержимое списка сообщений зависит от того, какая опция просмотра сообщений выбрана (задается включением/отключением пункта “Полный перечень сообщений” в меню “Опции”). Если включен “Полный перечень сообщений”, то в списке всегда отображаются все сообщения независимо от того, какой режим просмотра выбран в дереве сообщений.

Меню “Опции” состоит из следующих пунктов:

§ “Выделять сообщения цветом” - позволяет отключить/включить режим использования цветов в списке сообщений;
§ “Полный перечень сообщений” - установка/отключение этой опции влияет на то, будет ли в списке отображаться весь перечень сообщений, или только тех, которые относятся к текущему режиму просмотра дерева;
§ “Показывать с последнего дня” - установка/отключение этой опции влияет на то, будет ли при переходе в новый режим курсор устанавливаться на первое сообщение из списка или на первое сообщение последнего дня.

При первом выборе закладки с необходимым протоколом всегда отображается полный список сообщений.

Существует два режима просмотра протоколов:

Просмотр списка сообщений

§ перечень сообщений о приеме посылок,
§ перечень сообщений об ошибках,
§ перечень сообщений о соединениях пользователей,
§ перечень сообщений, относящихся к администрированию пакета,
§ полный перечень сообщений,
§ перечень сообщений, отобранных по указанному критерию.

Статистика сообщений

§ статистика приемов (график),
§ статистика индексаций базы данных (график).

В этих режимах доступны такие виды отображений:

- перечень сообщений о приеме посылок

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений, относящихся к приему пополнений.

Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к приему пополнений, если данная опция отключена.

- перечень сообщений об ошибках

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений об ошибках.

Выбор элемента дерева позволяет найти соответствующее сообщение об ошибке в списке.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к сообщениям об ошибках, если данная опция отключена.

- перечень сообщений о соединениях пользователей

Если нажата эта кнопка, то окно дерева отбражает даты и время сообщений, относящихся к соединению и разъединению пользователей.

Выбор элемента дерева позволяет найти соответствующее соединение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции "Полный список сообщений" или перечень сообщений, относящихся только к обращению пользователей к системе, если данная опция отключена.

- перечень сообщений, относящихся к администрированию пакета

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений, относящихся к административным сообщениям (сообщения проверок, индексации базы, проверок библиотек и т. п.).

Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к административным задачам, если данная опция отключена.

- все сообщения в этом файле

Если нажата эта кнопка, то окно дерева отображает даты сообщений.

Окно списка содержит полный перечень сообщений данного файла вне зависимости от состояния опции “Полный список сообщений”.

- перечень сообщений, отобранных по указанному критерию

Если нажата эта кнопка, то окно списка содержит только перечень отобранных сообщений.

Данный режим позволяет отобрать сообщения из общего списка по следующим критериям:

· по тексту сообщения,
· по имени функции,
· по дате,
· по времени,
· по коду.

Окно дерева отображает даты и время отобранных сообщений.

· Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень только отобранных сообщений, если данная опция отключена.

- статистика сообщений

Выбор данного режима позволяет построить график приемов посылок в базу данных и график индексаций базы на основе сообщений из данного файла.

График статистики приемов можно посмотреть в режиме всех приемов или на конкретную дату, выбрав соответствующий пункт дерева сообщений (рис. 2.6).

Рис. 2.6. Статистика приемов посылок

График статистики индексаций базы данных можно построить в разрезе всех индексаций или по дням.

В режиме статистики доступны следующие клавиши (слева направо):

Опции просмотра графиков

· печать текущей страницы графика на текущий принтер;
· показать график на одной/нескольких страницах;
· спрятать/показать ярлыки элементов графика;
· уменьшить масштаб графика;
· нормальный масштаб графика;
· увеличить масштаб графика;
· переход на первую страницу графика;
· переход на предыдущую страницу графика;
· переход на следующую страницу графика;
· переход на последнюю страницу графика.

Дополнительными возможностями манипулирования графиком являются:

· при нажатой правой клавише мышки можно производить скроллинг графика в любом направлении;
· при нажатой левой клавише мышки:

• при движении вниз и вправо - увеличить масштаб;

• при движении вверх и влево - восстановить нормальный масштаб.

При передвижении курсора над графиком в нижней панели отображаются атрибуты текущего элемента графика.

2.2.6. Планировщик и Группы заданий

2.2.6.1. Выполнение задач администрирования по расписанию

С помощью Планировщика Вы можете настроить ту или иную задачу, а также группу заданий на выполнение по расписанию: в определенное время и с указанной периодичностью.

Для просмотра и изменения параметров выбранной задачи используется кнопка [image] на панели Менеджера задач. При нажатии на нее перед Вами откроется окно "Настройка параметров" (рис. 2.7) с закладкой Параметры задачи, на которой Вы можете изменить параметры "Время ожидания завершения задачи" и "Период обновления информации в Менеджере задач" и настроить расписание выполнения задачи Планировщиком. Закладка Параметры группы служит для формирования и редактирования групп заданий и рассматривается в п. 2.6.2.

Рис. 2.7. Окно настройки параметров с закладкой “Параметры задачи”

"Время ожидания завершения задачи" (в минутах) задает максимальный интервал, в течение которого Администратор ожидает завершения задачи. Если задача не завершится в течение указанного интервала, то она принудительно снимается с выполнения и формируется соответствующий код возврата, который документируется в протоколе работы системы. Этот механизм позволяет избежать “зацикливания” задачи.

По умолчанию для всех задач установлены заведомо большие интервалы, которые гарантированно обеспечивают нормальное выполнение задачи на слабопроизводительных компьютерах. Вы можете изменить этот параметр в соответствии с оцененным для Вашего компьютера временем выполнения задачи.

"Период обновления информации в Менеджере задач" (в секундах) задает частоту опрашивания Администратором текущего состояния выполняемой задачи. Этот параметр также целесообразно устанавливать после оценки времени выполнения задачи на Вашем компьютере.

Слишком частый опрос состояния задачи может приводить к замедлению ее исполнения, а чрезмерно редкий - не позволит зафиксировать последовательность выполнения отдельных этапов задачи.

"Поведение после ошибки" дает возможность выбора автоматического запуска задачи повторно, если при первом выполнении задача прошла с ошибками.

Для одиночной задачи параметр имеет значения "Прервать выполнение" и "Повторить задание". Первое значение установлено по умолчанию и в случае ошибки не будет предприниматься никаких действий. В случае выбора повторного запуска задача будет запускаться ещё дважды, если первый перезапуск не даст положительный результат.

Для групповой задачи больший выбор действий после ошибки:

· Прервать выполнение - установлено по умолчанию;
· Продолжить выполнение;
· Повторить задание и прервать;
· Повторить задание и продолжить.

Опция "Отправлять сообщения по e-mail при аварийном завершении" устанавливается для того, чтобы получать на e-mail, указанный в настройках Сервера на закладке HTTP/E-mail в группе Отправка, результатов выполнения задач (см. Раздел 1, п. 4.6.2), сообщение в случае, если в результате выполнения задачи были выявлены ошибки или произошел сбой в процессе ее выполнения. По умолчанию опция установлена на всех задачах.

Расписание выполнения задачи Планировщиком.

При планировании выполнения задач по расписанию Вам необходимо учитывать, что одновременное выполнение нескольких задач невозможно, то есть расписание должно обеспечивать нормальное завершение очередной задачи перед запуском последующей. Запуск задачи при уже выполняющейся другой задаче не происходит. Исключение составляют задачи "Получение обновлений и отправка результатов", “ИнформБюро: Восстановление индексов” и “ИнформБюро: Прием сообщений”, которые могут выполняться одновременно с другой задачей. Для того чтобы избежать временных накладок, рекомендуем Вам воспользоваться группированием заданий, подробно описанном в п. 2.6.2 “Создание групп заданий”.

2.2.6.2. Создание групп заданий

В Менеджере задач существует возможность группировать задания в пакеты для последовательного выполнения, при этом сразу же по окончании отработки одной задачи стартует следующая. Это позволяет избежать временных нестыковок при запуске задач по расписанию. Просмотр и редактирование групп заданий доступно из закладки Группы заданий Менеджера задач (рис. 2.8).

Рис. 2.8. Окно Менеджера задач с закладкой Группы заданий

Группа заданий трактуется Менеджером задач как одна задача и может быть поставлена на выполнение по расписанию с помощью Планировщика точно так же, как и любая задача из раздела Общие или Сервисные задачи ("Настройка параметров", закладка Параметры задачи). Если какая-либо из задач пакета аварийно завершается, то прерывается выполнение всего пакета.

Для того чтобы создать новую группу, необходимо нажать кнопку [image]. Перед вами откроется окно Настройки параметров (рис. 2.9) с закладкой Параметры группы. В поле Название задачи вписывается название создаваемой группы, а в поле Состав группы с помощью кнопки [image] добавляются задачи, которые можно выбрать в открывающемся окне выбора задания (рис. 2.10).

Рис. 2.9. Окно настройки параметров с закладкой “Параметры группы”

Порядок следования задач в поле Состав группы определяет последовательность их выполнения. Его можно изменить с помощью кнопок [image] и [image], предварительно выделив перемещаемую задачу щелчком мыши. Если Вы хотите удалить какую-то задачу из группы, воспользуйтесь для этого кнопкой [image]. Для сохранения созданной группы (если состав группы и порядок следования задач удовлетворяют Вас), необходимо нажать кнопку Сохранить.

Для редактирования ранее созданной группы необходимо открыть Менеджер задач, перейти на закладку Группы заданий, выделить группу для редактирования и нажать кнопку [image]. В открывшемся окне Настройки параметров необходимо перейти на закладку Параметры группы. Далее действия по изменению состава группы и порядка следования задач аналогичны действиям по созданию новой группы.

Рис. 2.10. Окно выбора задания

Для удаления ранее созданной группы заданий необходимо выделить ее и нажать кнопку [image] в окне Менеджера задач.


2.2.5. Просмотр протоколов работы

Для просмотра протоколов работы (лог-файлов) системы определенной структуры - LigaSrv.log, Liga.log, LigaAdm.log, Receive.log, Mail.log и истории приема посылок используется кнопка просмотра протоколов работы, доступная из главного окна Администратора системы, или кнопка [image] в Менеджере задач.

Режимы просмотра протоколов

Центральное окно содержит закладки для просмотра истории приема обновлений, почтового протокола, протоколов поступлений, Администратора, Клиента, Сервера (рис. 2.5). Для просмотра отдельно выбранного файла используется кнопка [image], при этом открывается закладка с именем выбранного файла.

Рис. 2.5. Просмотр протоколов работы системы

Каждая закладка содержит окно дерева и окно списка или графика сообщений (в зависимости от режима). Исключение составляют закладки "Протокол поступлений" и "Протокол Mail, FTP" - в них предоставляется возможность просмотра текстовых файлов Receive.log и Mail.log.

Содержимое дерева сообщений зависит от режима просмотра дерева (управляется кнопками Панели Инструментов) и служит для быстрого перехода на соответствующее сообщение.

Окно дерева отображает даты (а в некоторых режимах и время) сообщений. Выбор элемента дерева позволяет найти первое сообщение из списка на конкретную дату (а в некоторых режимах и на конкретное время).

Содержимое списка сообщений зависит от того, какая опция просмотра сообщений выбрана (задается включением/отключением пункта “Полный перечень сообщений” в меню “Опции”). Если включен “Полный перечень сообщений”, то в списке всегда отображаются все сообщения независимо от того, какой режим просмотра выбран в дереве сообщений.

Меню “Опции” состоит из следующих пунктов:

§ “Выделять сообщения цветом” - позволяет отключить/включить режим использования цветов в списке сообщений;
§ “Полный перечень сообщений” - установка/отключение этой опции влияет на то, будет ли в списке отображаться весь перечень сообщений, или только тех, которые относятся к текущему режиму просмотра дерева;
§ “Показывать с последнего дня” - установка/отключение этой опции влияет на то, будет ли при переходе в новый режим курсор устанавливаться на первое сообщение из списка или на первое сообщение последнего дня.

При первом выборе закладки с необходимым протоколом всегда отображается полный список сообщений.

Существует два режима просмотра протоколов:

Просмотр списка сообщений

§ перечень сообщений о приеме посылок,
§ перечень сообщений об ошибках,
§ перечень сообщений о соединениях пользователей,
§ перечень сообщений, относящихся к администрированию пакета,
§ полный перечень сообщений,
§ перечень сообщений, отобранных по указанному критерию.

Статистика сообщений

§ статистика приемов (график),
§ статистика индексаций базы данных (график).

В этих режимах доступны такие виды отображений:

- перечень сообщений о приеме посылок

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений, относящихся к приему пополнений.

Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к приему пополнений, если данная опция отключена.

- перечень сообщений об ошибках

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений об ошибках.

Выбор элемента дерева позволяет найти соответствующее сообщение об ошибке в списке.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к сообщениям об ошибках, если данная опция отключена.

- перечень сообщений о соединениях пользователей

Если нажата эта кнопка, то окно дерева отбражает даты и время сообщений, относящихся к соединению и разъединению пользователей.

Выбор элемента дерева позволяет найти соответствующее соединение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции "Полный список сообщений" или перечень сообщений, относящихся только к обращению пользователей к системе, если данная опция отключена.

- перечень сообщений, относящихся к администрированию пакета

Если нажата эта кнопка, то окно дерева отображает даты и время сообщений, относящихся к административным сообщениям (сообщения проверок, индексации базы, проверок библиотек и т. п.).

Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень сообщений, относящихся только к административным задачам, если данная опция отключена.

- все сообщения в этом файле

Если нажата эта кнопка, то окно дерева отображает даты сообщений.

Окно списка содержит полный перечень сообщений данного файла вне зависимости от состояния опции “Полный список сообщений”.

- перечень сообщений, отобранных по указанному критерию

Если нажата эта кнопка, то окно списка содержит только перечень отобранных сообщений.

Данный режим позволяет отобрать сообщения из общего списка по следующим критериям:

· по тексту сообщения,
· по имени функции,
· по дате,
· по времени,
· по коду.

Окно дерева отображает даты и время отобранных сообщений.

· Выбор элемента дерева позволяет найти соответствующее сообщение из списка на конкретную дату и время.

Окно списка содержит полный перечень сообщений данного файла при включенной опции “Полный список сообщений” или перечень только отобранных сообщений, если данная опция отключена.

- статистика сообщений

Выбор данного режима позволяет построить график приемов посылок в базу данных и график индексаций базы на основе сообщений из данного файла.

График статистики приемов можно посмотреть в режиме всех приемов или на конкретную дату, выбрав соответствующий пункт дерева сообщений (рис. 2.6).

Рис. 2.6. Статистика приемов посылок

График статистики индексаций базы данных можно построить в разрезе всех индексаций или по дням.

В режиме статистики доступны следующие клавиши (слева направо):

Опции просмотра графиков

· печать текущей страницы графика на текущий принтер;
· показать график на одной/нескольких страницах;
· спрятать/показать ярлыки элементов графика;
· уменьшить масштаб графика;
· нормальный масштаб графика;
· увеличить масштаб графика;
· переход на первую страницу графика;
· переход на предыдущую страницу графика;
· переход на следующую страницу графика;
· переход на последнюю страницу графика.

Дополнительными возможностями манипулирования графиком являются:

· при нажатой правой клавише мышки можно производить скроллинг графика в любом направлении;
· при нажатой левой клавише мышки:

• при движении вниз и вправо - увеличить масштаб;

• при движении вверх и влево - восстановить нормальный масштаб.

При передвижении курсора над графиком в нижней панели отображаются атрибуты текущего элемента графика.


2.2.6.1. Выполнение задач администрирования по расписанию

С помощью Планировщика Вы можете настроить ту или иную задачу, а также группу заданий на выполнение по расписанию: в определенное время и с указанной периодичностью.

Для просмотра и изменения параметров выбранной задачи используется кнопка [image] на панели Менеджера задач. При нажатии на нее перед Вами откроется окно "Настройка параметров" (рис. 2.7) с закладкой Параметры задачи, на которой Вы можете изменить параметры "Время ожидания завершения задачи" и "Период обновления информации в Менеджере задач" и настроить расписание выполнения задачи Планировщиком. Закладка Параметры группы служит для формирования и редактирования групп заданий и рассматривается в п. 2.6.2.

Рис. 2.7. Окно настройки параметров с закладкой “Параметры задачи”

"Время ожидания завершения задачи" (в минутах) задает максимальный интервал, в течение которого Администратор ожидает завершения задачи. Если задача не завершится в течение указанного интервала, то она принудительно снимается с выполнения и формируется соответствующий код возврата, который документируется в протоколе работы системы. Этот механизм позволяет избежать “зацикливания” задачи.

По умолчанию для всех задач установлены заведомо большие интервалы, которые гарантированно обеспечивают нормальное выполнение задачи на слабопроизводительных компьютерах. Вы можете изменить этот параметр в соответствии с оцененным для Вашего компьютера временем выполнения задачи.

"Период обновления информации в Менеджере задач" (в секундах) задает частоту опрашивания Администратором текущего состояния выполняемой задачи. Этот параметр также целесообразно устанавливать после оценки времени выполнения задачи на Вашем компьютере.

Слишком частый опрос состояния задачи может приводить к замедлению ее исполнения, а чрезмерно редкий - не позволит зафиксировать последовательность выполнения отдельных этапов задачи.

"Поведение после ошибки" дает возможность выбора автоматического запуска задачи повторно, если при первом выполнении задача прошла с ошибками.

Для одиночной задачи параметр имеет значения "Прервать выполнение" и "Повторить задание". Первое значение установлено по умолчанию и в случае ошибки не будет предприниматься никаких действий. В случае выбора повторного запуска задача будет запускаться ещё дважды, если первый перезапуск не даст положительный результат.

Для групповой задачи больший выбор действий после ошибки:

· Прервать выполнение - установлено по умолчанию;
· Продолжить выполнение;
· Повторить задание и прервать;
· Повторить задание и продолжить.

Опция "Отправлять сообщения по e-mail при аварийном завершении" устанавливается для того, чтобы получать на e-mail, указанный в настройках Сервера на закладке HTTP/E-mail в группе Отправка, результатов выполнения задач (см. Раздел 1, п. 4.6.2), сообщение в случае, если в результате выполнения задачи были выявлены ошибки или произошел сбой в процессе ее выполнения. По умолчанию опция установлена на всех задачах.

Расписание выполнения задачи Планировщиком.

При планировании выполнения задач по расписанию Вам необходимо учитывать, что одновременное выполнение нескольких задач невозможно, то есть расписание должно обеспечивать нормальное завершение очередной задачи перед запуском последующей. Запуск задачи при уже выполняющейся другой задаче не происходит. Исключение составляют задачи "Получение обновлений и отправка результатов", “ИнформБюро: Восстановление индексов” и “ИнформБюро: Прием сообщений”, которые могут выполняться одновременно с другой задачей. Для того чтобы избежать временных накладок, рекомендуем Вам воспользоваться группированием заданий, подробно описанном в п. 2.6.2 “Создание групп заданий”.


2.4.1. Менеджер пользователей

Для управления базой пользователей системы выберите пункт [image] Менеджер пользователей из меню Администратора. Перед Вами откроется окно с именами пользователей и названиями групп (рис. 2.12).

Вы можете добавлять пользователей и группы в систему, редактировать их свойства и удалять, а также импортировать в базу пользователей домена Windows и групп Active Directory. Система не устанавливает ограничение на количество пользователей, введенных в базу, но ограничивает количество одновременно работающих пользователей.

Рис. 2.12. Окно Менеджера пользователей

2.4.1.1. Добавление и редактирование пользователей

Для того, чтобы добавить пользователя, Вам необходимо нажать кнопку [image], после чего откроется окно (рис. 2.13) редактора параметров пользователя.

В закладке Пользователь Вы можете задать:

· Имя пользователя (обязательный параметр), которое используется для идентификации при входе пользователя в систему;
· Описание (необязательный параметр), используемое для расширенной идентификации пользователя Администратором;
· Пароль (обязательный параметр, который может принимать пустое значение), используемый при входе пользователя в систему.

Рис. 2.13. Окно параметров пользователя

Рис. 2.14. Окно, определяющее принадлежность пользователя к уже существующим группам

В закладке Группа задается принадлежность пользователя к существующим группам (рис. 2.14) (пользователь всегда входит в группу Everyone).

В закладке Права задаются права пользователя (рис. 2.15) (необязательный параметр), которые регламентируют рабочее время пользователя в системе.

Если Вами был приобретен вариант поставки системы с Корпоративными портфелями, то Вы также можете установить права доступа к ним:

· Разрешено отправлять сетевые сообщения - доступ на обмен сообщениями средствами системы ЛЗ;
· Разрешено создавать Корпоративные портфели - доступ на создание Корпоративных портфелей.

Рис. 2.15. Окно, определяющее права пользователя

Для изменения параметров пользователя Вам необходимо нажать кнопку [image], после чего откроется описанное выше окно редактора, в котором будут представлены текущие параметры выбранного в списке пользователя.

Для удаления выбранного пользователя из списка достаточно нажать кнопку [image].

2.4.1.2. Импорт в базу пользователей системы имен пользователей домена Windows и групп Active Directory

Возможность импортировать в базу пользователей домена Windows доступна только в том случае, если Сервер системы установлен на Windows XP, 2003, 7 или Vista и запущен с правами пользователя, имеющего доступ к базе пользователей домена (Active Directory).

После нажатия кнопки [image] Импорт пользователей домена, откроется окно импорта пользователей домена (см. рис. 2.16). В секции "Домен Windows" необходимо выбрать домен из выпадающего списка всех сетевых доменов. После чего в секции "Список пользователей/групп" отобразится список всех пользователей выбранного домена. Можно выбрать отдельного пользователя, нескольких или всех пользователей данного домена, выделив их стандартными средствами Windows. Для подтверждения вашего выбора нажмите кнопку [image] Импорт. После чего выбранные пользователи домена и их описание будут добавлены в список пользователей системы.

Редактирование параметров пользователей домена осуществляется аналогично пользователям, введенным вручную. Пользователи домена автоматически входят в группу Everyone.

Рис. 2.16. Окно импорта пользователей домена

После нажатия на кнопку [image] Добавить группы Active Directory в секции «Группы Active Directory» добавление групп происходит аналогично импорту пользователей домена. После нажатия на кнопку [image] Импорт выбранные группы с описанием будут добавлены в список групп в этой секции.

ВАЖНО! При наличии групп Active Directory в списке авторизация доменных пользователей будет осуществляться исключительно на основании членства в этих группах.

Пользователи групп Active Directory будут добавлены в список пользователей после первого удачного входа в систему.

Клиент при подключении всегда в первую очередь пытается подсоединиться как пользователь домена (логин и пароль при этом не запрашиваются). Сервер проверяет на контроллере домена наличие такого пользователя (при наличии хотя бы одной группы Active Directory в списке проверяется наличие группы в домене и членство пользователя в данной группе). Если пользователь не найден (или не является участником группы Active Directory), то появляется стандартное окно авторизации входа в систему, в котором пользователь должен ввести свои имя и пароль (нельзя использовать имя и пароль пользователя домена для авторизации в системе). При подключении должна обеспечиваться связь сервера с контроллером домена.

Примечание

Если пользователь записан в базе пользователей системы как доменный, но Сервер не может получить подтверждения от контроллера домена (нет связи, пользователя удалили из домена, пользователь не включен в группу Active Directory или что-либо другое), то при входе Клиент запросит ввести имя и пароль. Такая ситуация не записывается в протокол Сервера, и администратор должен устранить проблему доменной регистрации или добавить пользователя с обычными именем и паролем в Менеджере пользователей.

Если включена опция "Разрешить первичную авторизацию", при входе нового пользователя в базу будут вноситься реквизиты доменного пользователя.

В окне Менеджера пользователей обычные и доменные имена пользователей помечаются различными иконками (пользователи, которые добавлены через группы Active Directory, помечаются иконками как у пользователей домена Windows).

Для пользователя из домена Windows запрещается редактировать пароль в оболочке Администратора системы.

2.4.1.3. Группы пользователей

Все пользователи системы ЛЗ автоматически входят в группу Everyone. Если Вы впервые инсталлируете систему, то всем пользователям будут даны максимальные права: отправлять сетевые сообщения, создавать Корпоративные портфели, если Вы приобрели этот дополнительный сервис, доступ к Реестру, если Вы приобрели отдельный модуль доступа к Реестру. Максимальные права открыты в группе Everyone.

Для того, чтобы создать группу пользователей, необходимо нажать кнопку [image]. При этом откроется окно редактора параметров группы (рис. 2.17).

Рис. 2.17. Окно редактора параметров группы

В этом окне Вы можете задать следующие параметры:

· Название группы (обязательный параметр), которое однозначно идентифицирует группу;
· Описание (необязательный параметр), которое содержит дополнительную информацию о группе;
· Состав группы (рис. 2.18) (необязательный параметр), который задает список существующих пользователей, входящих в группу;
· Права членов группы (рис. 2.19) (необязательный параметр), которыми может регламентироваться дата и время входа членов группы в систему, а также дополнительные права. Права, которые можно назначать всем членам группы аналогичные правам, которые устанавливаются для отдельных пользователей и описаны выше.

Для изменения и просмотра текущих параметров выбранной в списке группы необходимо нажать кнопку [image], после чего откроется описанное выше окно редактора параметра группы. Для удаления выбранной группы из списка достаточно нажать кнопку [image].

Рис. 2.18. Окно определения состава группы

Рис. 2.19. Окно, определяющее права члена группы

Примечание

1. Пользователь с именем Administrator является системным и его удаление из базы пользователей не допускается. Вам предоставляется возможность изменять только пароль этого пользователя. Этот пользователь обладает всей совокупностью прав в системе независимо от принадлежности его к какой-либо группе.
2. При идентификации пользователя в системе регистр символов в его имени игнорируется, а в пароле - учитывается.
3. Одновременный вход в систему двух пользователей с одинаковым именем не допускается. Исключение составляет пользователь Administrator, который имеет право войти в систему из оболочки Клиента и из оболочки Администратора.
4. Если права пользователя не определены, то ему приписываются права группы, в которую он входит. Если пользователь входит в состав одной или нескольких групп, то ему присваиваются консолидированные права, являющиеся объединением всех прав, заданных для этих групп, и его собственных. Например, если время работы пользователя ограничено интервалом 10:00 - 12:00 и он входит в состав двух групп, время работы в которых ограничивается интервалами 8:00 - 10:00 и 12:00 - 14:00, то этому пользователю будет разрешено работать в интервале 8:00 - 14:00.
5. Удаление группы не приводит к удалению входящих в нее пользователей.

Создание и восстановление резервной копии списка пользователей

Для того чтобы создать резервную копию списка пользователей, Вам необходимо нажать кнопку [image], после чего откроется окно Backup выбора пути и имени файла для резервной копии списка пользователей.

Примечание

При создании резервной копии списка пользователей сохраняется информация об имени пользователя, описании пользователя, пароль и его права. Имена пользователей из домена получаются с сервера системы, т.е. только те, которые зарегистрированы сервером, а не администратором сети. Принадлежность пользователей к группам и список групп не сохраняется.

Для того чтобы восстановить резервную копию списка пользователей, Вам необходимо нажать кнопку [image], после чего откроется окно Restore выбора пути к резервной копии списка пользователей.

Примечание

Вы можете экспортировать список пользователей из текстового файла. Для этого необходимо создать текстовый файл с расширением *.udb и записать в отдельных строках имена пользователей системы. После этого откройте полученный файл как резервную копию списка пользователей для восстановления. После экспорта списка пользователей не забудьте установить пароли и права доступа!

Экспорт базы пользователей в текстовый файл

Для того, чтобы сохранить список пользователей в txt-файл, необходимо нажать кнопку [image], после чего откроется окно выбора пути и имени файла.

Примечание

Полученный текстовый файл удобно просматривать в редакторе Microsoft Excel. При таком просмотре имена пользователей и их описания будут располагаться в отдельных ячейках. Такой вариант является более удобным для просмотра и печати.

2.4.1.4. Группа пользователей системы VERDICTUM

В системах ЛЗ с доступом к системе анализа судебных решений VERDICTUM в списке групп пользователей присутствует группа VERDICTUM.

При первой инсталляции системы группа не содержит ни одного пользователя. Для того, чтобы пользователь получил доступ к системе VERDICTUM, которая вызывается из Клиента системы ЛЗ, необходимо чтобы он являлся членом данной группы.

Количество пользователей этой группы ограничено и определяется количеством приобретенных Вами пользователей. Количество присоединенных к группе пользователей и количество возможных указывается в свойствах группы на закладке "Состав".

В случае уменьшения Вами количества приобретенных доступов к системе VERDICTUM, количество присоединенных ранее пользователей может превышать количество доступных. Тогда информация о количестве пользователей группы будет отображаться красным шрифтом. В этой ситуации необходимо отредактировать список входящих в группу пользователей с помощью кнопки "Удалить".


2.4.1.1. Добавление и редактирование пользователей

Для того, чтобы добавить пользователя, Вам необходимо нажать кнопку [image], после чего откроется окно (рис. 2.13) редактора параметров пользователя.

В закладке Пользователь Вы можете задать:

· Имя пользователя (обязательный параметр), которое используется для идентификации при входе пользователя в систему;
· Описание (необязательный параметр), используемое для расширенной идентификации пользователя Администратором;
· Пароль (обязательный параметр, который может принимать пустое значение), используемый при входе пользователя в систему.

Рис. 2.13. Окно параметров пользователя

Рис. 2.14. Окно, определяющее принадлежность пользователя к уже существующим группам

В закладке Группа задается принадлежность пользователя к существующим группам (рис. 2.14) (пользователь всегда входит в группу Everyone).

В закладке Права задаются права пользователя (рис. 2.15) (необязательный параметр), которые регламентируют рабочее время пользователя в системе.

Если Вами был приобретен вариант поставки системы с Корпоративными портфелями, то Вы также можете установить права доступа к ним:

· Разрешено отправлять сетевые сообщения - доступ на обмен сообщениями средствами системы ЛЗ;
· Разрешено создавать Корпоративные портфели - доступ на создание Корпоративных портфелей.

Рис. 2.15. Окно, определяющее права пользователя

Для изменения параметров пользователя Вам необходимо нажать кнопку [image], после чего откроется описанное выше окно редактора, в котором будут представлены текущие параметры выбранного в списке пользователя.

Для удаления выбранного пользователя из списка достаточно нажать кнопку [image].

2.4.1.2. Импорт в базу пользователей системы имен пользователей домена Windows и групп Active Directory

Возможность импортировать в базу пользователей домена Windows доступна только в том случае, если Сервер системы установлен на Windows XP, 2003, 7 или Vista и запущен с правами пользователя, имеющего доступ к базе пользователей домена (Active Directory).

После нажатия кнопки [image] Импорт пользователей домена, откроется окно импорта пользователей домена (см. рис. 2.16). В секции "Домен Windows" необходимо выбрать домен из выпадающего списка всех сетевых доменов. После чего в секции "Список пользователей/групп" отобразится список всех пользователей выбранного домена. Можно выбрать отдельного пользователя, нескольких или всех пользователей данного домена, выделив их стандартными средствами Windows. Для подтверждения вашего выбора нажмите кнопку [image] Импорт. После чего выбранные пользователи домена и их описание будут добавлены в список пользователей системы.

Редактирование параметров пользователей домена осуществляется аналогично пользователям, введенным вручную. Пользователи домена автоматически входят в группу Everyone.

Рис. 2.16. Окно импорта пользователей домена

После нажатия на кнопку [image] Добавить группы Active Directory в секции «Группы Active Directory» добавление групп происходит аналогично импорту пользователей домена. После нажатия на кнопку [image] Импорт выбранные группы с описанием будут добавлены в список групп в этой секции.

ВАЖНО! При наличии групп Active Directory в списке авторизация доменных пользователей будет осуществляться исключительно на основании членства в этих группах.

Пользователи групп Active Directory будут добавлены в список пользователей после первого удачного входа в систему.

Клиент при подключении всегда в первую очередь пытается подсоединиться как пользователь домена (логин и пароль при этом не запрашиваются). Сервер проверяет на контроллере домена наличие такого пользователя (при наличии хотя бы одной группы Active Directory в списке проверяется наличие группы в домене и членство пользователя в данной группе). Если пользователь не найден (или не является участником группы Active Directory), то появляется стандартное окно авторизации входа в систему, в котором пользователь должен ввести свои имя и пароль (нельзя использовать имя и пароль пользователя домена для авторизации в системе). При подключении должна обеспечиваться связь сервера с контроллером домена.

Примечание

Если пользователь записан в базе пользователей системы как доменный, но Сервер не может получить подтверждения от контроллера домена (нет связи, пользователя удалили из домена, пользователь не включен в группу Active Directory или что-либо другое), то при входе Клиент запросит ввести имя и пароль. Такая ситуация не записывается в протокол Сервера, и администратор должен устранить проблему доменной регистрации или добавить пользователя с обычными именем и паролем в Менеджере пользователей.

Если включена опция "Разрешить первичную авторизацию", при входе нового пользователя в базу будут вноситься реквизиты доменного пользователя.

В окне Менеджера пользователей обычные и доменные имена пользователей помечаются различными иконками (пользователи, которые добавлены через группы Active Directory, помечаются иконками как у пользователей домена Windows).

Для пользователя из домена Windows запрещается редактировать пароль в оболочке Администратора системы.


2.4.1.3. Группы пользователей

Все пользователи системы ЛЗ автоматически входят в группу Everyone. Если Вы впервые инсталлируете систему, то всем пользователям будут даны максимальные права: отправлять сетевые сообщения, создавать Корпоративные портфели, если Вы приобрели этот дополнительный сервис, доступ к Реестру, если Вы приобрели отдельный модуль доступа к Реестру. Максимальные права открыты в группе Everyone.

Для того, чтобы создать группу пользователей, необходимо нажать кнопку [image]. При этом откроется окно редактора параметров группы (рис. 2.17).

Рис. 2.17. Окно редактора параметров группы

В этом окне Вы можете задать следующие параметры:

· Название группы (обязательный параметр), которое однозначно идентифицирует группу;
· Описание (необязательный параметр), которое содержит дополнительную информацию о группе;
· Состав группы (рис. 2.18) (необязательный параметр), который задает список существующих пользователей, входящих в группу;
· Права членов группы (рис. 2.19) (необязательный параметр), которыми может регламентироваться дата и время входа членов группы в систему, а также дополнительные права. Права, которые можно назначать всем членам группы аналогичные правам, которые устанавливаются для отдельных пользователей и описаны выше.

Для изменения и просмотра текущих параметров выбранной в списке группы необходимо нажать кнопку [image], после чего откроется описанное выше окно редактора параметра группы. Для удаления выбранной группы из списка достаточно нажать кнопку [image].

Рис. 2.18. Окно определения состава группы

Рис. 2.19. Окно, определяющее права члена группы

Примечание

1. Пользователь с именем Administrator является системным и его удаление из базы пользователей не допускается. Вам предоставляется возможность изменять только пароль этого пользователя. Этот пользователь обладает всей совокупностью прав в системе независимо от принадлежности его к какой-либо группе.
2. При идентификации пользователя в системе регистр символов в его имени игнорируется, а в пароле - учитывается.
3. Одновременный вход в систему двух пользователей с одинаковым именем не допускается. Исключение составляет пользователь Administrator, который имеет право войти в систему из оболочки Клиента и из оболочки Администратора.
4. Если права пользователя не определены, то ему приписываются права группы, в которую он входит. Если пользователь входит в состав одной или нескольких групп, то ему присваиваются консолидированные права, являющиеся объединением всех прав, заданных для этих групп, и его собственных. Например, если время работы пользователя ограничено интервалом 10:00 - 12:00 и он входит в состав двух групп, время работы в которых ограничивается интервалами 8:00 - 10:00 и 12:00 - 14:00, то этому пользователю будет разрешено работать в интервале 8:00 - 14:00.
5. Удаление группы не приводит к удалению входящих в нее пользователей.

Создание и восстановление резервной копии списка пользователей

Для того чтобы создать резервную копию списка пользователей, Вам необходимо нажать кнопку [image], после чего откроется окно Backup выбора пути и имени файла для резервной копии списка пользователей.

Примечание

При создании резервной копии списка пользователей сохраняется информация об имени пользователя, описании пользователя, пароль и его права. Имена пользователей из домена получаются с сервера системы, т.е. только те, которые зарегистрированы сервером, а не администратором сети. Принадлежность пользователей к группам и список групп не сохраняется.

Для того чтобы восстановить резервную копию списка пользователей, Вам необходимо нажать кнопку [image], после чего откроется окно Restore выбора пути к резервной копии списка пользователей.

Примечание

Вы можете экспортировать список пользователей из текстового файла. Для этого необходимо создать текстовый файл с расширением *.udb и записать в отдельных строках имена пользователей системы. После этого откройте полученный файл как резервную копию списка пользователей для восстановления. После экспорта списка пользователей не забудьте установить пароли и права доступа!

Экспорт базы пользователей в текстовый файл

Для того, чтобы сохранить список пользователей в txt-файл, необходимо нажать кнопку [image], после чего откроется окно выбора пути и имени файла.

Примечание

Полученный текстовый файл удобно просматривать в редакторе Microsoft Excel. При таком просмотре имена пользователей и их описания будут располагаться в отдельных ячейках. Такой вариант является более удобным для просмотра и печати.

2.4.1.4. Группа пользователей системы VERDICTUM

В системах ЛЗ с доступом к системе анализа судебных решений VERDICTUM в списке групп пользователей присутствует группа VERDICTUM.

При первой инсталляции системы группа не содержит ни одного пользователя. Для того, чтобы пользователь получил доступ к системе VERDICTUM, которая вызывается из Клиента системы ЛЗ, необходимо чтобы он являлся членом данной группы.

Количество пользователей этой группы ограничено и определяется количеством приобретенных Вами пользователей. Количество присоединенных к группе пользователей и количество возможных указывается в свойствах группы на закладке "Состав".

В случае уменьшения Вами количества приобретенных доступов к системе VERDICTUM, количество присоединенных ранее пользователей может превышать количество доступных. Тогда информация о количестве пользователей группы будет отображаться красным шрифтом. В этой ситуации необходимо отредактировать список входящих в группу пользователей с помощью кнопки "Удалить".


2.4.2. Менеджер базы прав

Если в поставку системы входят Собственные базы данных пользователя, назначение прав на эти базы и документы, входящие в эти базы, Вы можете осуществить при помощи Менеджера базы прав Администратора системы. Вызов этого режима осуществляется при помощи кнопки [image] главного меню Администратора (табл. 2.1). Детальная работа с Менеджером базы прав описывается в “ЛІГА:Конструктор. Руководство по созданию собственных баз данных в системе ЛIГА:ЗАКОН”.


2.4.3. Менеджер сеансов

Каждый подключившийся к системе пользователь организует сеанс (сессию), который поддерживается на Сервере. Для управления пользовательскими сеансами Вам необходимо активизировать Менеджер сеансов, нажав соответствующую кнопку на панели оболочки Администратора. Менеджер сеансов представляет собой окно (рис. 2.20), в котором отображается список активных пользовательских сеансов.

Крайняя левая колонка этого списка служит для выбора соответствующего сеанса. В графе Пользователь указывается имя пользователя, открывшего сеанс.

Следующая колонка отображает состояние сеанса (заблокирован или нет).

Рис. 2.20. Менеджер сеансов

В графе Подключение указывается время входа пользователя в систему, а в графе Активность - время его последнего обращения к системе.

С помощью Менеджера сеансов Вы можете:

· заблокировать любой сеанс, кроме сеанса пользователя Administrator, открытого из программной оболочки Администратора. При этом соответствующему пользователю передается сообщение о блокировке сеанса, после чего ему запрещается доступ к базе данных, но он может обмениваться сообщениями с другими пользователями;
· разблокировать ранее заблокированный сеанс. При этом пользователю передается соответствующее сообщение и восстанавливается его доступ к базе данных;
· завершить любой сеанс, кроме сеанса пользователя Administrator, открытого из программной оболочки Администратора. При этом пользователю передается сообщение о завершении сеанса и сетевой интерфейс программной оболочки Клиента закрывается;
· послать сообщение одному, нескольким или всем пользователям.

Список активных сеансов в окне Менеджера сеансов обновляется с периодичностью примерно два раза в минуту. Если Вам необходимо принудительно обновить список (получить от Сервера информацию о подключенных пользователях), то Вам достаточно нажать кнопку [image].

В верхнем правом углу окна Менеджера сеансов отображается информация о количестве подключенных к системе пользователей и о максимально допустимом количестве подключений.

Примечание

1. Ограничение на максимально допустимое количество подключений распространяется только на подключения, производимые из оболочки Клиента. Если Вы приобрели сетевой вариант системы ЛЗ с 25 пользовательскими лицензиями, то система позволяет одновременное подключение 25 оболочек Клиента и одной оболочки Администратора.
2. При передаче сообщений из оболочки Администратора (в отличие от оболочки Клиента) возможны два способа:
a. - передача прямого сообщения - для этого Вам необходимо набрать текст сообщения, отметить пользователей, которым Вы хотите его передать, и нажать кнопку [image] . При этом сообщение будет отправлено непосредственно выбранным пользователям;
b. - передача отложенного сообщения - для этого Вам необходимо нажать кнопку [image] и перед Вами откроется окно, содержащее список всех пользователей системы, причем активные пользователи (подключенные в данный момент к Серверу) будут выделены красным цветом. Вы можете выбрать любое количество пользователей (в том числе и неактивных) и передать им сообщение. При этом сообщение передается на Сервер, который транслирует его активным пользователям непосредственно, а для неактивных сохраняет в базе сообщений. При последующем подключении пользователя к Серверу проверяется наличие сообщений для него и, если таковые имеются, они транслируются ему, после чего они удаляются из базы сообщений. В программной оболочке Клиента используется именно этот механизм передачи сообщений.


2.5.1. Корпоративные портфели

Если в поставку системы включена возможность создавать Корпоративные портфели, то для их администрирования Вы можете воспользоваться разделом “Корпоративные портфели”. Чтобы открыть этот раздел, необходимо нажать кнопку [image] в меню Администраторa. Основные команды администрирования всех портфелей расположены в контекстном меню раздела, которое можно вызвать щелчком правой кнопки мыши на пункте “Портфели” (рис. 2.21):

Рис. 2.21. Контекстное меню администрирования всех портфелей

Импортировать Портфель - команда предназначена для импорта Личных портфелей в Корпоративные. При вызове этой команды открывается окно выбора файла Портфеля для импорта. Импорт Портфелей из системы с другим номером электронного ключа невозможен (необходима их сертификация в ООО "ЛИГА ЗАКОН").

Подключить Портфель - команда предназначена для подключения/отключения Портфелей или Личных портфелей, перемещенных в каталог с Корпоративными портфелями вручную (файлы Корпоративных портфелей находятся в каталоге Liga\User и имеют формат имени файла LFld000x.fld). При вызове этой команды открывается окно выбора Портфеля для подключения (рис. 2.22). В окне отображается список портфелей с реквизитами (Файл портфеля, Название портфеля и Автор портфеля) для подключения. Подключение Портфелей из системы с другим номером электронного ключа невозможно (необходима их сертификация в ООО "ЛИГА ЗАКОН").

Рис. 2.22. Окно выбора Портфеля для подключения

Подключить Портфель из архива - команда предназначена для подключения из архивов отключенных Портфелей или из архивов Личных портфелей, перемещенных в каталог с Корпоративными портфелями вручную (файлы Корпоративных портфелей находятся в каталоге Liga\User и имеют формат имени файла LFld000x.fld). При вызове этой команды открывается окно выбора Портфеля для подключения (рис. 2.22). В окне отображается список Портфелей с реквизитами (Файл портфеля, Название портфеля и Автор портфеля) для подключения. После выбора Портфеля для подключения появляется окно со списком архивов этого Портфеля (рис. 2.23). Подключение из архивов отключенных Портфелей из системы с другим номером электронного ключа невозможно (необходима их сертификация в ООО "ЛИГА ЗАКОН").

Рис. 2.23. Окно выбора архива Портфеля для подключения

Удалить права на Портфели - команда предназначена для удаления прав доступа ко всем портфелям.

Контекстное меню для Портфеля имеет несколько другой вид, рис. 2.24:

Рис. 2.24. Контекстное меню тома “Портфели”

Описание команд контекстного меню для работы с портфелем:

· Отключить Портфель - при выборе этой команды выбранный портфель удаляется из списка подключенных, но при этом файлы портфеля не удаляются и его можно потом подключить снова;
· Удалить Портфель - при выборе этой команды портфель будет удален, после чего его уже нельзя будет восстановить;
· Сохранить в архиве - при выборе этой команды создается архив для выбранного портфеля;
· Восстановить из архива - при выборе этой команды появляется окно со списком архивов для выбранного портфеля (рис. 2.23), в котором можно выбрать архив для восстановления или удалить его;
· Права на раздел - команда предназначена для назначения прав доступа только к выбранному портфелю или разделу;
· Права на раздел с вложениями - команда предназначена для назначения прав доступа к выбранному портфелю, а также его разделам или разделу с подразделами.

На каждый портфель (раздел), а также портфель с разделами могут быть назначены права “Владелец”, “Разрешен просмотр”, “Разрешена модификация”. При создании портфеля (раздела) создатель автоматически становится его владельцем.

· “Владелец” Портфеля (раздела) имеет право создавать разделы, редактировать и удалять Портфель (раздел) и назначать права на него;
· “Разрешен просмотр” - пользователь может только читать содержимое Портфеля;
· “Разрешена модификация” - пользователь может редактировать содержимое

Портфеля, но не может удалить его целиком.

Окно назначения прав доступа в Корпоративный портфель, вызываемое из пунктов контекстного меню "Права на раздел" и "Права на раздел с вложениями" аналогично тому, которое вызывается из Клиента системы при создании нового Корпоративного портфеля и при переводе Личного портфеля в Корпоративный (рис. 2.25). Подробно назначение прав и работа с Портфелями описана в "Руководстве пользователя".

Рис. 2.25. Окно установки прав доступа к Корпоративному портфелю


2.5.2. Сервисы

В настоящее время Сервер системы ЛЗ поддерживает два сервиса (службы) - “Планировщик задач” (см. п. 2.2.6) и “Автоответчик” (см. Раздел 1, п. 4.3). Из оболочки Администратора системы Вы можете просматривать текущее состояние этих сервисов, а также активизировать и деактивизировать их. Для управления сервисами Вам необходимо нажать кнопку Сервисы на панели оболочки Администратора системы. После этого перед Вами откроется окно (рис. 2.26), в котором отображается список сервисов и их состояние.

Рис. 2.26. Окно “Сервисы”

Используя кнопку Пуск, Вы можете активизировать выбранный сервис, а используя кнопку Стоп - деактивизировать его. Режимы запуска сервисов при старте Сервера задаются при настройках Сервера системы ЛЗ (см. п. 4.3 Раздела 1 данного руководства). С помощью оболочки Администратора Вы можете изменить текущее состояние сервисов системы.

Примечание

1. При деактивизированном Планировщике выполнение задач обслуживания базы данных невозможно даже из оболочки Администратора системы. Отключать Планировщик целесообразно в тех случаях, когда Вы желаете исключить выполнение задач в течение некоторого промежутка времени.
2. При деактивизированном Автоответчике невозможно автоматическое конфигурирование сетевых параметров Клиентов и Администратора системы путем получения настроек с Сервера. Если система в Вашей сети работает устойчиво и конфигурация сети не изменяется, целесообразно отключать этот сервис, так как при его функционировании потребляется вычислительный ресурс, что снижает производительность Сервера.


3. СПОСОБЫ ПОЛУЧЕНИЯ ОБНОВЛЕНИЙ ЭЛЕКТРОННЫМИ СРЕДСТВАМИ

3.1. НТTP-сервер

Обновления к системе ЛЗ доступны на HTTP-сервере ООО "ЛИГА ЗАКОН", расположенном по адресу

http://update.liga.net

Что необходимо сделать, чтобы начать получать обновления через HTTP-сервер?

Чтобы начать получать обновления через HTTP-сервер необходимо выполнить одно из предложенных действий:

· Заполнить заявку на получение обновлений на сайте http://support.ligazakon.ua/forms/1/ ,
· прислать письмо-заявку на получение обновлений по электронной почте на адрес admin@ligazakon.ua .

Что следует указать в письме с запросом?

В письме необходимо указать:

· название Вашей организации;
· регистрационный номер комплекта системы ЛЗ, который Вы приобрели. Если Вы имеете несколько комплектов, то необходимо указать все регистрационные номера (они указаны на электронных ключах и на лицензионных карточках);
· будет ли способ обновления через HTTP-сервер основным способом обновления Вашей системы или вспомогательным при каком-либо другом;
· адрес электронной почты для получения индивидуальных посылок в случае отправки проверочного файла;
· контактный телефон и контактное лицо.

Как работать с HTTP-сервером?

Система ЛЗ может производить автоматическое получение обновлений с HTTP-сервера. Настройка этой функции подробно описана в Разделе 1, п. 4.6.

Для того чтобы зайти на HTTP-сервер ООО "ЛИГА ЗАКОН" с помощью WEB-броузера Internet Explorer, необходимо набрать в адресной строке следующее:

http://update.liga.net

Появится диалоговое окно для ввода логина и пароля. После установления соединения Вы попадете в корневую папку. Обновления хранятся в следующих каталогах:

· All - содержит файлы для автоматического обновления систем ЛЗ;
· Accountant - содержит обновления для системы Бухгалтер;
· Company - содержит обновления для системы Предприятие;
· Lawyer - содержит обновления для системы Юрист.

В каждом из вышеперечисленных каталогов обновления хранятся отсортированными по датам выпуска, кроме того в каталогах имеется ежедневно обновляемая папка-ссылка lastday, указывающая на последний пакет обновлений. Внутри каталогов Liga7 и News дополнительно есть папка All с неотсортированными обновлениями.

Для обновления системы необходимо вручную скопировать файлы обновлений в каталог Text_New\ системы и запустить задачу "Прием в базу" (см. пункт 2.1.1 Раздела 2 "Администрирование системы").

Внимание!

В случае, если у Вас в ходе общей проверки обнаружены пропущенные файлы, то Вы можете загрузить с HTTP-сервера только те файлы, которые перечислены в разделе [Post] файла 000ХXXXX.CHK (файлы с расширением ADD). Файлы из раздела [Files] (с расширением LHT) вы можете получить ТОЛЬКО в форме индивидуальной посылки *.PVT, выслав файл 000ХXXXX.CHK по адресу ООО "ЛИГА ЗАКОН" (см. пункт 2.2.1 Раздела 2 данного руководства).

3.2. E-mail

Как перейти на обслуживание по E-mail, если до сих пор Вы получали обновления другим способом?

Чтобы перейти на обслуживание по E-mail, Вам необходимо связаться со Службой поддержки Абонентов Сети для оформления соответствующих документов.

Телефон: (044) 538-01-03 (многоканальный)

Адрес: ул. Т. Шамрыло, 23

Что необходимо сделать, чтобы начать получать обновления по E-mail?

После оформления документов необходимо прислать по электронной почте на адрес admin@ligazakon.ua тестовое письмо-заявку с того адреса, на который Вы хотите получать обновления к системе ЛЗ.

Что следует указать в письме-заявке?

В письме-заявке необходимо указать:

· название Вашей организации;
· регистрационный номер комплекта системы ЛЗ, который Вы приобрели. Если Вы имеете несколько комплектов, то необходимо указать все регистрационные номера (они указаны на электронных ключах и на лицензионных карточках);
· электронный адрес, на который Вы желаете получать обновления;
· контактный телефон и контактное лицо.

Внимание!

Настоятельно не рекомендуется использование бесплатных почтовых ящиков и ящиков с лимитом менее 15 МБ для получения обновлений к системе ЛЗ.

В каком виде к Вам будут поступать обновления к системе ЛЗ?

Обновления будут поступать в виде файлов с расширениями ADD, BBS, CMP или PVT, присоединенных к электронным письмам, на указанный в тестовом письме адрес. Получив электронные письма с файлами обновлений для системы ЛЗ, Вы должны извлечь присоединенные к этим письмам файлы и скопировать их в каталог Text_new\, который находится в каталоге системы ЛЗ. Затем необходимо выполнить задачу “Прием в базу”. Эта задача описана в Разделе 2, п. 2.1.1 .

Система ЛЗ может производить автоматическое получение обновлений. Настройка этой функции подробно описана в Разделе 1, п. 4.6.1.

В системе ЛЗ на Вашем компьютере не хватает некоторых документов. Как их получить?

Необходимо выполнить общую проверку базы в Администраторе системы (см. Раздел 2, п. 2.2.1). В результате этой проверки в каталоге Log\ будет сформирован проверочный файл 000ХXXXX.CHK (где XXХXX - регистрационный номер Вашего комплекта системы).

Пришлите нам электронное письмо с присоединенным (attachment) к нему файлом 000ХXXXX.CHK на адрес admin@ligazakon.ua. В течение суток он будет обработан, и к Вам будет поступать недостающая информация в виде индивидуальных посылок XXXXXnnn.PVT (где nnn - порядковый номер посылки) по 5 МБ в сутки.

Внимание!

Проверочные файлы, присоединяемые к электронному письму, не должны быть заархивированы, в противном случае они не будут обработаны!

Система ЛЗ может производить автоматическую отправку проверочных файлов. Настройка этой функции подробно описана в Разделе 1, п. 4.6.2.

Примечание

К сожалению, электронная почта несовершенна. Поэтому мы просим Вас производить общую проверку базы не реже чем раз в неделю, поскольку за месяц-два количество отсутствующих посылок может достигнуть десятков мегабайт.

ВНИМАНИЮ ДИЛЕРОВ!

Если Вы присылаете проверочный файл своего клиента, то в письме обязательно укажите:

§ название Вашей организации и регистрационный номер (с указанием, что Вы являетесь нашим дилером);
§ название и регистрационный номер Вашего клиента.

Для справок:

телефон: (044) 538-01-03

E-mail: support@ligazakon.ua

3.3. Автономная утилита Liga Mailer

Автономная утилита Liga Mailer (почтовый модуль) предназначена для автоматической фоновой проверки HTTP-сервера или почтового ящика на наличие новых посылок-обновлений и отправки *.chk -файлов по электронной почте.

Для загрузки Liga Mailer “вручную” необходимо запустить программу LMail.exe в каталоге Liga. На рабочей панели системы Windows (рядом с часами) появится изображение конверта с параграфом

При первом запуске утилиты откроется окно конфигурации почтового модуля с двумя закладками - Маршруты и HTTP/E-mail. Настройка параметров автоматического получения обновлений электронными средствами аналогична настройкам параметров в конфигураторе Сервера и описана в пункте 4.6 Раздела 1 данного руководства. На закладке Маршруты существенными являются параметры Program, Data, Log, New Texts и Work.

Внимание!

При выборке посылок с использованием автономного модуля Lmail.exe (модуль, размещенный на одном компьютере с системой, не считается автономным) необходимо обеспечить наличие в каталоге Data этого модуля актуальных файлов history.ldx (история приема) и PostList.avl (список доступных типов посылок). Для этого необходимо скопировать их туда вручную. Эти файлы не включаются в дистрибутив почтового модуля. Все успешно выбранные посылки фиксируются модулем в его локальной истории посылок. Таким образом, Вам необходимо поддерживать актуальность файла PostList.avl, который меняется только в том случае, если Вы приобрели дополнительно новые базы или перешли на новый тип версии системы.

Параметр Log определяет путь к протоколу работы утилиты. Параметр New Texts задает путь к каталогу, в котором будут сохраняться полученные обновления.

Work - путь к рабочему каталогу. Значения остальных параметров не влияют на работу системы.

Для вызова рабочего окна программы необходимо подвести курсор к этому знаку и дважды щелкнуть на нем мышкой или нажать правую кнопку мышки и выбрать из контекстного меню команду “Parameters”.

В рабочем окне программы можно настроить отдельно прием обновлений по электронной почте и отправку проверочных файлов (рис. 3.1).

Для немедленного получения недостающих обновлений с HTTP-сервера или почтового ящика можно воспользоваться кнопкой [image]. Для немедленной выкачки актуального Forall2.usr - кнопка [image]. Для отправки проверочного файла используется кнопка [image] .

Рис. 3.1. Рабочее окно программы Liga Mailer

Настройка параметров программы Liga Mailer

Внимание!

Не допускается одновременная работа Сервера системы и программы LMail.exe

Параметры приема обновлений по электронной почте (Check for new mail):

“Each N minutes” - частота проверки почтового ящика на наличие в нем писем с обновлениями;

“Время и дата приема” - этими параметрами устанавливаются конкретное время и дата проверки почтового ящика. Если указан только параметр “время”, то проверка будет проводиться ежедневно в указанное в этом поле время. Если установлен также параметр “дата”, то проверка будет выполнена единожды в указанные дату и время;

“Don’t check at all” - установка этого параметра снимает автоматическую проверку почтового ящика на наличие писем с обновлениями;

“Check new mail after start program” - проверка почтового ящика запускается сразу после старта программы Liga Mailer.

Параметры отправки проверочных файлов по электронной почте (Send mail):

“Each N minutes” - частота отправки проверочных файлов по электронной почте поставщику системы;

“Время и дата отправки” - этими параметрами устанавливаются конкретное время и дата отсылки проверочных файлов. Если указан только параметр “время”, то отсылка будет проводиться ежедневно в указанное в этом поле время. Если установлен также параметр “дата”, то отправка будет выполнена единожды в указанные дату и время;

“Don’t send at all” - установка этого параметра снимает автоматическую отправку проверочных файлов поставщику системы;

“Try send after start program” - отправка проверочных файлов запускается сразу после старта программы Liga Mailer.

После установки параметров программа по заданному расписанию будет проверять Ваш почтовый ящик на наличие в нем писем с обновлениями для системы ЛЗ и извлекать их из почтового ящика. Письма складываются в каталог Work.

Далее осуществляется разборка писем, во время которой из них извлекаются вложения (Attachments).

Все файлы с расширениями ADD, BBS и PVT из каталога Work перемещаются в каталог для приема обновлений (задается параметром “New Texts”, обычно это каталог Text_new).

Если в каталоге LOG после выполнения задачи образовался проверочный файл, то по расписанию осуществляется отправка этого файла по адресу, указанному в поле “Send to” (по умолчанию - check@liga.kiev.ua). Файл отправляется в виде вложения в письмо в кодировке UUEncode.

При выходе из программы (не из окна настроек) программа сохраняет настройки расписания в файле LMail.ini в текущем каталоге. При следующем запуске, если в командной строке не указан другой файл настроек, система восстанавливает расписание из этого файла.

Автономное функционирование LMail.exe

Утилита может быть установлена на отдельном компьютере, на котором есть доступ в Интернет или к электронной почте и на котором не установлена система ЛЗ.

Эта функция полезна в том случае, если доступ в Интернет и к электронной почте возможен только с другого компьютера, а у Вас нет сети, либо нет возможности организовать совместный доступ в Интернет Вашего компьютера через другой. В таком случае Вы можете расположить на компьютере, имеющем доступ к электронной почте, автономный почтовый модуль системы ЛЗ и настроить его на получение обновлений.

Для инсталляции утилиты откройте каталог Install на DVD-диске. Запустите программу инсталляции LM_inst.exe. В ходе инсталляции у Вас будут запрошены месторасположение программных модулей на жестком диске и название программной группы. В каталог, определенный для установки утилиты, будут скопированы необходимые программные модули, а также созданы необходимые для работы подкаталоги: Data, Log, Text_New и Work.


4. ОБНОВЛЕНИЕ СИСТЕМЫ С ПОМОЩЬЮ DVD-ДИСКА

Инсталляция системы ЛЗ, поставляемая на фирменном DVD-диске, позволяет установить систему “с нуля”, переустановить систему заново, переустановить с существующими параметрами или обновить только ее программную часть. Программу Install.exe можно запускать не только с фирменного DVD-диска, но и с винчестера, и даже с сетевого ресурса, предварительно скопировав туда содержимое инсталляционных дисков, каждого в отдельную директорию.

При запуске программа установки пытается обнаружить на Вашем компьютере ранее установленную версию системы ЛЗ. Если система не обнаружена, то программа осуществляет установку по стандартной схеме. При этом Вам будет необходимо определить все параметры установки (как это сделать, описано в п. 3.1 Раздела 1 данного руководства)

4.1. Обновление Сервера

Примечание

Обновление базы данных системы ЛЗ может быть проведено с помощью программы установки, находящейся на фирменном DVD-диске (сценарий “Обновить систему с существующими параметрами”).

Обновление программной оболочки может быть проведено с помощью программы установки, находящейся на фирменном DVD-диске (сценарий “Обновить только программное обеспечение”).

В случае обнаружения ранее установленной системы программа запросит Вас о желаемом способе установки системы (рис. 4.1).

Рис. 4.1. Окно выбора сценария инсталляции системы

Внимание!

Если Вы выбрали сценарий обновления, а система ЛЗ запущена на Вашем компьютере, то программа установки выдаст предупреждение (рис. 4.2) и не запустит инсталляцию, пока активное приложение и Сервер ЛЗ не будут выгружены.

Рис. 4.2. Окно с предупреждением о том, что запущена система ЛЗ

Основными условиями обнаружения системы на Вашем компьютере являются:

· наличие в регистрационной базе (Registry) операционной системы, установленной на Вашем компьютере, записей о расположении системы ЛЗ (пути к программам и данным);
· наличие неповрежденного ключевого файла (XХХХХ.usr, где XXXXX - регистрационный номер лицензионного пакета системы), содержащего регистрационную информацию пользователя, по пути, заданному в регистрационной базе Вашего компьютера.

Если установленная на Вашем компьютере система имеет более позднюю версию, чем инсталлируемая, то программа инсталляции предупредит Вас об этом (рис. 4.3). В этом случае Вы можете отказаться от дальнейшей инсталляции.

Рис. 4.3. Окно с предупреждением о том, что система ЛЗ, установленная на компьютере, имеет более позднюю версию, чем данная инсталляция

Рассмотрим возможные сценарии инсталляции, предлагаемые программой инсталляции системы ЛЗ (рис. 4.1):

Обновить систему с существующими параметрами

Этот сценарий позволяет осуществить обновление базы данных системы ЛЗ с помощью DVD-диска.

Если Вы выберете сценарий “Обновить систему с существующими параметрами”, то программа установки не будет запрашивать у Вас параметры системы, а сразу приступит к копированию файлов программ и данных, используя текущие установки системы.

Далее программа инсталляции оценит актуальность базы данных, содержащейся в инсталляционном пакете, и базы, установленной на Вашем компьютере. Если содержащаяся у Вас база является более актуальной, то инсталляционная программа отберет посылки, выравнивающие актуальность инсталлируемой базы. Эти посылки, принятые Вами ранее, сохраняются в каталоге, задаваемом параметром “Save Sends” (по умолчанию - SaveArc\) конфигурации системы. Отобранные посылки программа инсталляции поместит в каталог, задаваемый параметром “New Texts” (по умолчанию - Text_new\) конфигурации системы. Если после завершения инсталляции системы Вы выполните задачу “Прием в базу”, то актуальность Вашей базы будет восстановлена.

Примечание

1. Если необходимые посылки не будут обнаружены в каталоге, задаваемом параметром “Save Sends” (по умолчанию - SaveArc\), то для восстановления актуальности базы Вам необходимо выполнить задачу “Общая проверка базы” (см. п. 2.2.1 Раздела 2) и передать Вашему поставщику системы ЛЗ проверочный файл (000xxxxx.CHK, где xxxxx - регистрационный номер комплекта системы). После обработки Вашего проверочного файла Вам будут переданы индивидуальные посылки (файлы XXXXXnnn.PVT, где XXXXX - регистрационный номер комплекта системы, а nnn - порядковый номер посылки), которые Вам необходимо будет принять в базу системы ЛЗ в установленном порядке (см. п. 2.1.1 Раздела 2).
2. Если у Вас установлен вариант системы с поддержкой Собственных БД, то инсталляционная программа предложит Вам выполнить резервное копирование документов, содержащихся в пользовательской базе. Резервная копия будет сохранена в подкаталоге OwnerBase\ каталога, задаваемого параметром “Save Sends” (по умолчанию - SaveArc\). После завершения инсталляции системы Вы сможете восстановить Собственные БД из резервной копии, воспользовавшись задачей “Восстановление резервной копии базы собственных документов”.

Обновить только программное обеспечение

Обновлять программное обеспечение можно только в том случае, если версия инсталляционного пакета совпадает с версией системы ЛЗ, установленной на Вашем компьютере. Это связано с тем, что форматы файлов данных в различных версиях могут отличаться. Чтобы узнать версию установленной на компьютере системы, необходимо запустить программу Ligaver.exe, которая находится в корневом каталоге Сервера (по умолчанию это каталог Liga).

При выборе этого сценария программа инсталляции скопирует из инсталляционного пакета только файлы программ, а файлы базы данных заменяться не будут.

Этим сценарием целесообразно воспользоваться в тех случаях, когда Вы уверены в целостности и актуальности базы данных системы ЛЗ, установленной на Вашем компьютере, и у Вас возникла необходимость восстановить файлы программ либо установить более свежую версию программного обеспечения.

Переустановить систему заново

В этом случае Вы переходите к стандартному сценарию инсталляции. Программа установки попросит Вас определить все необходимые параметры и приступит к копированию файлов программ и данных на Ваш компьютер. При этом все записи в регистрационной базе данных операционной системы Вашего компьютера, относящиеся к системе ЛЗ, будут обновлены. Этот процесс подробно описан в п. 3.1 Раздела 1 данного руководства.

Завершить инсталляцию

При выборе этого действия выполнение инсталляционной программы завершится. Никакие изменения в установленную у Вас систему ЛЗ вноситься не будут.

4.2. Обновление сетевых Клиента и Администратора

Обновление Клиента и Администратора с помощью программы установки

При запуске программа установки сетевого Клиента (Install LIGA Client) или Администратора (Install LIGA Admin) попытается обнаружить на Вашем компьютере ранее установленную версию соответствующей программной оболочки системы ЛЗ (рис. 4.4). Если оболочка не была обнаружена, то программа осуществляет установку по стандартной схеме. При этом Вам будет необходимо определить все параметры установки. Как это сделать, описано в Разделе 1, п. 3.

Рис. 4.4. Окно выбора варианта инсталляции Клиента системы

При обнаружении установленной оболочки Клиента или Администратора программа предложит обновить систему.

При выборе опции “Переустановить систему заново” Вам придется определить все параметры Клиента или Администратора заново. Как это сделать, описано в Разделе 1, п. 4.3, 4.8.

При выборе опции “Обновить систему с существующими параметрами” программа установки заменит программную часть автоматически, используя текущие установки программной оболочки Клиента или Администратора.

Если установленная на Вашем компьютере система имеет более позднюю версию, чем инсталлируемая, то программа инсталляции предупредит Вас об этом (рис. 4.5). В этом случае Вы можете отказаться от дальнейшей инсталляции.

Рис. 4.5. Окно с предупреждением о том, что система ЛЗ, установленная на компьютере, имеет более позднюю версию

Автоматическое обновление Клиента и Администратора

при первом запуске после обновления Сервера

Если Вы запустите программную оболочку Клиента или Администратора, которая имеет более раннюю версию по сравнению с Сервером системы ЛЗ, то на экране компьютера появится соответствующее сообщение с предложением обновить программную часть Клиента или Администратора (рис. 4.6).

Рис. 4.6. Окно с предложением обновить программное обеспечение системы

Если Вы решите обновить программное обеспечение (кнопка Да), то система запустит сервиспак (см. п. 1 Раздела 6) и завершит свое выполнение. Сервиспак определит все параметры системы и выполнит ее обновление в соответствии с текущей конфигурацией. После завершения обновления сервиспак сам запустит Клиента или Администратора системы ЛЗ.

Если Вы откажетесь от обновления программного обеспечения (кнопка Нет), то оболочка, которая активизировала сервиспак, запущена не будет.

Основным условием обнаружения Клиента или Администратора системы на Вашем компьютере является наличие в регистрационной базе (Registry) операционной системы, установленной на Вашем компьютере, записей о расположении системы ЛЗ.

При автоматическом обновлении Клиента с помощью сервиспака проверяются права пользователя и, если они уже, чем права администратора, выдается предупреждение об отсутствии прав администратора (рис. 4.7):

Рис. 4.7. Предупреждение об отсутствии прав Администратора при обновлении программного обеспечения


5. УДАЛЕННЫЙ ДОСТУП

Если для Вас открыт удаленный доступ, то Вы можете устанавливать Клиента и Администратора на удаленном для Сервера компьютере, связь с которым осуществляется через интернет-соединение. То есть у Вас появляется возможность работать с документами не только в локальной сети у себя в офисе, а и на любом другом компьютере, имеющем доступ к сети Интернет.

Для создания новых удаленных пользователей системы Вам необходимо отправить на электронный адрес ООО "ЛИГА ЗАКОН" письмо с именами (login) пользователей, для которых разрешается удаленный доступ. В ООО "ЛИГА ЗАКОН" формируется системный файл, в котором указываются имена удаленных пользователей, максимальное число раз смены рабочего места пользователя (лимит мобильности) и дата, до которой пользователю разрешен доступ к системе ЛЗ (дата продлевается автоматически с датой абонентского обслуживания, но может быть установлена и вручную).

Системный файл для удаленных пользователей называется ForAll_R.USR и отсылается Вам в системной посылке ALLxxxxx.ADD. После приема такой посылки системный файл помещается в подкаталог DATA того каталога, в котором установлен Сервер системы (по умолчанию это каталог Liga). После обработки этого файла у Вас формируется база удаленных пользователей с указанными именами пользователей. За базу удаленных пользователей отвечают файлы rudb.dat и rudb.idx, которые размещены в каталоге DATA.

Сервер обеспечивает одновременное обслуживание как локальных, так и удаленных пользователей. Пользователь системы, которому разрешен удаленный доступ, может подключаться к системе и локально. При этом ограничения по удаленному доступу не проверяются. Пользователь administrator при открытом удаленном доступе автоматически является удаленным. В Менеджере пользователей (см. Раздел 2, п. 4.1) удаленные пользователи отображаются пиктограммой салатового цвета. Для управления удаленными пользователями предназначена База удаленных пользователей (см п. 4 данного Раздела).

Для корректной работы удаленного клиента системы ЛЗ необходимо разрешить процессу liga.exe подключение к соответствующему удаленному (находящемуся в сети Internet) серверу ЛЗ по протоколу TCP, порт 30583.

5.1. Инсталляция удаленного Клиента

Для инсталляции удаленных Клиентов используется программа Cli_rem.exe, которая находится в каталоге Install\ на фирменном DVD-диске. Скопируйте ее в одноименный подкаталог каталога Liga, в котором установлен Сервер, и запустите.

Процедура инсталляции удаленного Клиента в целом совпадает с процедурой инсталляции сетевого Клиента и подробно описана в п. 3.3 Раздела 1. В указанном пункте обратите внимание на отдельные моменты, касающиеся удаленного Клиента.

5.2. Инсталляция удаленного Администратора

Для инсталляции удаленного Администратора используется программа Adm_rem.exe, которая находится в каталоге Install\ на фирменном DVD-диске. Скопируйте ее в одноименный подкаталог каталога Liga, в котором установлен Сервер, и запустите.

Процедура инсталляции удаленного Администратора в целом совпадает с процедурой инсталляции Администратора локальной сети и подробно описана в п. 3.2 Раздела 1.

5.3. Настройка параметров Клиента и Администратора

Для конфигурирования удаленных Клиента и Администратора используется программа Ligacfg.exe, которая запускается с помощью ярлыков Конфигурация Клиента ЛІГА:ЗАКОН и Конфигурация Администратора ЛІГА:ЗАКОН в программной группе LIGA.

Настройка параметров, используемых при конфигурировани удаленных Клиента и Администратора, в основном совпадает с настройкой параметров сетевых Клиента и Администратора и описана в п. 4.8 Раздела 1.

Различия в настройке присутствуют, в частности, в настройке параметров связи на закладке Связь.

5.4. База удаленных пользователей

Если в поставку системы включена возможность удаленного доступа к базам данных ЛЗ, то для администрирования базы удаленных пользователей в меню Администраторa появится кнопка [image]. Нажав на нее, Вы увидите окно “База удаленных пользователей” со списком удаленных пользователей (рис. 5.1).

Рис. 5.1. Окно базы удаленных пользователей

На панели инструментов окна “База удаленных пользователей” расположены следующие кнопки:

· создание/изменение пароля для пользователя, которому разрешен удаленный доступ к системе ЛЗ;
· синхронизация базы удаленных пользователей с базой пользователей системы, работающих в локальной сети. После синхронизации удаленные пользователи отображаются в Менеджере пользователей и выделяются зеленым цветом.

Внимание!

Если Вы переустанавливаете удаленного Клиента системы на другой компьютер, то при входе в систему появится окно с предупреждением о том, что у Вас уменьшается лимит мобильности. Когда лимит мобильности достигнет значения “0”, удаленный Клиент не сможет зайти в систему.

При работе сетевого Клиента системы с именем пользователя, которому разрешен удаленный доступ к базам данных, лимит мобильности не проверяется.


5.4. База удаленных пользователей

Если в поставку системы включена возможность удаленного доступа к базам данных ЛЗ, то для администрирования базы удаленных пользователей в меню Администраторa появится кнопка [image]. Нажав на нее, Вы увидите окно “База удаленных пользователей” со списком удаленных пользователей (рис. 5.1).

Рис. 5.1. Окно базы удаленных пользователей

На панели инструментов окна “База удаленных пользователей” расположены следующие кнопки:

· создание/изменение пароля для пользователя, которому разрешен удаленный доступ к системе ЛЗ;
· синхронизация базы удаленных пользователей с базой пользователей системы, работающих в локальной сети. После синхронизации удаленные пользователи отображаются в Менеджере пользователей и выделяются зеленым цветом.

Внимание!

Если Вы переустанавливаете удаленного Клиента системы на другой компьютер, то при входе в систему появится окно с предупреждением о том, что у Вас уменьшается лимит мобильности. Когда лимит мобильности достигнет значения “0”, удаленный Клиент не сможет зайти в систему.

При работе сетевого Клиента системы с именем пользователя, которому разрешен удаленный доступ к базам данных, лимит мобильности не проверяется.


6. ДОПОЛНИТЕЛЬНЫЕ ЗАДАЧИ

6.1. Ресурсный сервис-пак

Начиная с версии 9 система ЛЗ предоставляет пользователям возможность получить доступ к работе с новыми ресурсами при помощи инсталляционного файла.

Файл для обновления версии, дополненной новыми ресурсами, пользователь получает непосредственно после обращения с соответствующим запросом в компанию ЛИГА:ЗАКОН или к обслуживающему региональному представителю.

Процесс установки ресурсов производится запуском файла вручную. Процесс фиксируется в лог-файле SP.log в папке Liga\Log.

Перед запуском приложения необходимо принять файл ForAll2.usr, который откроет новые базы в ключе. Если файл ForAll2.usr принят не будет, то будет обновлена только программная часть, а обновления для новых ресурсов приняты не будут. Пользователь может установить информационные ресурсы позже с помощью данного сервис-пака, предварительно приняв в систему актуальный ForAll2.usr.

Программа установки ресурсов запускает инсталляцию сервис-пака, распаковывает посылки в каталог приема (установленный параметром “New Texts” настроек Сервера системы ЛЗ, по умолчанию это каталог Text_new\), запускает Сервер системы и административную задачу “Прием обновлений”. При этом Сервер системы должен оставаться в рабочем состоянии на время приема посылок. Если версия установленной у пользователя системы равна версии сервис-пака, то запускается только прием посылок одного или нескольких новых ресурсов, открытых в ключе. В систему будут приняты все посылки с момента выхода нового ресурса.

6.2. Автоматическое обновление сетевых Клиента и Администратора

Программные оболочки сетевых Клиента и Администратора системы ЛЗ осуществляют автоматический контроль версий своих программных модулей. При подключении к Серверу они передают ему свой номер версии. Сервер сравнивает этот номер с номером, зарегистрированным у него. Этот номер регистрируется при инсталляции Сервера и автоматически обновляется каждым очередным сервиспаком. Если текущая версия программной оболочки является более ранней, чем зарегистрированная для Сервера, то Сервер передает Клиенту (или Администратору) сообщение о необходимости обновления версии. Процесс обновления сетевых Клиента и Администратора полностью аналогичен изложенному в п. 2 Раздела 4 (автоматическое обновление Клиента и Администратора при первом запуске после обновления Сервера).

6.3. Перенос системы ЛЗ с другого компьютера

Если у Вас возникла необходимость в переносе системы с другого компьютера, и Вы хотите сохранить текущее состояние базы данных, то Вы можете сделать это следующим образом. Установите DVD-диск в Ваш DVD-ROM, на экране появится меню. Для начала переноса нажмите пункт "ПЕРЕНЕСЕННЯ СИСТЕМИ ЛІГА:ЗАКОН".

Программа выдаст Вам запрос о параметрах системы в соответствии со стандартным сценарием. После определения всех параметров, перед началом копирования файлов и программ, она предложит Вам определить настройки переноса системы с другого компьютера (рис. 6.1):

Рис. 6.1. Окно переноса системы с другого компьютера

При выборе варианта "Регистрация системы" программа установки осуществит регистрацию системы в регистрационной базе операционной системы, установленной на Вашем компьютере, и завершит свое выполнение. Этот вариант используется в том случае, если пользователь скопировал систему ранее с другого компьютера и ему необходимо зарегистрировать систему в реестре с ключевым файлом, находящимся в каталоге системы. Либо же на компьютере была переустановлена операционная система и необходимо внести данные системы ЛЗ в реестр.

При выборе варианта "Регистрация с новым номером ключа" программа установки осуществит регистрацию системы с новым ключом в регистрационной базе операционной системы.

Для переноса файлов системы и регистрации программ в реестре Windows необходимо выбрать пункт "Перенос с диска на диск" (рис. 6.1). Чтобы выбрать место расположения системы нажмите кнопку Обзор... . Этот вариант инсталляции системы удобен в случае переноса системы с одного компьютера на другой тогда, когда система, установленная на компьютере, имеет более актуальную базу по сравнению с инсталляционным диском, входящим в комплект поставки системы во время ее приобретения.

Примечание

После переноса Сервера системы ЛЗ на другой компьютер Вам придется переконфигурировать параметры связи (Communications) всех сетевых Клиентов, настроив их на другое имя сервера. Как это сделать, подробно описано в Разделе 1, п. 4.8.


ПРИЛОЖЕНИЕ 1. Осуществление технической поддержки

Контактный телефон Службы

технической поддержки:

(044) 585-24-01 (многоканальный)

E-mail: support@ligazakon.ua

admin@ligazakon.ua

Обращаясь в Службу технической поддержки,

следует знать следующее:

· название Вашей организации;
· регистрационный номер Вашего комплекта системы ЛЗ и способ получения обновлений от нас, если Вы являетесь зарегистрированным пользователем нашей системы;
· номер версии Вашей системы (9.4.1 и т. д.);
· вариант системы - локальный или сетевой.

Вам следует, по возможности:

· четко сформулировать вопрос или возникшую проблему;
· передать точное дословное сообщение системы об ошибке;
· позвонить, находясь рядом с тем компьютером, где возникла проблема.

Примечание

Прежде чем обращаться в Службу технической поддержки, рекомендуем Вам ознакомиться с часто задаваемыми вопросами о ответами на них на странице http://support.ligazakon.ua ), раздел "Вопросы и ответы". Возможно, среди них Вы найдете ответ и на свой вопрос.


ПРИЛОЖЕНИЕ 2. Описание служебного файла Common.ini

Секция [BackUp]

Параметр NoSavePostFiles :

0 означает сохранять в SAVEARC успешно принятые посылки. Это значение установлено по умолчанию;

1 означает не сохранять в SAVEARC успешно принятые посылки.

Параметр SaveArcDays :

60 - означает сохранять в SAVEARC успешно принятые посылки в течение 60 дней. Это значение установлено по умолчанию;

значения параметра должны быть в пределах 0-365. Если параметра нет или его значение за пределами указанного интервала - будет установлено 60 дней.

Секция [Receive]

Параметр TestSessionSize :

от 400 до 6000 - означает максимальное количество документов, которое может быть принято в систему за одну порцию приема при выполнении операции "Прием в базу" (см. п. 2.1.1 Раздела 2). По умолчанию установлено 1600.

Параметр LogSteps :

0 означает ведение обычного протокола. Это значение установлено по умолчанию;

1 означает внесение в протокол дополнительных сообщений об этапах приема (на английском языке).

Секция [MaxSize]

Параметр ReceiveLog :

4000000 Этот параметр задает максимальный размер в байтах протокола приема, при котором он укорачивается наполовину.

Значение 4000000 установлено по умолчанию.

0 или отсутствие ключа означает неограниченный по размеру протокол.

Внимание!

Секции и параметры, не указанные в этом приложении, носят служебный характер.

Их изменение категорически запрещено!


ПРИЛОЖЕНИЕ 3. Вспомогательные утилиты

Утилиты настройки и конфигурирования электронных ключей

В настоящее время системы ЛЗ поддерживают работу с электронными ключами Guardant. Каталог с драйверами и утилитами размещен в основном каталоге системы (по умолчанию - ..\Liga\) и носит название Guardant.drv.

Утилиты для работы с ключами Guardant:

Для этого типа ключей предусмотрены утилиты:

· grddriversru.msi предназначена для инсталляции и переустановки драйверов электронных ключей защиты типа Guardant. Не рекомендуем Вам изменять настройки конфигурации электронного ключа без предварительной консультации Службы технической поддержки "ЛИГА:ЗАКОН".
· GRDEM32.exe предназначена для обнаружения и проверки работоспособности установленных электронных ключей защиты типа Guardant.
· CheckGRD.exe проверяет физическое наличие ключей типа Guardant в портах.

В случае возникновения вопросов по использованию вышеперечисленных утилит обращайтесь в Службу технической поддержки компании “ЛИГА:ЗАКОН” по тел. (044) 585-24-01, http://support.ligazakon.ua

Утилита контроля целостности файлов данных FIX_DATA.EXE

Данная утилита находится в корневом каталоге системы ЛЗ и используется для восстановления работоспособности системы после сбоев в работе компьютера при выполнении административных задач. Утилита может применяться, если в работе системы появляются сообщения "Ошибка чтения-записи из файла данных", "Ошибка в имени пользователя".

Рекомендуем использовать утилиту только в случае появления этих ошибок.

Перед использованием данной программы необходимо выгрузить Сервер системы. После запуска утилиты нужно выбрать из списка в диалоговом окне файл:

файл базы пользователей ubd.dat в том случае, если возникли проблемы с логинами и паролями пользователей,

файл базы прав objdb.dat,

после чего нажать кнопку "Fix it!".

Утилита проверки номера версии системы ЛЗ

В основном каталоге системы ЛЗ (по умолчанию - ..\Liga\) расположена утилита Ligaver.exe, с помощью которой можно узнать версии программных компонентов системы. После запуска утилита выводит окно (рис. 1), в котором указаны программные компоненты, проинсталлированные в Вашей системе, и их версии.

Рис. 1. Утилита проверки версии системы

Утилита сбора информации об установленной на компьютере

пользователя версии системы ЛЗ и ее окружении

Утилиту сбора информации следует использовать по запросу сотрудников Службы поддержки Абонентов Сети в том случае, если при решении вопроса, с которым Вы обратились в Службу поддержки Абонентов Сети, Вы затрудняетесь дать точные ответы на вопросы сотрудников Службы об установленной на Вашем компьютере версии системы ЛЗ, технических характеристиках компьютера, установленных и запущенных сервисах и приложениях и т. д.

Утилита LigaInfo.exe находится на инсталляционном DVD-диске в каталоге Install (если инсталляционный пакет состоит из нескольких дисков, то утилита находится на первом диске). Для запуска утилиты дважды щелкните мышью на ярлыке [image].

После установки системы для сбора информации о системе ЛЗ, о ее Администраторе или Клиенте в Программной группе LIGA нужно выбрать соответствующий пункт меню, в зависимости от того, информация о каком программном продукте Вам нужна:

- [image] Information about LIGA ZAKON system;

- [image] Администратор - Информация о системе ЛІГА ЗАКОН;

- [image] Клиент - Информация о системе ЛІГА ЗАКОН.

Сбор информации может занять некоторое время, дождитесь его завершения. На экране откроется информационное окно с древовидной структурой в соответствии с информационными разделами: программы компании "ЛИГА:ЗАКОН", общие параметры, жесткие диски, монитор, принтеры, устройства, драйвера и т. д., см. рис. 2.

Рис. 2. Основное окно утилиты сбора информации

С помощью кнопки Send by e-mail можно отправить SysInfo.txt и log-файлы в Службу технической поддержки Абонентов компании "ЛИГА:ЗАКОН". При нажатии на данную кнопку открывается окно, в котором можно выбрать файлы, которые необходимо отправить по почте:

Рис. 3. Окно выбора файлов к отправке

После выбора файлов нажмите кнопку ОК, сформируется письмо в почтовой программе, установленной по умолчанию на Вашем компьютере.

Результаты работы утилиты можно сохранить в текстовом файле (кнопка Save) и передать в Службу технической поддержки. При этом объем сохраняемой в файл информации зависит от позиции курсора в древовидной структуре: если активен корень дерева "Вся информация", то сохраняются все информационные разделы (ветви); если активна одна из веток, например, "Общие параметры", то сохраняется информация только из этого раздела.

Кнопка Close служит для завершения работы с утилитой.


РУКОВОДСТВО АДМИНИСТРАТОРА (сетевой вариант)

© Информационно-аналитический центр "ЛИГА",

ООО "ЛИГА ЗАКОН", 2014

04112, г. Киев, ул. Т. Шамрыло, 23

тел. (044) 538-01-03

e-mail: sales@ligazakon.ua

http://www.ligazakon.ua

РУКОВОДСТВО АДМИНИСТРАТОРА

Локальной БД “Учет персонала”

Системы информационно-правового обеспечения

ЛІГА:ЗАКОН

ОБСЛУЖИВАНИЕ ЛОКАЛЬНОЙ БД “УЧЕТ ПЕРСОНАЛА”

УПРАВЛЕНИЕ ПОЛЬЗОВАТЕЛЯМИ СИСТЕМЫ

УПРАВЛЕНИЕ ПРАВАМИ ДОСТУПА

АДМИНИСТРИРОВАНИЕ КОРПОРАТИВНЫХ ПОРТФЕЛЕЙ


1. ОБСЛУЖИВАНИЕ ЛОКАЛЬНОЙ БД “УЧЕТ ПЕРСОНАЛА”

1.1. Правила обслуживания

В систему ЛЗ входит готовый шаблон Локальной БД, который имеет название "Учет персонала". Локальная база "Учет персонала" для кадровой службы предприятия любой величины служит механизмом учета, анализа и поддержания в актуальном состоянии основных личных данных сотрудников предприятия на основании формы П - 2, с разграничением прав доступа к этим данным.

"Локальная БД" - это база данных документов пользователей, которая создается и доступна в рамках вашей системы. Модуль конструирования Локальной БД называется Конструктором БД.

В отличие от баз данных систем семейства ЛЗ, которые пополняются и поддерживаются в актуальном состоянии посылками, созданными в ООО "ЛИГА ЗАКОН", информационное наполнение Локальной БД полностью находится в зоне ответственности самих пользователей системы ЛЗ.

Сохранность информационного наполнения Локальной БД системы ЛЗ обеспечивается таким инструментом, как резервное копирование Локальной БД. Мы рекомендуем Вам самостоятельно определить необходимую частоту выполнения этой задачи в зависимости от интенсивности операций модификации документов. Кроме этой задачи, в обслуживание Локальной БД входит прием в базу новых и обработка модифицированных документов - все это выполняется с помощью задачи "Создание и прием собственных посылок".

Мы рекомендуем Вам установить выполнение задач "Создание и прием собственных посылок" и резервного копирования по расписанию и обязательно проверять протоколы выполнения задач (ligasrv.log, receive.log).

В обязанности Администратора системы ЛЗ входит также постоянный мониторинг свободного места на том жестком диске, где установлена система.

1.2. Задачи администрирования

Доступ к конструированию Локальной БД и модификации ее структуры имеет Владелец Локальной БД и пользователь под именем administrator.

Право редактирования Справочника значений и Классификатора на этапе заполнения карточки поисковых реквизитов назначается другим пользователям системы, если загрузить Клиент системы пользователем под именем administrator.

Задачи сопровождения Локальной БД находятся в Менеджере задач программы Администратора системы ЛЗ на закладке "Собственные базы", рис. 1.1.

Рис. 1.1. Менеджер задач на закладке “Собственные базы”

1.2.1. Создание и прием собственных посылок

Основной задачей администрирования Локальной БД является задача "Создание и прием собственных посылок". Эта задача запускается в случае, если пользователем были добавлены новые, либо модифицированы существующие документы Локальной БД. Предварительно подготовленные документы (карточки поисковых реквизитов и, возможно, тексты) размещаются в каталоге, задаваемом параметром "Custom Base" (по умолчанию - каталог SelfBase\).

При запуске рассматриваемой задачи система ищет в указанном каталоге файлы подготовленных документов и оформляет их в формате стандартных посылок с расширением COR, которые размещаются в каталоге, задаваемом параметром "New Texts" (по умолчанию - каталог Text_New\). На следующем этапе запускается стандартный алгоритм приема посылок, описанный в Руководстве администратора систем ЛЗ, пункт "Прием в базу".

1.2.2. Резервирование Локальной БД

Резервное копирование Локальной БД - важный элемент защиты Вашей информации в случае сбоя на винчестере или в программном обеспечении. Рекомендуем Вам определить необходимую частоту запуска задачи резервного копирования в зависимости от интенсивности работы по модификации документов Локальной БД и настроить выполнение этой задачи по расписанию.

Резервное копирование

Задача "Создание резервной копии базы собственных документов" архивирует в каталог ...\Liga\SaveArc\OwnerBase\ все документы из собственной базы, файлы описателей баз def148.lht, defcuser.lht и файл common.ini, в котором содержится информация, необходимая для поддержания уникальности имен файлов документов, вводящихся в базу. Имя файла-архива XXXBckUp.bsb содержит номер Вашего ключа защиты в упакованном виде ХХХ. Мы рекомендуем архивировать Вашу Локальную базу каждый раз перед выполнением задачи "Создание и прием собственных посылок". Таким образом, Вы будете застрахованы от сбоев во время приема, связанных с ошибками на жестком диске, перебоями питания и т.п. Архивирование делается также при обновлении системы ЛЗ с DVD-диска, если выбран режим обновления системы с существующими параметрами. В таком случае система сама предложит Вам создать резервную копию, и мы рекомендуем Вам не отказываться от этой процедуры.

Если в момент архивации в каталоге уже обнаружен файл резервной копии, сделанный ранее, этот архив переименовывается - к его имени добавляется дата переименования. Вы можете хранить несколько резервных копий или удалять их, если Вы уверены, что последняя резервная копия содержит все необходимые Вам документы.

Восстановление из резервной копии

Задача "Восстановление резервной копии базы собственных документов" выполняется в случае, если Вами обнаружен серьезный сбой в базах данных системы ЛЗ, а также в случае переноса системы на другой винчестер.

При запуске этой задачи из каталога ...\Liga\SaveArc\OwnerBase распаковывается файл резервной копии ХХХBckUp.bsb и запускается задача приема посылок в базу. Если Вам нужно восстановить базу из более ранней резервной копии - переименуйте ее файл.

1.3. Выполнение задач администрирования по расписанию

В режиме "Менеджер задач" на закладке Собственные базы возможна настройка параметров запуска задач по расписанию. К задачам обслуживания Локальной БД относятся следующие задачи:

· Создание и прием собственных посылок
· Создание резервной копии базы собственных документов
· Восстановление резервной копии базы собственных документов.

Для настройки выполнения задач по расписанию необходимо настроить частоту запуска в окне "Настройка параметров", которое вызывается кнопкой [image] Корректировать параметры задачи в Менеджере задач. Подробно настройка выполнения задач по расписанию описана в Руководстве администратора систем ЛІГА:ЗАКОН.

Задачу восстановления Локальной БД из резервной копии рекомендуется выполнять только в случае выявления сбоев в информационном наполнении системы и не включать в расписание.


2. УПРАВЛЕНИЕ ПОЛЬЗОВАТЕЛЯМИ СИСТЕМЫ

Управление пользователями системы ЛЗ происходит из оболочки Администратора системы. В системе могут быть пользователи, подключенные по локальной сети, и удаленные пользователи, использующие для доступа к информационным ресурсам системы интернет-соединение.

2.1. Пользователи локальной сети

Управление пользователями локальной сети осуществляется из режима Менеджер пользователей программы Администратора системы ЛЗ.

Операции добавления новых пользователей, редактирование их параметров, удаление пользователей, управление их правами в целом, создание групп пользователей описаны в Руководстве администратора систем ЛІГА:ЗАКОН.

Обращаем Ваше внимание на отдельные виды прав, использование которых характерно ведения Локальной БД, рис. 2.1:

· Разрешено создавать Корпоративные портфели - доступ на создание Корпоративных портфелей, см. Раздел 4.
· Уровень доступа (1 - min, 10 - max) - используется системой соответствия уровней доступа пользователей и уровня секретности документа при определении прав доступа к документу.

Рис. 2.1. Параметры пользователя на закладке "Права"

2.2. Удаленные пользователи

В системе ЛЗ Вы можете устанавливать Клиента и Администратора на удаленном для Сервера компьютере, связь с которым осуществляется через интернет-соединение. Таким образом, у Вас появляется возможность работать с документами не только в локальной сети у себя в офисе, а и на любом другом компьютере, имеющем доступ к сети Интернет.

Для создания новых удаленных пользователей системы Вам необходимо отправить на электронный адрес ООО "ЛИГА ЗАКОН" письмо с именами (login) пользователей, для которых разрешается удаленный доступ. В ООО "ЛИГА ЗАКОН" формируется системный файл ForAll_R.USR, в котором указываются имена удаленных пользователей, максимальное число раз смены рабочего места пользователя (лимит мобильности и дата, до которой пользователю разрешен доступ к системе ЛЗ (дата продлевается автоматически с датой абонентского обслуживания но может быть установлена и вручную). Системный файл отправляется системной посылкой ALLxxxxx.ADD.

После приема такой посылки системный файл помещается в подкаталог DATA того каталога, в котором установлен Сервер системы (по умолчанию это каталог Liga). После обработки этого файла у Вас формируется база удаленных пользователей с указанными именами пользователей. За базу удаленных пользователей отвечают файлы rudb.dat и rudb.idx, которые размещены в каталоге DATA.

Сервер обеспечивает одновременное обслуживание как локальных, так и удаленных пользователей. Пользователь системы, которому разрешен удаленный доступ, может подключаться к системе и локально. При этом ограничения по удаленному доступу не проверяются. Пользователь administrator при открытом удаленном доступе автоматически является удаленным. В Менеджере пользователей удаленные пользователи отображаются пиктограммой салатового цвета.

Инсталляция программного обеспечения удаленного Администратора и Клиента системы, настройка параметров соединения с сервером подробно описаны в Руководстве администратора систем ЛІГА:ЗАКОН.

Для администрирования базы удаленных пользователей предназначен режим Менеджер удаленных пользователей, который открывается кнопкой [image] окна ЛІГА:Администратор, рис. 2.2.

Рис. 2.2. Окно менеджера удаленных пользователей

На панели инструментов окна "Менеджер удаленных пользователей" расположены следующие кнопки:

создание/изменение пароля для пользователя, которому разрешен удаленный доступ к системе ЛЗ;

синхронизация базы удаленных пользователей с базой пользователей системы, работающих в локальной сети. После синхронизации удаленные пользователи отображаются в Менеджере пользователей и выделяются зеленым цветом.

Внимание!

Если Вы переустанавливаете удаленного Клиента системы на другой компьютер, то при входе в систему появится окно с предупреждением о том, что у Вас уменьшается лимит мобильности. Когда лимит мобильности достигнет значения "0", удаленный Клиент не сможет зайти в систему.

При работе сетевого Клиента системы с именем пользователя, которому разрешен удаленный доступ к базам данных, лимит мобильности не проверяется.


3. УПРАВЛЕНИЕ ПРАВАМИ ДОСТУПА

Модуль управления правами доступа к Локальной БД пользователей вызывается кнопкой [image] в окне ЛІГА:Администратор, см. рис. 3.1. В этом окне реализовано управление правами доступа к Локальной БД в целом и к ее документам.

В нижней части окна в выпадающем меню выберите название Локальной базы. (Меню доступно, если Вы приобрели несколько Конструкторов БД.) В окне отобразится список документов выбранной Локальной БД.

Рис. 3.1. Окно менеджера базы прав

В нижней части окна расположены кнопки, с помощью которых можно:

· установить права на базу;
· установить права на документы;
· снять права на базу и документы.

C помощью кнопки [image] Права на базу определите доступ пользователей к базе в целом:

· Владелец (О) - разрешается изменять конфигурацию Локальной БД, просматривать, создавать и модифицировать (удалять) все документы Локальной БД, а также назначать на них права другим пользователям;
· Разрешен просмотр (R) - разрешается просмотр документов Локальной БД;
· Разрешена модификация (M) - разрешается просматривать, добавлять, модифицировать и удалять документы Локальной БД.

Модуль управления правами доступа имеет единый интерфейс окна определения прав, рис. 3.2, который используется во всех диалогах определения прав к объектам системы.

Рис. 3.2. Окно назначения прав доступа

Чтобы назначить права отдельному пользователю, необходимо выбрать (пометить мышкой) его имя из списка в левом окне и нажать кнопку [image]. Имя пользователя будет внесено в общий Список групп и пользователей в верхнем окне (рис. 3.2), после чего необходимо отметить необходимые опции в списке возможных прав доступа: Владелец, Разрешен просмотр, Запрещен просмотр, Разрешена модификация, Запрещена модификация. Для разных объектов базы прав (баз данных, отдельных документов, Портфелей, разделов Портфелей) уровень прав устанавливается отдельно и хранится в таблице прав в упакованном формате. По умолчанию, если права на объект конкретному пользователю в таблицу прав не занесены, это означает, что этот пользователь не имеет прав на просмотр и модификацию. Таким образом, активизировать права "-R Запрещен просмотр", "-М Запрещена модификация" для всех пользователей, которым права просмотра и модификации запрещены, нет необходимости.

Чтобы назначить права группе пользователей, выберите ее имя в списке, расположенном с окне внизу справа и нажмите кнопку [image]. Имя группы пользователей переместится в верхнее окно, и Вы можете отметить галочками нужные виды прав ("Владелец", "Разрешен просмотр" и т. д.).

Чтобы удалить пользователя или группу из верхнего списка, нажмите кнопку [image].

Описанные выше действия нужно повторить необходимое число раз, после чего нажать кнопку Согласие. Для выхода из окна назначения прав без изменения установленных прав на объект(ы) нажмите кнопку Отказ.

Примечание

В некоторых случаях над кнопкой Согласие расположен переключатель, позволяющий "Установить" права (при этом все ранее существующие права на этот объект удаляются и вступают с силу вновь определенные Вами права) или "Добавить" (при этом определенные Вами права на объект добавляются к уже существующим).

Чтобы установить права на документы, выберите мышкой название документа в списке (рис. 3.1) и нажмите на кнопку [image]. Откроется диалоговое окно назначения прав (рис. 3.2). Вы можете назначить права сразу на несколько документов, выделив их клавишей Пробел или с помощью команд контекстного меню "Пометить", "Пометить все", "Снять все пометки".

Чтобы снять права на базу и документы, нажмите на кнопку [image]. Обратите внимание - из таблицы прав удаляются права на базу в целом и на ее документы одновременно. Если у Вас есть несколько Локальных баз, права будут сняты на все Локальные БД.


4. АДМИНИСТРИРОВАНИЕ КОРПОРАТИВНЫХ ПОРТФЕЛЕЙ

Использование Портфелей в системе ЛЗ позволяет создавать собственные аналитические подборки документов, а также накапливать и классифицировать разнородную информацию по желанию пользователя. В отличие от Личных портфелей, которые хранятся на компьютере пользователя, содержимое Корпоративных портфелей может быть доступно различным пользователям сетевой версии системы в соответствии с определенными правами доступа, так как Корпоративные портфели хранятся на сервере.

Основные возможности работы с Портфелями в целом описаны в Руководстве пользователя систем ЛЗ.

Система дает возможность создать Корпоративный портфель только в том случае, если пользователь имеет права на создание корпоративного типа Портфеля. Права Разрешено создавать Корпоративные портфели назначаются в программе Администратор системы ЛЗ в "Менеджере пользователей" на закладке "Права", рис. 4.1.

Рис. 4.1. Опция "Разрешено создавать Корпоративные портфели" в Менеджере пользователей

Администрирование Корпоративных портфелей выполняется в режиме, который вызывается одноименной кнопкой программы ЛІГА:Администратор.

Рис. 4.2. Окно администрирования Корпоративных портфелей

Активизировав мышкой название Портфеля или его раздела, рис. 4.2, можно назначать пользователям [image] Права на раздел или [image] Права на раздел с вложениями.

Основные команды администрирования всех портфелей расположены в контекстном меню Менеджера портфелей, которое можно вызвать щелчком правой кнопки мыши на пункте "Портфели" (рис. 4.3):

Рис. 4.3. Контекстное меню администрирования всех портфелей

Импортировать Портфель - команда предназначена для импорта Личных портфелей в Корпоративные. При вызове этой команды открывается окно выбора файла Портфеля для импорта. Импорт Портфелей из системы с другим номером электронного ключа невозможен (необходима их сертификация в OOO "ЛИГА ЗАКОН").

Подключить Портфель - команда предназначена для подключения/отключения Портфелей или Личных портфелей, перемещенных в каталог с Корпоративными портфелями вручную (файлы Корпоративных портфелей находятся в каталоге Liga\User и имеют формат имени файла LFld000x.fld). При вызове этой команды открывается окно выбора Портфеля для подключения (рис. 4.4). В окне отображается список портфелей с реквизитами (Файл портфеля, Название портфеля и Автор портфеля) для подключения. Подключение Портфелей из системы с другим номером электронного ключа невозможно (необходима их сертификация в OOO "ЛИГА ЗАКОН").

Рис. 4.4. Окно выбора Портфеля для подключения

Подключить Портфель из архива - команда предназначена для подключения из архивов отключенных Портфелей или из архивов Личных портфелей, перемещенных в каталог с Корпоративными портфелями вручную (файлы Корпоративных портфелей находятся в каталоге Liga\User и имеют формат имени файла LFld000x.fld). При вызове этой команды открывается окно выбора Портфеля для подключения (рис. 4.4). В окне отображается список Портфелей с реквизитами (Файл портфеля, Название портфеля и Автор портфеля) для подключения. После выбора Портфеля для подключения появляется окно со списком архивов этого Портфеля (рис. 4.5). Подключение из архивов отключенных Портфелей из системыс другим номером электронного ключа невозможно (необходима их сертификация в ООО "ЛИГА ЗАКОН").

Рис. 4.5. Окно выбора архива Портфеля для подключения

Удалить права на Портфели - команда предназначена для удаления прав доступа ко всем Портфелям.

Контекстное меню для Портфеля имеет несколько другой вид, рис. 4.6:

Рис. 4.6. Контекстное меню тома "Портфели"

Описание команд контекстного меню для работы с Портфелем:

Отключить Портфель - при выборе этой команды выбранный портфель удаляется из списка подключенных, но при этом файлы портфеля не удаляются и его можно потом подключить снова;

Удалить Портфель - Портфель физически удаляется из системы;

Сохранить в архиве - при выборе этой команды создается архив для выбранного портфеля;

Восстановить из архива - при выборе этой команды появляется окно со списком архивов для выбранного портфеля (рис. 4.5), в котором можно выбрать архив для восстановления или удалить его;

Права на раздел - команда предназначена для назначения прав доступа только к выбранному портфелю или разделу;

Права на раздел с вложениями - команда предназначена для назначения прав доступа к выбранному портфелю, а также его разделам или разделу с подразделами.

Права, реализованные для Корпоративных портфелей

На каждый Портфель (раздел), а также портфель с разделами могут быть назначены права "Владелец", "Разрешен просмотр", "Разрешена модификация".

При создании Портфеля (раздела) создатель автоматически становится его владельцем.

· "Владелец" Портфеля (раздела) имеет право создавать разделы, редактировать и удалять портфель (раздел) и назначать права на него;
· "Разрешен просмотр" - пользователь может только читать содержимое Портфеля;
· "Разрешена модификация" - пользователь может редактировать содержимое Портфеля, но не может удалить его целиком.

Запрещающие опции прав очевидны. Аналогично можно добавить группу пользователей из левого нижнего окна в общий список при помощи кнопки [image] и назначить права всей группе. Группы пользователей создаются в "Менеджере пользователей".

Удаление из общего списка осуществляется при помощи кнопки [image]. Чтобы подтвердить назначение прав, необходимо нажать мышкой кнопку Принять. Отказ от назначения - кнопка Отказ.

Права доступа в раздел Портфеля назначаются аналогично назначению прав доступа в Портфели, как было описано выше.

Удаление Корпоративных портфелей возможно только из программы Администратор системы ЛІГА:ЗАКОН.

Пользователь, выполнивший команду "Сделать Личный портфель Корпоративным", становится Владельцем этого Портфеля. По команде контекстного меню "Права" он может раздавать права доступа в Портфель и его отдельные разделы другим пользователям.

При публикации содержания Портфеля необходимо учитывать, что сохраненные в нем внутренние файлы будут доступны другим пользователям при наличии прав доступа всегда, а ссылки на внешние файлы будут работать только в том случае, если у другого пользователя, кроме прав доступа, будет полностью совпадать наименование пути к месту расположения файла на сетевом ресурсе и при наличии прав доступа к этому ресурсу, что обеспечивается Администратором локальной сети.